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1 Introduction

1.1 Product Description

Backup4all is an award-winning backup software for Windows. Backup4all protects your valuable
data from partial or total loss by automating backup tasks, password protecting and compressing
it  to  save  storage  space.  Using  Backup4all  you  can  easily  backup  to  any  local,  network  drive,
backup to FTP (with support for SSL encryption, proxy server, passive mode), SFTP backup to CD,
DVD or Blu-ray disc, or other removable media (such as USB or Firewire drives).

Backup4all  can backup open/locked files  (if  the files  are  located  on  local  partitions  on  Windows
XP/2003/Vista/Windows 7) and it  can perform full,  differential,  incremental  and mirror backups.
Once a backup is performed, you can see what files have been changed since the last backup or
you can read the statistics about the next backup execution. You can use the context menu from
the tree to run standard actions associated with the file type.

There is also the option to run predefined backups, such as My Documents, My Pictures, Internet
Explorer  Favorites,  Mozilla  FireFox  Profiles,  Mozilla  Thunderbird  or  Outlook  Express  emails  and
settings.

Backup4all  has  ZIP64  support  (can  create  backups  over  2  GB)  and  creates  standard  zip  files,
meaning  that  you  can  access  it  with  any  zip  compatible  utility.  Backup4all  also  allows  you  to
encrypt your backup using AES encryption (128/192/256-bit).
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Backup4all  keeps  track  of  file  versions.  You  can  easily  restore  any  version  of  files  or  a  whole
folder. You can filter files to be restored.
Backup4all  tests  the  backup  files  automatically  to  ensure  the  backup  is  safe  and  correctly
executed  (uses  CRC32).  You  can  also  enable  email  notifications  to  receive  an  email  in  case  of
success/error/warning.

Backup4all works with any drive letter, including mapped network drives and UNC paths. It comes
with its own built-in CD/DVD/Blu-ray burning support.
Backup4all  runs  on  Windows  2000  Server/2003/XP/Vista/Windows  7/Windows  2008  both  32-
bit/64-bit and offers multi language support.

 

1.2 System Requirements

To install Backup4all you need Windows 2000/XP/Server 2003/Vista/Windows 7 or Windows 2008
and at least 50 megabytes of free disk space. Installing additional language files may increase the
space requirements.
 
Because the application uses zip compression, additional disk space is needed for the temporary
directory. The amount of free space depends on the size of files to backup.
 
Note: Backup4all  can backup open files  only if  installed  on Windows XP,  Windows 2003 Server,
Windows Vista, Windows 7  or  Windows 2008 and if  the files  are on NTFS partitions.  Backup4all
works on Windows 2000 too but this feature will not be available on these systems.

1.3 Features Summary

Intuitive interface
The Brief View and Getting Started window allows you to easily define/run backup jobs or restore
backed up data. Switching to the Explore  View, you can see all  the files/folders that  are  in  the
backup job and the new files that will be stored at the next backup execution. You can sort and
search the file tree in Explore view. You can start this backup application at windows startup or
minimize it to the system tray. 
 
Backup locked or open files (XP/2003/Vista/Windows 7)
Backup4all uses the Volume Shadow Copy service that allows you to back up local open files from
NTFS  partitions  in  Windows  XP/2003/Vista/2008  Server.  Now  you  can  backup  your  emails  and
settings without closing Microsoft Outlook, Outlook Express or other email clients.
 
File and Folder Filters
Powerful file and folder filtering engine with lots of options to filter by attribute, size, date, name
and type). You can create filters using a combination of restrictions and you can define separate
filters for inclusion and exclusion. 
 
Predefined Filters
Filters can now be added through the Options window, and once you set some predefined filters
you can use them in any backup job. If you change the predefined filter at a later time, it will be
automatically modified on each backup job that uses it too.
   
Manage multiple backup jobs
This backup software allows defining multiple backup jobs and saving them for future use. On the
main form, you have an overview of all  defined backups organized in groups. Backup4all comes
with  several  predefined  backup  jobs:  "My  Documents",  "My  Pictures",  "Outlook  Express"  and
allows importing backup plugins for dozens of other applications.
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Email notifications
You can configure Backup4all to send custom emails after a backup finished, with success, error
and warning notifications. Additional options allow you to attach the backup log file and send the
email to several addresses.
 
Pause/Resume or Stop operation
The  backup  operation  now  supports  pausing  and  resuming,  so  running  a  backup  job  can  be
interrupted and continued at a later time. There is also a Stop operation now, that when pressed
will not Cancel the backup, but instead will save everything until that point when it was pressed.

Automatic updates
Backup4all can now check for updates either manually or automatically at a scheduled date. This
allows you to better stay in touch with the latest development of Backup4all.

Backup catalog file
Backup4all stores a summary snapshot of the file and folder information into a backup catalog file
(".bkc") each time a backup is executed. This catalog is stored in a different file than the backup
itself  and  it  allows  Backup4all  to  keep  track  of  the  backed  up  files.  The  advantage  of  using  a
catalog  is  faster  backup  execution.  Another  advantage  is  that  you  can  run  Backup4all  together
with other backup applications because they will not interfere with each other.
 
Backup directly to CD/DVD/Blu-ray
This backup software comes with  its  own built-in  CD/DVD/Blu-ray burning support.  Just set  the
destination  on  CD/DVD/Blu-ray  disc  and  execute  the  backup  job.  However,  you  can  use  UDF
format (using SPTD driver installed with Backup4all, or other products such as DirectCD or InCD)
or the Joliet format. Backup4all also has the possibility to erase CD-RW/DVD-RW/Blu-ray media.
 
FTP Backup
You can backup your files  to  remote  locations  using  the  FTP  service  (with  SSL  support,  active/
passive transfer modes, firewall support, XCRC tests). You just have to select FTP as destination,
enter the FTP configurations and you are ready to backup to FTP.

SFTP Backup
You can backup your files to remote locations using the SFTP service. Select SFTP as destination,
enter the configurations and you are ready to backup to SFTP.
 
Backup Destination
You can store the backup in a local folder, on another computer in the same LAN, on media such
as:  CD-R,  CD-RW, DVD+R,  DVD-R,  DVD+RW,  DVD-RW,  Blu-ray,  Blu-ray  RW,  on  USB drives  or
other removable media, on FTP or SFTP.

Extra Actions
Perform extra actions before and/or after backup execution.
 
Statistics
You can actually see the number of files that will be processed at next backup (very useful when
you have a large number of files). Other information refers to the size and date of the executed
backups and the available free space on storage destination.
 
Play custom sounds
Backup4all can play custom success/warning/error sounds at the end of the backup.
 
File warnings
File  warnings  are  displayed  to  the  user  during  backup  execution  if  the  user  chooses  so.  These
warnings are also  written  to  the  log  file.  Scheduled  backups  do  not  show these  warnings  even
when this option is set.
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New Backup Wizard
This backup software provides step-by-step instructions to create a new backup job by selecting
Where, What, How and When to backup.

Easy File and Folder Selection
You can browse a folder tree to select several files and folders as source of the backup or you can
include or exclude them individually. Multiple files/folders can be added as Sources at once (drag-
and-drop supported).
Backup Types
Different backup types to choose from: full  backup, differential backup, incremental backup and
mirror backup.
   
Standard Zip Compression and zip64 support
If  the  zip  file  size  is  less  than  2  Gbytes,  Backup4all  creates  standard  zip  files.  This  format  is
compatible with any zip utility available on the market. Unlike other backup softwares, for zip files
greater than 2 Gbytes, Backup4all uses zip64 technology (which allows unlimited zip file size).

Backup Plugins
Starting  with  version  3.10  is  possible  to  load  plugins  to  backup/restore  the  settings  of  specific
programs.  A  plugin  is  actually  an  XML  file  that  once  imported  in  Backup4all  adds  a  predefined
backup. For instance, a backup plugin for Mozilla FireFox, when loaded, will  automatically add in
the  Predefined  Backup  list  an  entry  for  Firefox,  so  when  defining  a  new  backup  job  if  that’s
selected, the FireFox profiles will be added as source for the new backup.

Customized Zip Names
You  can  customize  name  prefixes  for  the  zip  archives,  which  store  your  backup  versions.
Backup4all also supports file/folder paths longer than 260 characters (turn off file parsing).

Password Protection
You  can  protect  your  ZIP  files  by  setting  a  password  for  each  backup  job.  Besides  normal
password protection, Backup4all also supports 128-bit, 192-bit and 256-bit AES encryption. These
numbers reflect the encryption key size used to encrypt the data - a higher key strenght provides
stronger encryption.

Snapshots
Mirror backup type makes an exact copy of selected files and folders (copying NTFS permissions
and alternate streams), including empty folders too (for an exact copy of the source). Optionally,
for mirror backups you can choose to zip the backed up files individually.

Disk Spanning
Automated support for splitting your backup between many removable disks or even on the same
media. You can specify the maximum size of the zip archives. When performing a mirror backup
and using disk spanning you can choose not to split the files. This is an useful option because you
can copy your music/movies to CD, DVD or Blu-ray disc and not have them split up when the CD,
DVD or Blu-ray disc is full.

Logs
The  operations  performed  by  Backup4all  are  logged.  This  allows  you  to  see  the  status  of
performed operations (backup/test/cleanup/restore). 
 
Command Line
A  command  line  version  of  this  backup  application  is  available  too  (that  lets  you  run  different
operations using parameters).
 
Restore Wizard
Restore  backed  up  data  step-by-step.  Allows  you  to  choose  the  version  of  files  which  will  be
restored  and  filter  them  to  restore  only  the  needed  versions  (file  versioning  applies  to  full,
differential  and  incremental  backups  only).  You  can  quickly  restore  the  latest  version  of  a  file/
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folder as well as restoring versions of files backed up at a specific date.
 
Compatibility
You  can  restore  data  using  any  standard  zip  software.  Backup4all  gives  you  this  way  more
flexibility  if  you need to restore  data  on  a  different  computer  (if  the  backup  was  created  using
independent splits, see this section on how to restore correctly using 3rd party zip software).
 
One touch backup
Some USB enclosures have a button to start the execution of an associated program. If you have
such a device, you can configure Backup4all to execute a backup job or a backup group when this
button is pressed (works only with certain USB enclosures).
 
Summary
Text  description  of  the  full  setup  for  each  backup  job  that  allows  you  to  easily  review  the
information regarding the backup.
 
Program security
Backup4all offers an option to lock its interface so that when it  starts you will  need to provide a
password in order to unlock it and be able to make changes to its settings.
 
Test backup
The application tests the backups (using CRC32). This ensures that the files have been backed up
properly  and  the  backup  is  safe.  You  can  also  test  the  backup  integrity  at  a  later  time  from
Backup4all's  main  menu.  When backing  up  to  removable  media,  after  each  media  item written
the  backup  test  is  performed  (for  spanned  backups).  When  backing  up  to  FTP,  the  XCRC
command  can  be  used  (if  supported  by  server).  This  speeds  up  the  testing  as  Backup4all  will
verify the backup based on the CRC information received from server.

1.4 Feature Matrix

Backup4all comes in three* editions: Lite, Standard and Professional.

Professional  is  the  full  edition  with  all  features  enabled,  while  Standard  and  Lite  are  the
limited-functionality editions.
Below you can find a comparison of the features available in each edition.
*Backup4all  Portable  Edition  is  a  custom version  of  Backup4all  that  works  only  on  portable
devices.

Interface    

 Lite Standard Professional Portable
Edition

Start application at Windows startup

Minimize/close application to system tray

Browsable  file  and  folder  tree  of  the  backup
sources

Add sources with drag-drop

Backup View

Brief view

Backup statistics
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Backup summary

Lock program interface with a password

Show "Getting Started" window

Show versions in Explore View 

Search  as-you-type  for  backup  jobs/groups  in
backup list 

Show  History  window  with  backup/restore/test/
cleanup logs

Browsable  file  and  folder  tree  of  the  backup
contents

File finder in Explore view (by name)

Sort files in Explore view (by name, size or date)

Available space in destination on Statistics view

Multiple selection in Explore view

Manage multiple backup configurations

Group backup configurations

Create  desktop  shortcut  to  backup  jobs  and
backup groups

Predefined backups

Microsoft Outlook backup plugin

Resizable  windows.  Store  window  position  and
size

Resizable  columns.  Store  position,  size  and
visibility

Toggle toolbar buttons hints and captions

Show/hide main toolbar 

Visualization modes for application startup

Change background color option

"Show errors in tray" option

View jobs/groups as: Tree, Icons or List

Lock program interface with a password

MSI setup for automatic deployment 

Backup    

 Lite Standard Professional Portable
Edition

Backup open files (locked or in use)



Backup4all 414

Backup4all 4 User Manual Copyright © 2010 Softland

Backup wizard

Browsable file and folder selection

Select individual files and folders to be backed up

Inclusion and exclusion filters for files and folders

Create and use general predefined filters

Possibility to Pause/Resume or Stop the backup

Customize filters

AES encryption (128-bit, 192-bit and 256-bit)

Email notifications on success, errors, warnings

Built-in scheduler

Run program/action before and/or after backup

Run program/action only once

Run at system shutdown

"Clean backup" action with parameters

Clear backup before executing a scheduled job

Erase disc before backup

Use local catalogs

Play sound on success, warning, error

Assign volume labels for removable media

Assign label for each backup version

Set backup thread priority

One Touch Backup feature

Independent spanned backups

Back up empty folders

Delete Sources after successful backup

Create backup log

Create backup catalog file

Run backup at log on OR log off

Free Backup Plugins

Possibility to set memory usage for backing up

Plug-n-backup
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Backup types    

 Lite Standard Professional Portable
Edition

Mirror backup (without zip)

Mirror  backup  with  individual  file  archiving  (zip
format)

Full backup

Store multiple versions for full backup type

Differential backup

Store multiple versions for differential backup

Incremental backup

Store multiple versions for incremental backup

Limit number of backup versions

Backup format    

 Lite Standard Professional Portable
Edition

Compress backup files (zip format)

Support for zip64 technology

Choose zip compression level

Password protected zip files

Customize zip name prefix

Split zip files

One to one copy (mirror backup)

Custom  file  locations  (for  temporary,
initialization, log, catalog file folder)

Backup media    

 Lite Standard Professional Portable
Edition

Backup from/to local hard drives

Backup from network drives

Backup to network drives

Backup from/to external hard drives

Backup  to  FTP  (SSL  support,  active/passive
transfer modes, firewall support)

Backup to SFTP

Backup from/to ZIP drives
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Backup from/to removable media

Backup  from/to  CD,  DVD  or  Blu-ray  disc  (using
UDF drivers)

Backup  from/to  CD,  DVD  or  Blu-ray  disc  (using
built-in burner)

Backup execution    

 Lite Standard Professional Portable
Edition

Show backup progress

Execute all backup configurations in a group

Perform  unattended  backups  using  built-in
schedulers

Perform unattended backups using built Windows
scheduler

Command line

Test    

 Lite Standard Professional Portable
Edition

Test backups (uses CRC32)

Test FTP backups (uses XCRC)

Test after backup option

Set test thread priority

Backup test performed after writing each disc

Delete Sources after successful backup

Create test log

Restore    

 Lite Standard Professional Portable
Edition

Restore wizard

Restore specific backup increments
 

Filter files to restore

Restore all files as of specific date

Restore to different folder

Restore selected file

Restore selected version of a file
 

Restore selected folder

Restore preview
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Set restore thread priority

Create restore log

Languages    

 Lite Standard Professional Portable
Edition

Multi-language support

Legend    

"New" means the feature is new and is available only from Backup4all 4

"Yes" means the feature was already available in previous Backup4all versions
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2 Getting Started

2.1 How to Configure a New Backup?

To create a new backup job, click on the New Backup Wizard toolbar button ( ). For each
backup job you must specify  at  least  its  name,  a valid  storage  destination  and  the  source  files
(first  two  steps  of  this  wizard),  the  rest  of  the  options  not  being  mandatory.  In  New  Backup
Wizard, you can switch anytime to Advanced mode for more configuration options.
 
These are the steps you must perform in the New Backup Wizard:

1) Enter the name of the backup in the Backup name field and select a location where you
want to save the backup. You can choose as destination:

· your local hard drive (Local)
· a network computer (LAN)
· an FTP location (FTP) 
· an SFTP location (SFTP) 

 
Click Next to go to the following step.

2)  Select  the  files  and  folders  you  want  to  backup  (sources  of  the  backup)  or  choose  a
predefined backup from the drop down list and click Next.
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3) Select how do you want to backup.  By default,  the Make incremental  option  is  selected.
You can also use encryption for the backup types that creates zip files. 
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Backup4all  provides extended information about the backup, which  can be  consulted before the
backup execution. You can switch between views by selecting one of the available views from the
drop down list:

· Brief  -  shows  basic  information  about  the  backup  job  and  the  buttons  for  backup  and
restore

· Explore - shows the source files and folders for the backup job
· Backup - shows the list of backup executions with the sources status before each execution
· Statistics - shows statistics about the latest backup and the next backup job
· Summary - shows configuration information about the backup

   
The  wizard  creates  an  ".ini"  file  in  the  IniFiles  folder  (usually  in  C:\Documents  and
Settings\<user>\Application  Data\Softland\Backup4all  4\)  with  the  same  name  as  the  backup
job. In addition, a backup catalog file (".bkc") is created both in the destination and locally in the
BkcFiles folder (same directory where the IniFiles folder is created).
 
Manually modifying ".bkc" or ".ini" files may result in corrupted backup jobs and the impossibility
of restoring the data you backed up. A backup job is automatically created when double clicking
on a ".bkc" file. You can also recreate the backup job by opening a ".bkc" or  ".ini"  file  from the
File->Open Backup menu.
 
Once  the  backup  job  is  created,  it  will  be  displayed  on  the  left  side  of  the  application's  main
window. On the right, you will see the content of the backup job (files and folders), depending on
the chosen view (brief, explore, backup, statistics or summary).
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2.2 How to Run a Backup Job?

To start a backup click the Backup button ( ) from the application's toolbar or press F6.

During  the  execution  of  the  backup,  you  will  see  a  Backup  image  appear  in  front  of  the  icon
chosen for  the backup job.  If  the  backup  is  finished  successfully  (without  errors  and  warnings)
this image will disappear restoring the initial view of the backup jobs' icon.

If one or more files could not be backed up (not enough user rights etc.), then the Warning icon
appears in front of the default backup job icon, after the backup finished. Read the log files (from
View->Job Logs->Last Backup log)  for  details  about  the files  that  were not backed up.  The
Warning icon will disappear when the backup is executed again and all files were backed up.

If an error occurred during backup and the backup was aborted, the Error icon appears in front of
the backup job. Read the log files (from View->Job Logs->Last Backup log) for details about
the  errors.  The  icon  will  disappear  when  the  backup  is  executed  again  and  the  execution  is
successful.

 

2.3 How to Manage Backup Jobs?

Copy an Existing Backup Configuration

You can  use  the  Create  Like  (Ctrl+L)  option  from  the  File  menu  to  create  a  duplicate  of  the
selected backup job and after that you can easily modify its configuration. This option can also be
selected from the right-click menu of the backup job.
 
 
Modify a Backup Job Configuration

First you must select the backup job you wish to modify. Then press the Properties button (
)  from  the  application's  toolbar.  This  will  open  the  Backup  Properties  window.  You  can  also
change  its  configuration  by  choosing  Properties  from  the  right-click  menu  of  the  backup  job.
After the Properties window is opened, go to the page with the settings you want to modify.
 
 
Delete a Backup Job

Select the backup job you want to delete and select Delete Backup option from the File menu.
Another possibility is to choose Delete from the right-click menu of the backup job. 
Files and folders from the source and destination will not be deleted, by any of these operations.

2.4 How to Restore from a Backup?

With Backup4all you can do the following restore operations:
· restore the latest version of all files
· restore all files as they were on a specified date
· filtered restore
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· restore all files from a folder
· restore the latest version of a particular file
· restore the latest version of multiple selected files
· restore any version of a particular file

To make a full or a filtered restore start the Restore Wizard by pressing the Restore button (

)  from  the  application's  toolbar.  You  can  restore  to  the  original  location  or  to  a  different
location of your choice.
 
You  can  restore  the  latest  version  of  a  file,  several  selected  files  or  all  files  from  a  folder  by
selecting the files or folder in the Explore View, right-click and select Restore Latest Version
or Restore Latest Version To...

If you want to restore a particular file version, switch to the Explore View,  select the targeted
file in the tree, right-click on a file version from the bottom list and choose Restore or Restore
to...

Beside  files,  folder  information  is  also  added  to  backup,  so  a  restore  process  can  recreate  the
original folder structure.
 

2.5 How to Test a Backup?

With Backup4all you can:
· test one or more versions of a backup (you can select any version for testing)
· automatically test latest version of a backup at each backup job execution

To test a selection or all the versions for the selected backup job, open the Test Backup window
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by pressing the Test button ( ) from the application's toolbar (or using the keyboard shortcut
 F9). 

In the test window, select the backup versions you wish to test and press the Test button. You
can also modify the priority of the test process by moving the slider to a lower or higher priority
(default is Normal). A High priority process finishes faster but consumes more resources than a
Normal priority process.

You can also test a backup execution if you switch to Backup View, right-click on a version and
select Test.
While performing the operation, a Test icon appears in front of the icon of the backup job being
tested.

To  be  sure  the  test  automatically  runs  after  each  backup,  you  should  open  the  Backup

Properties window by pressing the Properties button ( ) from the application's toolbar and
in the Advanced tab make sure the Test after backup option is checked.
 
If the test was executed automatically after backup and it failed, the Error icon appears in front
of the backup job icon.  Read  the  log  file  for  details  about  the  errors  (View->Job Logs->Last
Test log). The icon will disappear when the backup job will be successful.
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2.6 How to Password Protect a Backup?

Passwords are used to protect your backup files from unauthorized access.
 
Setting the Password
 
The Encryption Settings window is shown in the Compression page under the Type section of
the Backup Properties window or in the New Backup Wizard. The button is available only for
full,  incremental,  differential  and  mirror  with  zip  backup  types  (not  available  for  mirror  without
zip).
 
By default the No encryption option is selected.
If you want to protect your backup, you can choose the type of the encryption to be used.
The  Zip(2)  compatible  encryption  offers  moderate  security  but  is  compatible  with  all  third
party zip applications.
 
The  best  choice  is  the  AES  encryption  which  is  the  new  standard  in  ZIP  protection,  but  is
recognized  only  by  the  latest  version  of  third  party  zip  applications  (like  Winzip  or  PKWare).
Backup4all  supports AES encryption in 3 different key strengths: 128-bit, 192-bit and 256-bit.
These numbers reflect the size of the encryption keys used to protect the data - the higher the
number  the stronger  the  encryption.  All  three  types  provide  higher  security  than  the  password
protection method.
When choosing a password, it is recommended that you use a combination of letters and numbers
and at least a 6 character long password.
 
You  should  manually  enter  the  password  in  the  New  password  field  and  re-enter  it  in  the
Confirm new password field to avoid typing errors.
The Old password  field is enabled only when the backup job already has a password. You can
change the password only if you enter the old one in this field.
This way only the owner of the backup will be allowed to change the password.

The system makes it possible to set different passwords for the same backup job, so the backup
may contain zip files with different passwords. Backup4all does not store passwords.  Make sure
that you remember all passwords that have been used for a backup job, or you will not be able to
restore your files.

How to Remove the Password?
 
In the Backup Properties->Compression page, go to Encrypt the zip file section, select the
No Encryption  option  and  enter  the  password  that  you  used  in  the  Old  password  field.  You
cannot remove the password if you don't provide the old one.
If you have the Zip(2) compatible encryption or AES encryption option selected, you can also
remove  the  password  by  entering  the  Old  password  and  leave  the  New  password  and
Confirm new password fields empty.
 
 
Using Passwords when Restoring
 
During the restore process of backups with password protection, the Enter Password dialog will
appear.  Enter  the  password  and  press  OK.  If  you  do  not  know  the  password  for  this  backup
number you can:

· press Skip backup to go to the next archive - the restore may be incomplete in this case.
· press  Stop  restore  to  stop  the  whole  process  -  the  restore  will  be  incomplete,  because

only a part of the files were restored.
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2.7 How to Backup to FTP?

Backup4all supports backing up to a remote computer or device using FTP (File Transfer Protocol)
connection.  This  is  a  practical  backup  destination  because  the  backed  up  data  can  be  easily
accessed from any other computer with an Internet connection.

Defining FTP configuration
 
Before using FTP as a destination for backing up, you should define a new FTP configuration using
the Tools->Options->FTP window. Once defined, you will be able to apply this FTP configuration
to individual backup jobs.
Press the Add  button once in  Tools->Options->FTP  to add  a new FTP  connection .  The New
FTP  configuration  name  will  appear  in  the  list  and  you  can  enter  the  other  settings  for  this
connection:

· Configuration name - Enter here an arbitrary name for the connection.
· Server name or IP  -  In this field you have to enter  the name or  IP address for  the FTP

server
· Port - In this field you have to enter the port number if different than the default FTP ports

(21).
· Destination folder - Here you can enter the destination path if different than root.
· User name - If this is a private FTP server (no anonymous access allowed) enter the user

name for your account.
· Password - In this field enter the password for the FTP server.

There  are  FTP  servers  that  allow  anonymous  access  (public  FTP  servers).  You  can  connect  to
these types of FTP servers using as user name Anonymous and your email address as password.
It is not recommended to backup important files to public FTP servers.
In the When destination server is  not ready  section you can enter  the number of  attempts
and time between those attempts to connect to the FTP server. By default, if the FTP server is not
reachable, Backup4all will try 3 times at a 5 seconds delay before aborting the backup. You can
increase or decrease these values using the Retry and wait fields.
Additional  settings like bandwidth,  SSL connection and firewall  can also be  configured from this
page.
 
Once you have finished defining the connection, press the Test button to check if the FTP details
you  have  entered  are  correct.  If  the  test  was  successful,  The  ftp  connection  was  tested
successfully message will be displayed.
 
 
Setting the destination to FTP
 
When defining a new backup job using the New Backup Wizard, select the FTP option in the d
estination section (1st page of the wizard). If you already have a backup job defined and want to
change the destination to FTP, select that backup job, open the Properties window (Ctrl+P), go
to the Destination page and select FTP server. After that, go to FTP server page and specify
an existing FTP configuration or create a new one.
 
From the  Use  existing  configuration  select  an  already  defined  FTP  configuration  (given  that
you  added  one  in  the  Tools->Options->FTP  window).  The  description  of  the  selected  FTP
configuration will be listed bellow.
You can change the defined settings by selecting the Custom configuration option and pressing
the Edit configuration button. Here you can modify the data in the fields and press OK to save.
However, if you do changes, it is recommended to use the Test FTP connection button to see if
the FTP settings are correct.
Once you press the OK button, Backup4all will try to connect to the FTP server to see if a backup
catalog  already  exists  on  the  destination.  If  the  FTP  destination  is  not  available,  a  Cannot
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connect to the FTP server message is displayed in the status bar (bottom of the main window).
In  the  Tools->Options->Backup  window  you  can  set  the  number  of  retries  and  the  time
between  the  retries  when  the  FTP  server  is  unavailable  (the  When  destination  not  ready
section).
 
 
Recommendations for backing up to FTP

1) After each change to the FTP configuration be sure to use the Test function.
2)  Most  FTP  sites  have  policies  against  hammering  (trying  repeatedly  to  connect  to  an
unavailable FTP server with little or no time between connection attempts). Thus they require
FTP clients to set  retry  times at  specific  intervals,  commonly  at  least  120  seconds  between
each attempt to connect. Most FTP sites can also monitor for devices that hammer, and once
detected the server will  ban access to the offending IP address either permanently or  for  a
limited  amount  of  time.  Thus,  when  you  set  the  retry  times  intervals  in  Tools->Options-
>FTP, you should use 60 seconds or more.
3)  If  you  backup  important  data  to  a  remote  location  using  FTP,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access
to the FTP, your files will still be protected.
4) Use XCRC when testing the FTP backups (faster) 

 

2.7.1 Connecting in Passive Mode

Some FTP servers require the connection to be established in a passive mode (i.e. your computer
establishes the connection so the flow of data is set up and initiated by you).
Most  Web  browsers  (which  act  as  FTP  clients)  use  passive  FTP  by  default  because  companies
prefer  it  as  a safety measure. So  switching  to  passive  mode  may  be  necessary  with  some  FTP
servers that are behind firewalls that do not allow connections from outside.
 
To set Backup4all to connect using Passive mode:

1)  On  the  Destination->FTP  server  window  (or  Tools->Options->FTP)  click  Edit
configuration
2) Check the Use passive mode for transfers (like WWW browsers) option
3) Press OK

After that use the Test FTP connection button to see if the FTP connection works.
 

2.7.2 Connecting Through Proxy

If  you  are  connecting  to  the  Internet  through  a  proxy  server,  you  will  have  to  enter  the
connection details in the FTP Configuration window in order to be able to backup to FTP.
 
Setting Backup4all to backup to FTP using proxy

1) Go to Backup Properties->Destination->FTP server->Edit configuration (or Tools-
>Options->FTP->Edit)
2) Select a Proxy Type from the available options:

· None - Sends the User name and optional Password for the FTP server as entered in
the FTP window

· Send command USER - Sends the User name and optional Password defined in the
proxy settings,  followed  immediately  by  the  User  name  and  optional  Password  for
the FTP server.

· Send command SITE - Sends the User name and optional Password defined in the
proxy  settings,  the  SITE  command  with  the  Host  value,  and  the  User  name  and
optional Password for the FTP site.

· Send command OPEN -   Sends the User  name  and optional  Password  defined in
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the  proxy  settings,  sends  the  OPEN  command  with  the  Host  value,  and  the  User
name and optional Password for the FTP site.

· USER  user@firewalluser@hostname  /  PASS  pass@firewallpass  -  Sends  the
command USER user@proxyuser@host, then the command PASS pwd@proxypwd
, or optionally PASS pwd.

· Transparent -  Sends the User name and optional Password defined in the  proxy
settings, followed immediately by the FTP server User name and optional Password.

3) Enter the name or IP address for the proxy server (firewall) in the Host name or IP field. 
4) Enter the port number in the Host Port field. 
5) Enter the user  name and password  needed for  this  proxy  connection  in  the  User  name
and Password fields. 
6) Press OK and then test the connection.

 

2.7.3 Using SSL Encryption

When you connect through FTP to a remote computer  you send the username and password  in
clear, unencrypted text. Also, when you backup your files to a remote computer, the information
is not sent directly to that computer. Instead it is routed through several other computers to get
there.  Anyone  along  the  route  can  access  what  you  are  sending,  including  your  username  and
password, if the data is not encrypted. If  an unauthorized person has access to this  data, your
account and the remote system you have access to, may no longer be secure. Backup4all solves
this by allowing SSL encryption support when using FTP (and also AES encryption for the backed
up zip files).
 
SSL  (Secure  Sockets  Layer)  is  a  protocol  used  for  transmitting  private  documents  via  the
Internet.  SSL  uses  a  cryptographic  system that  uses  two  keys  to  encrypt  data  -  a  public  key
known to everyone and a private or secret key known only to the recipient of the message.
 
 
Backing up to FTP using SSL encryption

1)  In  Backup  Properties->Destination->FTP  server->Custom  configuration.  (or  the
Tools->Options->FTP window)
2) From the SSL encryption level box select an option that applies to your situation:

· No SSL - the server does not require Secure Socket Layer transport
· Implicit SSL - implies that Secure Socket Layer is in use
· Only explicit SSL - allows the connection to the FTP server only if SSL is available.
· Explicit SSL,  if  available  -  When SSL is  available,  uses  explicit  security  by  default.

The  server  allows  regular  FTP  sessions  without  encryption  as  well  as  encrypted  FTP
sessions using SSL.

3) Press OK and test your connection
 

2.8 How to Backup to SFTP?

Backup4all  supports  backing up to a remote  computer  or  device  using  SFTP  (SSH File  Transfer
Protocol) connection. This is also practical backup destination because the backed up data can be
easily accessed from any other computer with an Internet connection.

Defining SFTP configuration
 
Before using SFTP  as a destination for  backing up,  you should define a new SFTP  configuration
using  the  Tools->Options->SFTP  window.  Once  defined,  you  will  be  able  to  apply  this  SFTP
configuration to individual backup jobs.

Press the Add button once in Tools->Options->SFTP to add a new FTP connection . The New
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SFTP configuration  name will  appear in  the  list  and  you  can  enter  the  other  settings  for  this
connection:

· Configuration name - Enter here an arbitrary name for the connection.
· Server name or IP - In this field you have to enter the name or IP address for the SFTP

server
· Port  -  In  this  field  you  have  to  enter  the  port  number  if  different  than  the  default  SFTP

ports (22).
· Destination folder - Here you can enter the destination path if different than root.
· User name - If this is a private SFTP server (no anonymous access allowed) enter the user

name for your account.
· Password - In this field enter the password for the SFTP server.

In the When destination server is  not ready  section you can enter  the number of  attempts
and time between those attempts to connect to the FTP server. By default, if the FTP server is not
reachable, Backup4all will try 3 times at a 5 seconds delay before aborting the backup. You can
increase or decrease these values using the Retry and wait fields.
Additional  settings  like  private  key,  bandwidth  limitation,  authentications,  encryption  and
compression can also be configured from this page.  
 
Once you have finished defining the connection, press the Test button to check if the SFTP details
you  have  entered  are  correct.  If  the  test  was  successful,  The  sftp  connection  was  tested
successfully message will be displayed.

 
Setting the destination to SFTP
 
When defining a new backup job using the New Backup Wizard, select the SFTP option in the d
estination section (1st page of the wizard). If you already have a backup job defined and want to
change the destination to SFTP, select that backup job, open the Properties window (Ctrl+P), go
to  the  Destination  page  and  select  SFTP  server.  After  that,  go  to  SFTP  server  page  and
specify an existing SFTP configuration or create a new one.

From the Use existing configuration select  an already defined SFTP  configuration (given that
you  added  one  in  the  Tools->Options->SFTP  window).  The  description  of  the  selected  SFTP
configuration will be listed bellow.

You can change the defined settings by selecting the Custom configuration option and pressing
the Edit configuration button. Here you can modify the data in the fields and press OK to save.
However, if you do changes, it is recommended to use the Test SFTP connection button to see
if the SFTP settings are correct.

Once  you  press  the  OK  button,  Backup4all  will  try  to  connect  to  the  SFTP  server  to  see  if  a
backup  catalog  already  exists  on  the  destination.  If  the  SFTP  destination  is  not  available,  a
Cannot connect to the SFTP server message is displayed in the status bar (bottom of the main
window).

In  the  Tools->Options->Backup  window  you  can  set  the  number  of  retries  and  the  time
between  the  retries  when  the  SFTP  server  is  unavailable  (the  When  destination  not  ready
section).

 
Recommendations for backing up to SFTP 

1) After each change to the SFTP configuration be sure to use the Test function.
2)  Most  SFTP  sites  have  policies  against  hammering  (trying  repeatedly  to  connect  to  an
unavailable  SFTP  server  with  little  or  no  time  between  connection  attempts).  Thus  they
require  SFTP  clients to set  retry  times at  specific  intervals,  commonly  at  least  120  seconds
between each attempt to connect. Most SFTP sites can also monitor for devices that hammer,
and once detected the server will ban access to the offending IP address either permanently
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or  for  a  limited  amount  of  time.  Thus,  when  you  set  the  retry  times  intervals  in  Tools-
>Options->SFTP, you should use 60 seconds or more.
3)  If  you  backup  important  data  to  a  remote  location  using  SFTP,  encrypt  the  zip  files  for
increased security. In this case, even if another person manages to gain unauthorized access
to the SFTP, your files will still be protected.

2.9 How to Backup to USB or Firewire drives?

You can backup your data to an USB or  Firewire  drive  and from an USB or  Firewire  drive  using
Backup4all.  This  is  a  practical  backup  destination  as  it  allows  you  to  store  important  files  to
external  devices,  offering increased portability.  It  can be  considered as an additional  protection
against data loss as the result of hardware failure or other disasters.

There  are  external  USB  hard  drives  with  performance  comparable  to  conventional  hard  drives.
These portable drives (called enclosures) are composed of devices that connect through USB on
one  side  and  to  conventional  hard  drives  on  the  other  side.  A  hard  drive  is  installed  into  the
enclosure  and  then  the  enclosure  is  plugged  into  the  computer,  thus  creating  a  normal  USB
backup device.  Given the size of  nowadays hard drives, this  can be  considered a mass  storage
device for backup purposes.

There are external hard drives that beside the USB technology use also Firewire as a connection
port. On one side Firewire hard drives tend to have increased speed over USB, but on the other
side USB ports are more common on computers.

Steps in backing up to USB drive with Backup4all:

1) Start your USB device. Before starting the backup process make sure that the USB drive
is  started  and  working.  Usually  the  enclosure  should  have  a  start  button  and  display  the
status of the drive using led displays. When it is started a green led should be lighted.
2) Make sure your drive is formatted. If you have just purchased the drive and didn’t use
it yet, you might have to format it (only if you didn’t use it before, since formatting will erase
everything from it). Formatting the USB drive in Windows Vista:

· Go  to  Start->Settings->Control  panel->System  and  Maintenance->Administrative
Tools->Computer Management

If you are prompted for an administrator password or confirmation, type the password or
provide confirmation.
· Under Storage click Disk Management
· To format  the volume with  the default  settings,  in  the  Format  dialog  box,  click  OK,

and then click OK again.
· Test  to  see  if  the  drive  is  now  recognized  by  going  to  Windows  Explorer  (a  new

drive letter should appear)
3)  Configure  Backup4all.  If  the  drive  is  formatted  and  recognized  by  Windows,  it  will  be
recognized by Backup4all too. Now, to backup to the USB drive you should define a backup
job in Backup4all that has the destination set to the USB drive. To ensure this, please select
the  backup  job  you  want  to  run,  press  CTRL+P  in  order  to  open  the  Backup  Properties
window and select the USB and Firewire page under Destination.  Select a drive from the
External hard drive drop down list. You can also define a new backup job and in the "Where
do you want to save your backup" section, select the USB drive.

 
Some USB drives have a button to start the execution of an associated program. If you have such
a  device  you  can  configure  Backup4all  to  execute  a  backup  job  or  a  backup  group  when  the
button is pressed. After the USB drive is ready, go to the Tools->Options  menu of Backup4all,
select  Backup on demand and press Detect  to check if  the  USB drive  is  compatible  with  the
One Touch Backup feature of Backup4all.
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2.10 How to Send Email Notifications?

Send Email notifications is a very useful feature that enables Backup4all to send an email with
information about the status of the performed backup job upon its completion.

Enabling email notifications

1) Open Tools->Options->Email 
2) Check the Enable email notifications box
3) Enter the following details:

· SMTP Server  -  specify the name or IP address of the SMTP server used  for  sending
the  mail  (example:  smtp.novapdf.com)  in  the  Server  name  or  IP  field  and  a  Port
number for it (usually is 25); you can also use Secure Socket Layer when connecting
to the SMTP server.

· Email addresses - you must specify the email address used to send the email (From
field) and optionally a Reply To email address

· Authentication  -  if  the  SMTP  server  requires  authentication  check  the  Server
requires authentication box and enter an user name and a password.

· Dial-up connection - if you are using a dial-up connection select from the drop-down
box  a  method  that  Backup4all  should  use  to  be  able  to  send  emails:  automatically
connect  (it  will  connect  without  user  assistance)  or  manually  connect  (it  will  require
user assistance to enable the connection).

4) Click  on the Send test email  button from the SMTP Server  section and enter  the  email
address where you want to receive the notification. Once you press OK you should receive a
test email. If you didn't receive it, you must revise the settings you configured.
5) Press OK to save your settings

Sending email notifications
 
You  have  to  enable  separately  for  each  backup  job  the  option  to  send  emails.  To  do  so  follow
these steps:

1)  Select  a  backup  job  and  open  the  Backup  Properties  window  (right  click  and  select
Properties or Ctrl+P)
2) Go to the Email page and check the Enable email notifications option.
3) Optionally  you can edit  the default  emails sent  and also to attach the  backup  log  to  the
email
4) Press OK to save your changes.

 

2.11 How to Configure One Touch Backup?

Some USB enclosures have a button to start the execution of an associated program. If you have
such a device, you can configure Backup4all to execute a backup job or a backup group when this
button is pressed. If your One Touch Backup device is not detected by Backup4all (Backup4all is
not natively compatible with the device), you could use the command line parameters to create a
command that can be associated to the One Touch button of your device. 
  
If the One Touch Backup option is enabled when the application starts and there is no backup job
or backup group set to be executed when the One Touch button of the USB enclosure is pressed,
the user will be asked to choose one from the options displayed in the One Touch Backup dialog:

· Create  a  new  backup  job  for  One  Touch  Backup.  If  you  select  this,  the  New  Backup
Wizard  will  start  and you can create a new backup  job  to  be  used  with  the  One  Touch
Backup feature

· Select an existing backup job or backup group for One Touch Backup.  If  you select this,
the  Backup  on  demand  page  of  the  Options  window  will  open  and  you  can  select  the
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backup job or group you want to use. This option is disabled when there is no backup job to
select.

· Disable this feature (you can activate it  back at any time from Options). This  will  disable
the One Touch Backup  feature. You can activate it  again from the  Backup on demand
page of the Options window.

If you press Cancel, Backup4all will open, but when you will press the One Touch button of the
USB  device  the  same  dialog  will  be  displayed.  This  dialog  will  appear  again  if  the  backup  job
(executed when the One Touch button is pressed) was deleted.

 

2.12 How to Use One Touch Backup?

You enable the One Touch Backup support from Options->Backup on demand page. At first
run there is no backup job configured to execute when the One Touch button is pressed, so you
will have to configure it as explained in the How to Configure One Touch Backup? tutorial.
 
Once everything is configured, you will just have to push the One Touch button and the selected
backup job or backup group will be executed.
 
If Backup4all is not started, it will start automatically. If it is already started, but minimized it will
show a pop-up window or the main window while backing up (depending on the settings from the
Options window).
 
When the backup finishes Backup4all is minimized, if the Hide when finished option is checked.
If the main window of the application was already open when the One Touch button was pressed,
the Hide when finished option will be ignored.

 

2.13 How to Enable Detailed Logging?

Backup4all allows you to log detailed information about the operations executed (backup, restore
or test). Practically, this means that beside the warnings and errors, the log file will contain
detailed information about all files handled by the backup, restore or test process.
 
To enable detailed logging:

1) Go to Tools menu and open the Options window
2) Switch to the Logs and history page
3) Check the Log detailed information option
4)  Check  the   Include  summary  in  log  option  (this  will  include  in  the  log  file  all  the
information available from the Summary view)
5) Additionally  you can limit  the size of  the log  folder  too.  Just  select  in  the  Restricted  to
section the maximum values you want to allow the log folder to grow to.
6) From the Log Viewer section, you can change the program to open the log files. From the
drop  down  list  you  can  select  Notepad  or  Wordpad.  You  can  also  browse  the  computer  to
select another text editor.
7) From the log file extension list, you can select the extension of the generated log file: .log
or .txt
8) Click OK to close the window and save the changes
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3 Backup Types

3.1 Backup Types

Backup4all  stores a summary snapshot of the file information into a backup catalog file  (".bkc")
each time a backup is executed. For every file backed up,  the snapshot  contains the file  name,
size and attributes as well as the date and time of creation, latest modification and latest access.

Legacy  backup  applications  inspect  each  file's  archive  flag  to  identify  which  files  have  been
changed. Backup4all will not interfere with any other backup software, because it  does not read
or change the archive flag, it uses the catalog file to decide which files have to be backed up and
which not.
Backup4all  implements  all  four  fundamental  backup  types:  full  backup,  differential  backup,
incremental backup and mirror backup. Below you can find an overview of these types.
 

Full Backup

Full backup is the starting point for all other backups and contains all the data in the folders and
files that are selected to be backed up. Because full  backup stores all  files and folders, frequent
full  backups  result  in  faster  and  simpler  restore  operations.  Remember  that  when  you  choose
other backup types, restore jobs may take longer.
 

Differential Backup

A differential backup contains all files that have changed since the last full backup. The advantage
of  a  differential  backup  is  that  it  shortens  restore  time  compared  to  an  incremental  backup.
However, if you perform the differential backup too many times, the size of the differential backup
might grow to be larger than the baseline full backup.
 

Incremental Backup

An  incremental  backup  stores  all  files  that  have  changed  since  the  last  full,  differential  or
incremental  backup.  The advantage  of  an  incremental  backup  is  that  it  takes  the  least  time  to
complete.  However,  during  a  restore  operation,  each  incremental  backup  must  be  processed,
which could result in a lengthy restore job.
 

Mirror Backup

A mirror backup is identical to a full backup, with the exception that the files are not compressed
in  zip  files  and  they  cannot  be  protected  with  a  password.  A  mirror  backup  is  most  frequently
used to create an exact copy of the backup data. It has the benefit that the backup files can also
be readily accessed using tools like Windows Explorer.
Using  the  mirror  backup  type,  you  can  also  choose  to  zip  each  file  individually,  preserving  the
folder structure. This allows you to use the zip compression and encryption features.
 
 
Save storage space

In  Backup4all  you  have  two options  for  saving  the  storage  space.  You  can  use  the  Yes,  limit
number of file versions and Yes, limit maximum number of stored backups to options to
reduce  the  backup  size.  When  you  limit  the  number  of  backups,  you  can  also  use  the  Merge
backups  option  to  perform  an  internal  merge  operation  between  backups  to  maintain  the
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maximum limit. These options can be used only for Full, Differential and Incremental backup type.
 

3.2 Full Backup

What is Full Backup?

Full backup is the starting point for all other backups, and contains all the data in the folders and
files  that  are  selected  to  be  backed  up.  Because  the  full  backup  stores  all  files  and  folders,
frequent  full  backups  result  in  faster  and simpler  restore operations.  Remember  that  when  you
choose other backup types, restore jobs may take longer.
 

Description of the Full Backup Type
 
It would be ideal to make full backups all the time, because they are the most comprehensive and
are  self-contained.  However,  the amount of  time it  takes  to  run  full  backups  often  prevents  us
from using this backup type. Full backups are often restricted to a weekly or  monthly schedule,
although the increasing speed and capacity of backup media is making overnight  full  backups  a
more realistic proposition.
 
Full backups, if you have the time to perform them, offer the best solution in data protection. In
effect, a single backup can provide the ability to completely restore all backed-up files.
 
However, you should be aware of a significant security issue. Each full backup contains an entire
copy of the data. If the backup media were to be illegally accessed or stolen, the hacker or thief
would then have access to an entire copy of your data.
 
Advantages

· Restore is the fastest

Disadvantages
· Backing up is the slowest
· The  storage  space  requirements  are  the  highest  (compared  to  incremental  or  differential

backups) 
 

Full Backup Type in Backup4all
 
Backup4all supports the full backup type and offers a solution for the storage space requirement
issue. You can use the Yes, limit number of file versions and Yes, limit number of backups
options to reduce the backup size. The output of a full backup is a container file, which is created
with zip compression.  You can select  the zip compression ratio  from the Compression  page in
Backup Properties. Backup4all also offers an option to encrypt your backup. This gives you the
option to protect your important backed up data in case a backup got lost or stolen.

 

3.3 Differential Backup

What is Differential Backup?
 
A differential backup contains all files that have changed since the last full backup. The advantage
of  a  differential  backup  is  that  it  shortens  restore  time  compared  to  a  full  backup  or  an
incremental backup. However, if you perform the differential backup too many times, the size of
the differential backup might grow to be larger than the baseline full backup.
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Description of the Differential Backup Type
 
There is a significant, but sometimes confusing, distinction between differential  and incremental
backup.
Incremental  backup  stores  all  the  new and  modified  files  since  the  last  full,  differential  or
incremental backup.
Differential backup offers a middle ground by  backing up all  the new and modified  files  since
the last full backup. That is where it gets its name: it backs up everything that's different since
the last full backup.
 
Restoring a differential backup is a faster process than restoring an incremental backup because
only  two  backup  container  files  are  needed:  the  latest  full  backup  and  the  latest  differential
backup.
 
Backup4all uses the information it has recorded in its catalog file (".bkc") to determine whether a
file has changed since the last full backup or not.
 
Use differential backup if you have a reasonable amount of time to perform backups. The upside
is that only two backup container files are needed to perform a complete restore. The downside is
if you run multiple differential backups after your full backup, you're probably including some files
in each differential backup that were already included in earlier differential backups, but haven't
been recently modified.
 
Advantages

· Restore is faster than restoring from incremental backup
· Backing up is faster than a full backup
· It uses less storage space than full backup

Disadvantages
· Restore is slower than restoring from full backup
· Backing up is slower than incremental backup
· It uses more storage space than incremental backup

 
Differential Backup Type in Backup4all

Backup4all supports the differential backup type and offers a solution for the slow backup issue.
In time, the differential can grow to a size that is equal or larger than the full version. Therefore
the following options can be used to trigger the creation of a new full backup:

· Automatically make full backup if the differential exceeds ...% of full backup size
(default is 50%)

· Automatically make full backup if the differential exceeds ... (default is 100 MB)

The system calculates the backup size for the differential backup and if the selected condition is
met it performs a full backup.

 

3.4 Incremental Backup

What is Incremental Backup?
 
An  incremental  backup  stores  all  files  that  have  changed  since  the  last  full,  differential  or
incremental  backup.  The advantage  of  an  incremental  backup  is  that  it  takes  the  least  time  to
complete.  However,  during  a  restore  operation,  each  incremental  backup  must  be  processed,
which could result in a lengthy restore job.
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Description of the Incremental Backup Type
 
Incremental  backup  provides  a  faster  method  of  backing  up  data  than  repeatedly  running  full
backups.  During an incremental  backup only the files  that  have changed since  the  most  recent
backup are included. That is where it gets its name: each backup is an increment since the most
recent backup.
 
The time it  takes to execute the backup may be a fraction of the time it  takes to perform a full
backup. Backup4all uses the information recorded in its catalog file (".bkc") to determine whether
a file has changed since the most recent backup.
 
The advantage of reduced backup duration comes with a price: increased restore duration. When
restoring  from  incremental  backup,  you  need  the  most  recent  full  backup  as  well  as  every
incremental backup you've made since the last full backup.
 
For  example,  if  you  did  a  full  backup  on  Friday  and  incremental  on  Monday,  Tuesday  and
Wednesday,  and  the  PC  crashes  Thursday  morning,  you  would  need  all  four  backup  container
files: Friday's full  backup plus the incremental backup for Monday, Tuesday and Wednesday.  By
comparison,  if  you  had  done  differential  backup  on  Monday,  Tuesday  and  Wednesday,  then  to
restore on Thursday morning you'd have needed Friday's full backup plus Wednesday's differential
backup.
 
Advantages

· Backing up is the fastest
· It uses the least storage space

Disadvantages
· Restore is the slowest 

Incremental Backup Type in Backup4all
 
Backup4all supports incremental backup type and offers a solution for the slow restore issue.
To  keep  the  number  of  stored  backups  to  a  reasonable  number  and  reduce  the  size  of  the
backups,  Backup4all  provides  three  options:  Yes,  limit  number  of  file  versions,  Yes,  limit
number of backups and Merge backups. These options will perform an internal merge to keep
the number of stored backups under the selected limit.
The following options can be used to trigger the creation of a new full backup:

· Automatically make full backup if  all  increments exceed ...  % of full  backup size
(default is 50%, not checked)

· Automatically make full  backup if  all  increments  exceed  ...  (default  is  100  MB,  not
checked)

The  system calculates  the  file  sizes  for  the  incremental  and  if  the  selected  condition  is  met,  it
performs a full backup.

 

3.5 Mirror Backup

What is Mirror Backup?
 
A mirror backup is identical to a full backup, with the exception that the files and folders are not
compressed in zip files and they cannot be protected with a password. A mirror backup is  most
frequently used to create an exact copy of the backup source data.  It  has the benefit  that  the
backup files can also be readily accessed using tools like Windows Explorer.
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Description of the Mirror Backup Type
 
A mirror backup is an exact copy of the selected folders and files at a given time. Mirror backup is
the  fastest  backup  method  because  it  copies  files  and  folders  to  the  destination  without  any
compression. However, the increased speed has its drawbacks: it needs larger storage space and
it cannot be password protected.
 
While  the other backup types collect all  the files  and  folders  being  backed  up  each  time  into  a
single compressed container file,  a mirror backup keeps  all  the individual  files  separately  in  the
destination. That is, the destination becomes a mirror (exact copy) of the source. You can even
directly  access  files  in  the  destination  without  needing  to  use  Backup4all's  restore  feature,
because each file is just an exact copy of the original.
 
One  handy  feature  of  mirror  backup  is  Backup4all's  Fast  mirror  option.  When  this  option  is
selected,  any  mirror  operation  after  the  first  will  only  copy  new and  modified  files,  making  the
operation very fast.
 
Another important feature is that users can choose to zip each file individually using the Zip the
files option. In this case, the compression and encryption options can be used.

A mirror backup cannot keep track of different versions of files. However, Backup4all provides an
option  to  customize  destination  folder  names  using  user-defined  parameters,  giving  you  the
ability  to  save  each  mirror  backup  in  a  different  folder  location.  Restore  using  Backup4all  is
possible only from the latest  mirror backup,  but  all  previous  mirror backups  remain available  in
the destination and can be accessed manually.
 
Advantages

· The fastest backup type, especially in conjunction with the Fast mirror option
· It  creates  a  snapshot  of  the  selected  files  and  folders  in  the  destination  which  you  can

browse and access later without needing to run Backup4all
· If used with Zip the files option, a selective restore is faster than in any other backup type

with zip. 

Disadvantages
· If not zipped, it needs more storage space than any other backup type
· Cannot track different versions of files

 

3.6 Backup Types in Backup4all

How are the Backup Types Implemented in Backup4all?
 
Backup4all creates two main types of backups:

· Backup types with zip compression
· Mirror backup type

User can change the backup type from the Type page in Backup Properties, or from a specific
type page, by checking the box to select that type as default backup type.

Backup Types with Zip Compression
 
Full,  differential  and  incremental  backup  use  zip  compression  to  reduce  the  size  of  the  stored
backup versions. To keep the number of stored zip files at a reasonable number, the application
provides three options:  Yes,  limit number of  file  versions,  Yes,  limit  number  of  backups
and  Merge  backups.  These  options  either  delete  older  stored  backups  or  perform  an  internal
merge to keep the number of stored backups or file versions under the selected limit.
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The Yes, limit number of file versions, Yes, limit number of backups and Merge backups
options cannot be used when the backup destination is on a removable media: floppy disk,  CD,
DVD, Blu-ray disc etc.
 
Customize zip name prefix
Typically  the  name  of  the  zip  file  is  something  like:  "1_C.zip",  "1_D.zip"  etc.  (one  zip  for  each
drive).  The  names  of  these  zip  files  do  not  make  much  sense  for  the  user  but  they  can  be
customized by pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)
· Backup Number (<BACKUP NUMBER>)
· Backup Type (<BACKUP TYPE>)
· Backup Date (<DATE>)
· Backup Time (<TIME>)
· Backup Year (<YEAR>)
· Backup Month (<MONTH_MMM>)
· Backup Month - numeric (<MONTH_MM>)
· Backup Week (<WEEK>)
· Backup Day of Week (<DAY OF WEEK>)
· Backup Day (<DAY>)

You can also add your text in the edit tag field. Use the Preview button to see how the names of
the zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |
Therefore  Backup4all  will  prompt  you  to  change  these  characters  if  present  in  the  Customize
prefix of backup files field.

 
Full Backup Type

The  full  backup  type  will  always  backup  all  the  files  defined  in  the  sources.  Incremental  and
differential backups will create a full backup first, because they will back up the new files (all files
are new if the backup was never executed).
 

Differential Backup Type

For a differential backup the system will always backup the differences from the last full backup,
regardless of the intermediate versions between the latest full and the current differential backup.
The first execution of a differential backup is a full backup, because it backs up the new files (and
all the files are new if the backup was never executed). 

Incremental Backup Type

In case of incremental backups only the new and the modified files since last backup (differential,
incremental or full backup) are added to the backup. Each file can have many versions stored in
the backup files..
  
Backup4all can generate custom zip file names, set a size limit for zip files and encrypt them. For
more details look at the Compression page from the Backup Properties window.
 
If a new backup job is created and the backup type is set to incremental or differential, then when
the backup job is first run, the application will perform a full backup. This also happens when the
catalog  (".bkc")  file  is  not  found  in  the  destination  folder  or  the  Clear  backup  action  was
executed before backup (see the Advanced page of the Backup Properties window).
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Mirror Backup Type
 
The mirror backup implementation provides some useful options to improve the backup quality.
 
Since the mirror backup keeps only one version of each file, you can use the Create subfolder
(s)  in  destination  with  following  name  option  to  copy  the  files  to  customized  subfolders,
therefore  keeping more versions  of  the files.  Backup4all  can only use  the  latest  version  for  the
Restore or Test operations. You can restore older versions manually.
 
If the Copy files in a subfolder option is checked, the files will be copied in a subfolder of the
destination  folder  (typically  you  will  see  a  ".bkc"  file  and  a  folder  with  the  same  name).  If  the
option is not set, the files (and folder structure) will be copied directly into the destination folder.
 
When the Fast Mirror (copy only new or modified files) option is used, Backup4all uses the
information  stored  in  ".bkc"  files  to  copy  only  new  or  modified  files  to  the  destination.  If  this
option is not set, the system will copy all files each time the backup is executed.
 
Using the mirror backup type, you can also choose to Zip the files. This option will zip each file
individually, preserving the folder structure. In this case, you can  use the zip compression and
encryption.
 
When changing the backup type between Full,  Incremental or Differential the older backups are
not  deleted,  only  the  type  of  the  next  backup  is  changed.  If  the  Yes,  limit  number  of  file
versions,  Yes,  limit  number  of  backups  and  Merge  backups  options  are  used,  the
application will delete or merge older backups so that the number of versions is less or equal to
the specified limit. However when changing between Mirror and Full,  Incremental or Differential,
the older versions are deleted.

By  default  the  Yes,  limit  number  of  file  versions  and  the  Yes,  limit  number  of  backups
options are not enabled. This means that the system will keep all the stored backup versions. If
you  choose  to  enable  the  Merge  backups  option,  when  the  limit  is  reached  the  system  will
perform  an  internal  merge  between  the  older  versions  keeping  the  number  of  stored  backups
equal  to  the  specified  limit  (the  merge  between  zip  files  is  necessary  to  keep  at  the  latest  file
version from each zip file to be merged).
However when changing between Mirror and Full,  Incremental or Differential,  the older versions
are deleted.
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4 Backup to CD, DVD or Blu-ray

4.1 Backup to CD, DVD or Blu-ray

Backing  up  to  CD,  DVD  or  Blu-ray  media  has  become  increasingly  common  due  to  mature
technology and cheap CD, DVD or Blu-ray burners.
If you plan to do a backup to a CD, DVD or Blu-ray disc, please consider our recommendations:

· Do not  use  the  same  CD,  DVD or  Blu-ray  disc  to  store  consecutive  backup  versions.  It's
better to use different CD, DVD or Blu-ray media for each backup version (change the CD,
DVD or Blu-ray disc at each backup run). Use a set of CD, DVD or Blu-ray media and rotate
them periodically (e.g.:  take 7  CD media,  one for  each week  day;  start  with  the  first  CD
again  every 7  days).  The reason for  this  is  that  in  case the burn process fails  or  the  CD,
DVD or  Blu-ray  data  becomes corrupted, you still  have  the  previous  backup  version  on  a
different disc.

· Rewritable CD, DVD or Blu-ray media can be burned only a limited number of times. When
strange errors happen you should consider that the CD, DVD or Blu-ray disc might be over-
burned (worn out).

· Always test the backed up data after burning. Backup4all has a special option to automate
the test after backup and also in case you are spanning multiple CD, DVD or Blu-ray discs ,
Backup4all test each CD, DVD or Blu-ray disc before writing the next one.

Backup4all makes the backup to CD, DVD or Blu-ray disc process to be easy to perform: just set
the  backup destination to the CD,  DVD or  Blu-ray  burner drive  and  run  the  backup.  By  default
Backup4all uses its own built-in burning engine to backup to CD, DVD or Blu-ray media (you do
not need third party drivers or burning software to be installed).
 
If you prefer packet writing (using third party software) you can select  it  in  the Write method
section.
 
If the backup does not fit onto one CD, DVD or  Blu-ray  disc,  Backup4all  will  automatically span
the backup over multiple media. Each disc is assigned a different label for future identification. We
recommend marking the CD, DVD or Blu-ray disc with this label.
 
A few recommendations before backing up to CD, DVD and Blu-ray discs:

· Before backup execution, be sure to insert the CD, DVD or Blu-ray disc containing the latest
".bkc" file if you have the option Use local  catalogs  unchecked (in  Backup Properties-
>Advanced->Backup options section, default is checked)

· On backups to hard disk, you can limit the number of stored zip backups by using the Yes, l
imit  number  of  file  versions,  Yes,  limit  number  of  backups  and  Merge  backups
options.  These  options  do  not  apply  to  CD,  DVD  or  Blu-ray  media,  you  cannot  limit  the
number of stored backups on removable media.

· A mirror backup copies every file matching the sources and the file filter to CD, DVD or Blu-
ray disc. On a mirror backup to hard disk, files that are deleted and excluded from sources
can be deleted from destination too if you want so. This is not possible on the CD, DVD or
Blu-ray disc, so deleted and excluded files are just left there as they were burned before,
but  the catalog (".bkc")  file  is  updated and the restore operation will  not copy  these  files
back.

· When backing up to CD, DVD or Blu-ray discs Backup4all requires additional free space on
the drive where the Temporary Folder is located (at least 700Mb when backing up to CDs,
or 4.7Gb when backing up to DVDs)

 

4.2 Use Built in Driver

Backup4all does not need third party drivers or other CD, DVD or Blu-ray burning software to be
installed (like ActiveX, ASPI, etc) to be able to burn a CD, DVD or Blu-ray. Backup4all has a built-
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in CD, DVD or Blu-ray burner to backup to CD, DVD or Blu-ray disc directly.
 
 
Set Up Internal CD, DVD or Blu-ray Burner
 
There are three simple steps to set up the internal CD, DVD or Blu-ray burner:

1) Open the Backup Properties window and go to the Destination page.
2) Select the drive letter for the CD, DVD or Blu-ray burner device you want to use. If the CD,
DVD  or  Blu-ray  device  is  compatible  with  the  built-in  burner,  you  will  see  the  following
message: [Device name] Using internal burner
3) In the same page, you can:

· configure the burn speed
· set the Erase disk before writing option
· switch the write method between build-in driver and UDF file system
· use a custom prefix

You can use two burners  for  UDF disc  format:  Use SCSI Pass Through Direct layer (SPTD)
and  Use native Win32 interface (SPTI). This format can be  used  to write  on CD-R/CD-RW/
DVD-R/DVD+R/DVD-RW/DVD+RW/DVD-DL/HD-DVD/Blue-ray/Blu-ray DL.
 
Use internal CD, DVD or Blu-ray burner
 
Typically, a backup to CD, DVD or Blu-ray disc performs additional steps shown in the status bar
at  the  bottom  of  the  main  window:  burning,  finalizing,  and  loading  disc.  During  the  last
operation,  the  CD,  DVD  or  Blu-ray  disc  is  ejected  and  reloaded.  After  this  step  the  backup  is
tested and the CD, DVD or Blu-ray disc ejected again (if these options are set).
Backup4all  can  also  perform  an  additional  Erase  CD/DVD/Blu-ray...  action  for  appropriate
media (rewritable CD, DVD or Blu-ray discs)
 

4.3 Use Packet Writing

If you do not wish to use the built-in burner or your CD, DVD or Blu-ray device is not compatible,
you can use third party packet writing software.

Packet Writing Software
 
Packet writing software can write only to CD-RW, DVD-RW or DVD+RW if the disks are formatted
using the Universal Data Format (UDF) file system.
 
The advantage of packet writing is that your rewritable media can be used like a floppy or zip disk
(drag  and  drop  from  Windows  Explorer  is  also  possible).  The  disadvantage  of  using  packet
writing  is  that  CD,  DVD  or  Blu-ray  discs  written  with  this  method  are  recognized  on  other
computers only if the same third party packet writing software is installed there too.
 
Here are the most important free packet writing applications:

1)  DELL DLA, distributed by DELL (free) (for Windows XP)

2)  IBM DLA , distributed by IBM (free) (for Windows XP)

Set Up Packet Writing
 
There are three simple steps to set up the packet writing to work with Backup4all:

1) Open New Backup Wizard or Backup Properties and go to the Destination page.
2) Select the drive letter for the CD, DVD or Blu-ray burner device you want to use.
3)  You must select Use UDF file system. Here you can also set the Erase disk before
writing option. Press the OK button.

http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R86132&formatcnt=1&fileid=112751
http://support.dell.com/support/downloads/download.aspx?c=us&cs=19&l=en&s=dhs&releaseid=R86132&formatcnt=1&fileid=112751
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-41602
http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-41602
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4) If packet writing is set, you will see the following message on the Destination page:
[Device name] Writing method is UDF

 
Use Packet Writing
 
Backup4all detects if the CD-RW, DVD-RW, DVD+RW or Blu-ray RW disc is UDF formatted. If the
disc is not UDF formatted it will show the following message: Disk in drive [drive letter] is not
UDF formatted. Please insert a UDF formatted disc.

 

4.4 Writing to CD, DVD or Blu-ray disc

By default, the backup catalog (.bkc) is stored both on the destination CD,  DVD or  Blu-ray  disc
and locally. To see if the catalog will be stored locally too, select Backup Properties for a backup
job, go to Advanced and see if the Use local catalogs (.bkc) option is checked.
If it is unchecked the backup catalog is stored only on the destination. The recommended option
is to leave it checked.
 
When  the  backup  process  starts,  Backup4all  searches  for  the  ".bkc"  file  locally  (by  default,
assuming that you didn't uncheck the option Use local catalogs), then:

· If the catalog file is found, Backup4all will  make a new version for  the backup job.  If  you
wish  to  write  the  new  backup  version  on  a  separate  CD,  DVD  or  Blu-ray  disc  (this  is
recommended) then you should set the Ask for a new disk before backup option.

· If  the  backup  catalog  is  not  found  locally  (was  deleted  by  mistake)  or  if  the  Use  local
catalogs option is unchecked, Backup4all will ask for the last CD, DVD or Blu-ray disc used
for the backup. When it  finds  the backup catalog,  Backup4all  will  make a new version for
the files in the backup job.

· If the catalog file is not found on the destination either, Backup4all will start with a new full
backup

         
Backup4all  will  automatically span the backup over  multiple  media  if  the size of  the backup job
does not fit on a single CD/DVD/Blu-ray disc. For each disc Backup4all will assign a different label
for future identification. We recommend marking the CD, DVD or Blu-ray disc with this label.
When spanning multiple  CD,  DVD or  Blu-ray  discs,  Backup4all  will  create  independent  zip  files,
meaning  that  if  you  have  a  backup  that  spans  over  3  CDs  and  if  one  of  the  CDs  becomes
unreadable, you will still be able to access and recover the data on the other 2 CDs.
 
It  is  recommended  to  always  leave  the  Test  after  backup  option  (Backup  Properties-
>Advanced) checked, especially if your backup is written on CD, DVD or Blu-ray disc. In case of
disk  spanning,  Backup4all  will  test  your  backed  up  data  after  each  individual  written  disc.  This
way  if  one  of  the  discs  has  errors  you  know  before  the  backup  job  is  finished  and  you  can
interrupt the backup process in time.
 
Note that when backing up to CD, DVD or Blu-ray disc Backup4all requires additional free space
on  the  drive  where  the  Temporary  Folder  is  located  (at  least  700Mb  when  backing  up  to  CDs,
4.7Gb when backing up to DVDs or 25GB when backing up to Blu-ray discs).

 

4.5 Other CD/DVD/Blu-ray Settings

The  Tools->Options->CD,  DVD  or  Blu-ray  window  contains  various  settings  related  to  the
burn process.

CD, DVD or Blu-ray
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Use SCSI Pass Through Direct Layer (SPTD)
Selected by default. Backup4all  uses  this  internal  burning engine to write  CD,  DVD,  HD-DVD or
Blu-ray discs. SPTD is a new method of access to storage devices and has the ability to provide
direct control of devices without risk of compromising it by some malicious 3rd party filter drivers
or other "rootkit" applications. 
SPTD  is  currently  supported  only  on  Microsoft  OS  Windows  2000  and  above.  SPTD  (similar  to
other access layers) is not removed from your system after Backup4all uninstall, in order not to
disrupt other applications that may use it. 
 
Use native Win32 Interface (SPTI)
If you have problems backing up using the SPTD method, we recommend you to use this option.
Eject CD, DVD or Blu-ray disc After Backup
You can leave the CD, DVD or Blu-ray disc ejected after the backup is finished (and tested). To do
so,  go  to Tools->Options->Backup and check the Eject CD,  DVD or  Blu-ray  after  backup
option.
 
Ask for a New Disk Before Backup
You can start with a new CD, DVD or Blu-ray disc each time the backup is executed. To do so, go
to Tools->Options->Backup and set the Ask for a new disk before backup option.
 
Warn Before Completely Erasing a Disk
If the Erase disk  before writing  option  is  set,  then each disk  you insert is  erased before the
backup  (or  backup  span)  is  written.  If  you  set  this  option  in  Tools->Options->Backup,
Backup4all will always ask you to confirm disk erasing.
 
Show disk label message after writing a disk
If this option is set in Tools->Options->Backup, you will be asked to mark the disc (CD, DVD or
Blu-ray)  with  a  label  after  each  disk  is  completely  written.  The  system  suggests  you  the  disk
labels and will refer to each disk using its label (while restoring). By default this option is checked.

 
Note:

· The  Use  SCSI  Pass  Through  Direct  Layer  (SPTD)  and  Use  native  Win32  interface
(SPTI) burning methods use the UDF disc format.



Main Window
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5 Main Window

5.1 Commands

Toolbar
 
The toolbar contains a selection of the most important Backup4all functions.

 New - starts the New Backup Wizard

 Open - creates a new backup job from the opened ".bkc" or ".ini" file

 Properties - opens a dialog to edit the backup job configuration

 Views - clicking this button will show the following drop-down menu:
· Brief - switches to Brief view
· Explore - switches to Explore view
· Backup - switches to Backup view
· Statistics - switches to Statistics view
· Summary - switches to Summary view

 Backup - starts the backup process for the currently selected backup job. Clicking the small
arrow displays the following drop-down menu:

· Make - performs the backup type defined in backup properties
· Make Full - performs a full backup regardless of the backup type
· Make  Differential  -  performs  a  differential  backup  regardless  of  the  backup  type

defined in backup properties
· Make Incremental -  performs an incremental backup regardless of the backup type

defined in backup properties

 Restore - starts the Restore Wizard
· Restore Latest  Version  -  restores  the  latest  version  to  its  original  location  without

showing the Restore wizard
· Restore Latest Version To - restores the latest version to another location (prompts

for one) without showing the Restore wizard

 Test - opens the Test Backup window

 Pause - pause the backup, test or restore process

 Resume - resume the backup, test or restore process

 Stop - stops the backup, test or restore process

 Cancel - cancels the backup, test or restore  process

 Refresh - reloads the backup catalog
 
Menu commands
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File

 
· New  Backup...  starts  the  New  Backup  Wizard,  same  as  the  New  toolbar  button  or

keyboard shortcut Ctrl+N
· Open Backup...  creates a new backup job from the opened ".bkc"  or  ".ini"  file,  same as

the Open toolbar button or the keyboard shortcut Ctrl+O
· Open Backup From - creates a new backup job from the opened ".bkc" or ".ini" file, and

user  can select  to open the catalog from multiple  locations  as:  local  hard  drive,  network,
FTP or SFTP server.

· Create Like duplicates the selected backup job, same as the toolbar button Create Like or
the keyboard shortcut Ctrl+E

· Delete Backup - removes the current selected backup, same as the toolbar button Delete
or the keyboard shortcut Ctrl+Del

· Properties... opens the backup properties window, same as the toolbar button Properties
or the keyboard shortcut Ctrl+P

· New Group... creates a new backup group
· Rename Group... renames the current expanded group
· Delete Group - removes the current expanded backup jobs group
· Import from version 4... imports ".ini" files from version 4 of Backup4all
· Exit - exits the application, same as the keyboard shortcut Alt+F4

View

· Brief - switches to Brief view, same as the Explore toolbar button or keyboard shortcut F4
· Backup  -  switches  to  Backup  view,  same  as  the  Explore  toolbar  button  or  keyboard
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shortcut CTRL + F2
· Explore  -  switches  to  Explore  view,  same  as  the  Explore  toolbar  button  or  keyboard

shortcut F2
· Statistics - switches to Statistics view, same as the Statistics toolbar button or keyboard

shortcut F3
· Summary  -  switches  to  Summary  view,  same  as  the  Summary  toolbar  button  or

keyboard shortcut CTRL + F4
· Open Folder - shows list of folders that can be opened with Windows Explorer

· Destination Folder - folder containing the destination files
· Catalog Folder - folder containing the ".bkc" files
· Initialization Folder - folder containing the ".ini" files

· Job Logs - contains a list of available logs
· Last Backup Log - shows the latest backup log for the selected backup job.  If there

is no log file, the menu is disabled.
· Last Restore Log - shows the latest restore log for the selected backup job. If there

is no log file, the menu is disabled.
· Last Test Log - shows the latest test log for the selected backup job. If there is no log

file, the menu is disabled
· Last Cleanup Log - shows the latest cleanup log. If  there is no log file, the menu is

disabled
· Open Log Folder - opens Windows Explorer showing the contents of the log folder

· View Application Log - shows the application's log file. If there is no log file, the menu is
disabled.

· View jobs as - change the display mode of the backup list
· Tree - the backup groups and jobs will be shown in a tree 
· Icons - the backup jobs will be shown with large icons 
· List - the backup jobs will be shown in a list 

· Show Toolbar - if not selected, the toolbar will be hide. By default this option is selected.
· Restore Default Layout - restores Backup4all's windows size, position and columns

Actions

· Backup
· Make Backup  -  starts the backup process for  the selected backup job,  same as the

Backup toolbar button or keyboard shortcut F6
· Make Full Backup - performs a full backup regardless of the backup type
· Make Differential Backup - performs a differential backup regardless of the backup

type
· Make  Incremental  Backup  -  performs  an  incremental  backup  regardless  of  the

backup type
· Backup <Name of group> Group - starts the backup process for each backup job in

the opened group, one backup job at  a time. Backup jobs are executed in  the same
order as they are visible in the backup group
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· Backup all groups - starts the backup process for all groups. The backup groups will
be processed in the same time, one backup job from each group will be executed at a
time.

· Restore
· Restore...  starts  the  Restore  wizard  same  as  the  Restore  toolbar  button  or  the

keyboard shortcut F7
· Restore Latest  Version  -  restores  the  latest  version  to  its  original  location  without

showing the Restore wizard
· Restore  Latest  Version  To...  -  restores  the  latest  version  to  another  location

(prompts for one) without showing the Restore wizard
· Test...  opens  the Test  Backup window,  same as the Test  toolbar  button  or  the  keyboard

shortcut F9
· Clean - opens the Clean Backup window that shows a list of backup numbers that can be

removed
· Pause  (CTRL  +  F8)  -  pause  the  backup,  test  or  restore  process,  same  as  the  Pause

toolbar button
· Stop (CTRL + S)  -  stops the backup,  test  or  restore process,  same as  the  Stop  toolbar

button
· Cancel  (F8)  -  cancels  the  backup,  test  or  restore  process,  same  as  the  Cancel  toolbar

button
· Refresh (F5) - reloads the backup catalog

Tools

· Erase CD/DVD/Blu-ray - opens the Erase CD/DVD/Blu-ray window
· Plugins - opens the Manage Plugins window
· Getting Started - opens the Getting Started window
· Options - opens the Options window

Help

· Backup4all Help (F1) - opens the help file

· Backup4all on the Web - opens  http://www.backup4all.com/
· Support Request... starts a new email message that will be sent to the support team 
· How to Order - provides information about where and how to buy the application
· Register... opens the Register Backup4all window
· Check for updates - displays a window with the available updates
· About Backup4all - opens the About box of Backup4all

http://www.backup4all.com/
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5.2 Getting Started

This window is displayed when you first  run Backup4all.  You can also access this  window if  you
select Getting Started from the Tools menu.
There are two large buttons for backup and restore and a list of articles about Backup4all.

Backup

Press this button to create or run backup jobs.

Create a new Backup 
Press the New button to start creating a new backup job using the New Backup Wizard.
If you want to run this job when the backup device is plugged in, check the Use the new job for
plug and backup.
 
Run Selected Backup  
Select an existing backup job from the list and press Backup to run the selected job.
If you want to run this job when the backup device is  plugged in,  check the Use the selected
job for plug and backup.
 

Restore

Open an Existing Backup 
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Use  the  Open  button  to  recreate  a  backup  job  from  the  backup  catalog  (.bkc)  or  from  the
initialization file (.ini).
The recreated backup job will be added to the backup list.

Restore Selected Backup
Select an existing backup job from the list and press Restore to open the Restore Wizard.
If  you  don't  want  to  show  the  Backup4all  Startup  window  next  time  you  open  Backup4all,
uncheck the Show this dialog at next start option.
By default this option is checked.

5.3 Backup List

Backup list contains all the defined backups visible in the left side of Backup4all's main window.
The backup jobs are grouped into backup groups, for easy handling.

To configure a backup job's appearance (icon and label) in the backup list, you have to open the
Backup  Properties  window,  switch  to  the  General  tab,  change  the  name  of  the  backup  job,
choose the group of the backup job and select a backup job icon. If you have several backup jobs
defined  in  the  same  group,  you  can  check  the  option  Sort  backup  jobs  alphabetically  in  a
group from Tools->Options->Preferences to have them ordered by name.  When you backup
an entire group, the backup jobs are backed up in the order that they are displayed in the group.
 
When right clicking a backup job, a menu is displayed giving the following options:

· Make Backup - starts the backup process for the selected backup job
· Make Full Backup - performs a full backup regardless of the backup type
· Make Differential Backup - performs a differential backup regardless of the backup type
· Make Incremental  Backup  -  performs  an  incremental  backup  regardless  of  the  backup

type
· Restore - opens the Restore Wizard window for the currently selected backup job
· Restore Latest Version - starts the latest version restore process for the selected backup
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job
· Restore  Latest  Version  To  -  opens  a  window  to  select  the  folder  were  you  want  the

backup to be restored 
· Test... starts the test process for the currently selected backup job
· Clean - opens the Clean Backup window for the selected backup job
· Cancel - aborts current backup process
· Pause - pause the current backup/test/cleanup/restore process
· Stop - stops the current backup/test/cleanup/restore process
· Job Logs - lets you open and view the Last Backup Log,  Last Restore Log,  Last Test

Log and Last Cleanup Log
· Create Like - duplicates a backup job
· Delete Backup - deletes a backup job
· Properties... opens the Backup Properties window

Backup4all  can process multiple backup jobs at the same time. You can filter  the backup list  to
see which backup jobs are executed at a certain time.
From the  drop-down  list  above  the  backup  list,  you  can  filter  the  backup  jobs  in  list.  You  can
choose to see all groups, only the active jobs or only a specified group.
If there are many backups listed, you can search for a backup job by typing its name in the Type
to search box on the bottom of the Backup List.  
  

5.4 Manage Backup Groups

Create a new backup group

1)  When  creating  (or  editing)  a  backup  job  using  the  New  Backup  Wizard  in  Advanced
mode (or Backup Properties), type a new name (that does not exist) for the backup group.
The new group will be created when the wizard is finished.

 

 
2) Right  click  on  backup  list  (left  panel  of  the  main  window)  and  choose  New Group.  The
Create a new group window will  appear and you can enter the name of the group. A new
empty group will be created (which can be selected later from the Groups combo of the New
Backup Wizard or from the Backup Properties window).
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Rename a backup group

Select the backup group from the groups drop-down list. Open the File menu or right click on the
backup list and choose Rename Group. A window similar with the one for Create a new group
will  appear.  You can enter  the new name and press OK.  The group will  be  renamed and  it  will
keep all the backup jobs it had.

Delete a backup group

Select  the  backup  group  from the  groups  drop-down  list.  Go  to  File  menu  or  right-click  in  the
backup list and choose Delete Group. A warning message will appear before the deletion. If you
choose Yes, the backup group will be deleted with all its backup jobs. To move backup jobs to a
different backup group, you must edit the backup job's properties and select a different group for
them.

 

5.5 Brief View

You can activate Brief view by:
· selecting the Brief menu item from the View menu
· pressing F4 keyboard shortcut
· selecting Brief from the Views drop-down list
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This view provides basic details and buttons for the selected backup job.

Backup
Pressing this button starts the backup process for the currently selected backup job.

Restore
Pressing this button starts the Restore Wizard.

Destination
Shows the destination of the backup job.

Backup type
Shows the backup type of the backup job.

Go to Summary
This link will lead you to the Summary view for a complete description of the backup
 
Last backup on
Date and time of the last backup

Last backup status
Displays the following information:

· Last backup was successful when everything went OK
· Last backup failed when the backup was aborted due to an error
· Last backup had <X> warnings when the backup was  done,  but  <X> files  could

not be backed up
· Last backup was canceled when the user canceled the backup execution

Go to Statistics
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This link will lead you to the Statistics view for a complete statistics listing 

View configuration errors
Press this  link  to open a new window with  the configuration errors  found in  the current backup
job. For each error there is a suggestion about how to fix the problem.

When the program starts, go directly to 
Check this option if you want to can change the default action of the Views button. The available
options are: Explore, Backup, Statistics and Summary.
The  default  action  of  the  Views  button  can  also  be  changed  from  Tools->Options-
>Preferences. 

 

5.6 Explore View

You can activate Explore view by:
· selecting Explore from the Views drop-down list
· selecting the Explore menu item from the View menu
· pressing F2 keyboard shortcut

 

 
The Explore View consists of a File Tree on top and a File Version List at the bottom. 

File Tree

The  file  tree  content  depends  on  the  backup  sources  and  file  filters  defined  for  the  selected
backup job. You can right-click on the folders and files in the tree to open the same context menu
that  is  available  from  Windows  Explorer  if  the  option  Show  context  menu  from  Tools-
>Options->Preferences  is  checked.  If  that  option  is  unchecked,  the  right-click  operation  will



Main Window 57

Backup4all 4 User Manual Copyright © 2010 Softland

display  only  the  Restore  Latest  Version  and  Restore  Latest  Version  to...  You  can  select
multiple files.
 
Be  careful  about  handling  files  in  the  Explore  view  with  the  Show  context  menu  option
checked: all actions are performed on the hard disk and any deletion will actually remove the file
from your hard disk!
 
Beside  the  Windows  Explorer  context  menu  items,  there  are  also  two  custom  menu  items,
which enable the restore of the last version of a file: Restore Last Version  and Restore Last
Version To...

If  you want to exclude a file/folder  from the backup sources,  you  can  right-click  that  file/folder
and  choose  Exclude  from  backup  sources  option.  This  action  will  uncheck  the  file/folder  in
Backup Properties->Sources.

The file tree shows the last modified date, size and attributes for each file in additional columns.
This  information is  the same as shown in  Windows Explorer.  You can sort  the files  by  name,
date, size or attributes by simply clicking on the appropriate column header. The files are sorted
within their folders. Size,  Modified  and Attributes  columns can be hidden if you right  click on
the column header and uncheck the names of the columns that you want to remove.
 
There are seven buttons on top of the file tree that help you show/hide files depending on their
status:
 

 If pressed, files that will be added to the backup are shown in the tree. All files with this status

will have  picture in front of them.

 If pressed, files that have not been changed since last backup are shown in the tree. All files

with this status will have  picture in front of them.

 If pressed, files that have been changed since last backup are shown in the tree. All files with

this status will have  picture in front of them.

 If pressed, files that are already present in backup and are now excluded by new changes in

file filter are shown in the tree. All files with this status will have  picture in front of them.

 If pressed, files that have been deleted from hard disk are shown in the tree. All files with this

status will have  picture in front of them.

 If  pressed,  all  directories  in  the  tree  will  be  expanded.  For  a  large  number  of  files  and
directories, this operation can take a longer time. Press the ESC key to stop the process.

 If pressed, all directories in the tree will be collapsed.

 
If you do not want to see empty folders when clicking on Expand all, check Hide empty folders
on expand all in the Tools->Options->Preferences window and click Expand all again. The
tree will show only folders containing at least one file.
 
There is an easy way to search for a file in the files and folder tree: simply start typing the file's
name and the matching file name will be selected. Only files that are visible in the tree are found,
so if you want to search in all files, you have to do an Expand all first.

If you want to see only the backed up files press these buttons:    

For the files that will be added to the next backup press:  

 
File Version List

If a file is selected in the tree, at the bottom of the view, you can see the list of the file's versions
from the backup. Information provided for each version:

· Type - Type of the Backup. Each of the backup types is represented by a descriptive icon: 
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 Full,  Incremental,  Differential,  Mirror
· Ver. - File version number
· Bck. No. - Number of the backup
· Backup Date - Date and time when the version was added to the backup
· Status - Status of operation performed on that file version (added, excluded...)
· Size - Size of the file version
· Modified - Date and time when the file version was last modified (at backup execution)
· Attributes - Attributes of the file version at backup execution (read-only, hidden, archive).

This column is hidden by default
· Bkc. Label - Label of the backup increment. This column is hidden by default

The file versions in the list can be sorted by clicking on the column headers. The right-click menu
on  the  column  header  provides  a  handy  way  to  show/hide  unnecessary  columns  (except  the
Version column which is grayed out).
 
Backup4all provides an easy way to restore any file version. Just right-click on the file version you
want to restore and:

· choose Restore if you want to restore the version in the original location
· choose Restore to... if you want to restore the version in another location
· choose Open if you want to open/view that version of the file with the associated Windows

application
· choose View with Notepad if you want to open/view that version of the file with Notepad
· choose  Compare  with  source  if  you  want  to  compare  the  selected  version  with  the

existing source
· choose Compare versions if you want to compare the selected versions
· choose Select columns to enable/disable the columns displayed

 

5.7 Backup View

You can activate Backup view by:
· selecting Backup from the Views drop-down list
· selecting the Backup menu item from the View menu
· pressing CTRL + F2 keyboard shortcut
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The Backup View consists of a Backup Version List on top and a  File Tree at the bottom. 

Backup Version List

If a backup version is selected, at the bottom of the view, you can see the list of the files in that
backup and their status before that backup. Information provided for each version:

· Type - Type of the Backup. Each of the backup types is represented by a descriptive icon: 

 Full,  Incremental,  Differential,  Mirror
· Backup Date - Date and time when the backup was created
· Bck No. - Number of the backup
· File No. - Number of files in that backup
· Folder No. - Number of folders in that backup
· Comp. Size - Compressed size of the file version
· Uncomp. Size - Uncompressed size of the file version
· Label - Label of the backup increment. 

The backup version list can be sorted by clicking on the column headers. The right-click menu on
the  column header provides a handy way to show/hide unnecessary  columns  (except  the Type
column which is grayed out).

Backup4all  provides  an  easy  way  to  restore  or  test  a  backup  version.  Just  right-click  on  the
backup version and:

· choose Restore if you want to restore the version in the original location
· choose Restore to... if you want to restore the version in another location
· choose Test if you want to test that backup version 
· choose View Backup Log if you want to open/view that log with the selected log viewer.
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Initially the default text editor is used.

File Tree

The file tree content depends on the files from the selected backup version. You can right-click on
the folders and files in the tree to open a menu that allows you to  choose the following options: 

· Restore if you want to restore the version in the original location
· Restore to... if you want to restore the version in another location
· Open  if  you  want  to  open/view  that  version  of  the  file  with  the  associated  Windows

application
· View with Notepad if you want to open/view that version of the file with Notepad
· Full expand to expand all the tree

The file tree shows the file/folder name, bck no. size, last modified date, attributes and status for
each file in additional columns. You can sort the files by simply clicking on the appropriate column
header. The files are sorted within their folders. Except File/Folder, each column can be hidden
if you right click on the column header and uncheck the names of the columns that you want to
remove.

There are seven buttons on top of the file tree that help you show/hide files depending on their
status:

 If pressed, files that were added to the backup as new are shown in the tree. All files with this

status will have  picture in front of them.

 If pressed, files that were added to the backup as modified are shown in the tree. All files with

this status will have  picture in front of them.

 If pressed, files that had been in backup and were excluded by new changes in file filter are

shown in the tree. All files with this status will have  picture in front of them.

 If  pressed,  all  directories  in  the  tree  will  be  expanded.  For  a  large  number  of  files  and
directories, this operation can take a longer time. Press the ESC key to stop the process.

 If pressed, all directories in the tree will be collapsed.

 If pressed, the Filter window will be shown. Use this option to filter the files displayed in the
tree.

 

5.8 Statistics View

You can activate Statistics view by:
· selecting Statistics from the Views drop-down list
· selecting from the View menu the Statistics menu item
· pressing the F3 keyboard shortcut
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This view provides statistical information about the last backup performed and calculates statistics
about the next backup, based on the current backup job configuration.

Information list:
 
Last backup on
Date and time of the last backup

Last backup duration
Shows the duration of the last backup execution
 
Last backup size
Shows  the  size  of  the  last  backup  (compressed)  /  size  of  all  files  present  in  backup
(uncompressed) / compression percentage

Last full backup on (not displayed for mirror backup type)
The date and time when the last full backup was executed. Note that the first backup is always a
full backup, even if the backup type is set to incremental or differential.

Last full backup duration (not displayed for mirror backup type)
Shows the duration of the last full backup execution
 
Last full backup size (not displayed for mirror backup type)
Shows  the  size  of  the  last  full  backup  (compressed)  /  size  of  all  files  present  in  backup
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(uncompressed) / compression percentage.
For  example  10  MB/30  MB/33%  means  that  the  size  of  the  last  full  backup  was  10  MB,  the
uncompressed size of the files backed up was 30 MB and the compression ratio was 33%.
 
Total size of backup (not displayed for mirror backup type)
Total size of the backup takes into consideration all backup increments, ".bkc" file and any folders
that might have been created. It shows the total size after compression / without compression /
compression percentage For mirror backup the compressed values are not shown, because there
is no compression.
 
Number of backups
Number of times the backup job was executed

Last backup status
Displays the following information:

· Last backup was successful when everything went OK
· Last backup failed when the backup was aborted due to an error
· Last backup had <X> warnings when the backup was  done,  but  <X> files  could

not be backed up
· Last backup was canceled when the user canceled the backup execution

Files/folders in backup
Shows the number of files in the backup. The number between the brackets is for the files added
at the last backup. For full backup the number of files added to the last backup will be always the
same with the total number of files. The same for mirror backup without the Fast mirror option
activated.
 

Statistics for next backup:

The  Calculate  Statistics  for  Next  Backup  (Ctrl+F5)  button  will  start  counting  the  new,
modified,  unchanged  and  excluded  files  since  the  last  backup  execution.  The  counters  will  be
shown in the labels below, divided into two sections: Files to backup containing the counters for
the  files  that  will  be  added  to  the  next  backup,  and  Changes  since  last  backup  containing  the
counters for the files changed since the last backup. For a large number of files, counting can be
time  consuming.  If  you  want  to  stop  the  counting  process  press  the  Cancel  button  from  the
toolbar. Calculate Statistics for Next Backup (Ctrl+F5)  uses the catalog file (".bkc"). If  this
catalog is on a CD, DVD or Blu-ray disc and you enter a previous backup version, the counters will
be  different.  Files  to  backup  counters  are  calculated  depending  on  the  backup  job  settings:
backup  type,  <Clear  backup>  action  etc.  Changes  since  last  backup  counters  are  always  the
same no matter the backup job settings.
 
Files/Folders to backup
For full  and differential  backup types these counters  are calculated based on the changes since
the last full backup.For the  incremental backup type, the counts are based on the changes since
the last backup (differential, full or incremental).
 
New files/folders
The number of new files/folders that  will  be  added to backup.  For mirror backup (with the Fast
mirror option unchecked), the new files/folders counter equals the total number of files/folders.
 
Modified files/folders
Shows the number of modified files/folders to be added to backup.  For mirror backup (with the
"Fast mirror" option unchecked), this number will always be 0.
 
Unchanged files/folders
Shows the number of unchanged files/folders to be added to backup. For differential, incremental
and mirror backup with Fast mirror option unchecked, this number will always be 0.
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Excluded files/folders
Shows the number of excluded files/folders, which will be removed from the backup.
 
Changes since last backup
Counts the changes since the last backup, regardless of the backup settings
 
New files/folders
Shows the number of new files/folders since last backup.
 
Modified files/folders
Shows the number of modified files/folders since last backup.
 
Unchanged files/folders
Shows the number of unchanged files/folders since last backup.
 
Excluded files/folders
Shows the number of excluded files/folders. A file/folder gets excluded because of the changes in
file/folder filter or because it was deleted or moved from the backup sources.
 
Total files/folders to backup
Shows the total number of files and folders that will be added to backup next time. This should be
the sum of the new, modified and unchanged file and folder counters.
 
Total size (uncompressed) to backup
Shows the sum of all file sizes to be included in the backup next time it is executed.
 
Free disk space on destination
Shows the available free disk space on the destination drive.

 

5.9 Summary View

You can activate the Summary view by:
· selecting Summary from the Views drop-down list
· selecting from the View menu the Summary menu item
· pressing the CTRL + F4 keyboard shortcut
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This view provides a text description containing all the configurations made for a backup job. You
can copy this text description and put it in a file for later use.

Information included in the Summary:
· General:

· Name:
· Group:
· Predefined backup:
· Description:
· Ini file:

· Destination:
· Destination type:
· Drive:
· Folder:
· Catalog:

· Source(s):
· Filters:

· Main:
· Include filter:
· Exclude filter:

· Customize
· Backup type:

· Type:
· Save storage space:
· Clear archive bit:
· Folder name prefix:
· Fast mirror:
· Create full paths:
· Copy files in a subfolder: 
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· Remove excluded or deleted files from backup:
· Zip the files: 
· Sort mirror files for optimized spanning:    
· Compression level:
· Do not compress files of type:
· Always use temporary folder to create zip files:
· Use alternate zipping mode:
· Password:
· Use Zip AES encryption:
· Key strength:
· Zip split size:
· Create independent splits:

· Advanced settings:
· Backup:

· Use local catalog:
· Test after backup:
· Delete sources after successful backup:
· Ask for backup label before execution:
· Backup open files:
· Backup execution priority:

· Actions:
· Action before backup:
· Action after backup:

· Comparison:
· Comparison criteria:

· Sounds:
· Emails:

 

5.10 Progresss View

You can activate the Progress view by:
· selecting Progress from the Views drop-down list
· selecting from the View menu the Progress menu item
· pressing the CTRL+F3 keyboard shortcut

Please note Progress  view is  active  only when the backup is  running.  When the backup is  not
running, that option is grayed out.
When the backup is started, Backup4all will switch automatically to Progress view and after the
backup is done it will switch back to your previous view.



Backup4all 466

Backup4all 4 User Manual Copyright © 2010 Softland

Action: Indicate the action in progress: Backup, Restore, Test, Clean

Operation:  Indicate  the  operation  in  progress:  Creating  file  list,  Updating  catalog,  Testing
backup etc

Current file: Displays the current file processed

On the Progress view page you can also see the file progress, file count, total  progress, elapsed
time and estimate time.

The  Pause,  Cancel  and  Stop  buttons  at  the  bottom  of  Progress  view  can  be  used  for  a  better
control of the backup jobs. 
 

5.11 Open backup

There are two ways to open a backup job from Backup4all.
· You can open the backup catalog (.bkc) or ini file using the Open Backup command from Files

menu. You just need to browse your computer and indicate the catalog or ini file location.
You can open the backup catalog (.bkc) or ini file using the Open Backup From command from
Files menu. This option is recommended to be used if the catalog is located on a network location
or on an FTP/SFTP server, but can also be used for local hard drives. 

Open backup from a local hard drive

Use this page if the catalog is on a local hard drive. Browse your computer and indicate the folder
containing the catalog(s) or ini file(s). 
Press Show to display the folders and selected file types (.bkc or ini). Press Scan to display a list
of only .bkc/ini files from all folders and subfolders in that location.

Open backup from a network drive
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Use  this  page  if  the  catalog  is  on  a  network  drive.  Select  the  network  location  and  enter  the
username/password if necessarily. 
Press Show to display the folders and selected file types (.bkc or ini). Press Scan to display a list
of only .bkc/ini files from all folders and subfolders in that location. 

Open backup from an FTP server

Use this page if the catalog is on an FTP server. Configure the FTP server or choose an existing
configuration. 
Press Show to display the folders and selected file types (.bkc or ini). Press Scan to display a list
of  only  .bkc/ini  files  from  all  folders  and  subfolders  in  that  location.  Here  you  can  see  how  to
configure the FTP server.

Open backup from an SFTP server

Use this page if the catalog is on an SFTP server. Configure the SFTP server or choose an existing
configuration. 
Press Show to display the folders and selected file types (.bkc or ini). Press Scan to display a list
of  only  .bkc/ini  files  from  all  folders  and  subfolders  in  that  location.  Here  you  can  see  how  to
configure the SFTP server.

Related Topics:

FTP - Edit Configuration
SFTP - Edit Configuration

5.12 Test

The  backup  test  is  meant  to  ensure  the  validity  and  the  integrity  of  the  backup  files  and  the
backup catalog. During test, all files and folders from destination will be tested to make sure they
were safely copied. The files in destination are not compared with the backup sources but with the
information stored in backup catalog.

The  Test  window  can  be  opened  from  Actions->Test...  menu  item  or  by  pressing  the  F9
keyboard shortcut. It lists all  the available information about the backup versions of the current
backup job.
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When  you  open  the  window  all  the  backup  versions  that  can  be  tested  are  selected.  You  can
select/deselect multiple backup versions you want to be tested using batch selection on that list.
To define the selection, keep the Shift  key pressed and use the up and down arrow keys  from
your keyboard or the mouse. If  you want to select multiple individual items, press and hold the
Ctrl key and select using the mouse the items you want tested.
Some backup versions created with older releases of Backup4all cannot be tested. These versions
are disabled and cannot be included in test selection.

There are several columns in the Test window that provide information for each backup version:
· Type - Type of the backup. Each of the backup types is represented by a descriptive icon:

 Full,  Differential,  Incremental,  Mirror
· Backup No. - Number of the backup
· Backup date - Date and time when the version was added to the backup
· File No. - Number of files included in that backup
· Folder No. - Number of folders included in that backup
· Comp. Size - The compressed size of the backup
· Uncomp. Size - The uncompressed size of the backup
· Label - Label of the backup increment.

The backup versions in the list can be sorted by clicking on the column headers.  The right-click
menu on the column header provides a handy way to show/hide unnecessary columns (except the
 Type column which is grayed out).

Using  the  Priority  slider  you  can  set  the  test  execution  speed  compared  to  the  rest  of  the
running processes on your computer. Default is Normal priority,  but there are other 4  priority
levels: Lowest priority, Low priority, High priority and Highest priority. On Lowest priority
the  test  process  will  consume  the  minimum  amount  of  computer  resources  but  will  take  the
longer  to  complete,  while  Highest  priority  will  consume  the  highest  amount  of  computer
resources but will take the least to complete.

To test the selected backup versions press the Test button, or press Cancel (or the Escape key)
to close the window.



Main Window 69

Backup4all 4 User Manual Copyright © 2010 Softland

 
After finishing the test, a pop-up message is displayed with the test results:

· Testing <backup name> found no errors - means that there are no corrupted/missing
files in the backup

 
· Testing <backup name> found error(s). Do you want to see the log file?  -  means

that some files are corrupted or missing from the backup; you should press Yes to see the
test log file (also available from the View->Job Logs->Last Test Log menu too)

Backup4all has also the option to test the files automatically after backup. This option is checked
by default and it is recommended to leave it this way. However, if you want to modify it, you can
find the Test after backup option  in  the Backup Properties-  >Advanced window for  the selected
backup job.
 

5.13 Clean backup

The Clean backup window can be opened from the Actions->Clean menu item. It gives options
to delete backup numbers based on certain criteria.

When you open the window all the backup numbers are displayed. You can either manually check
multiple backup numbers you want deleted or use the filter  options to have them automatically
selected  if  they  match  a  certain  criteria.  Once  you  select  a  type  of  backup,  if  there  are  other
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backup numbers depending on it they will automatically be selected too. For instance, selecting a
Full Backup (marked with red in the list) will also batch select the other incremental or differential
backup numbers that depend on the selected full backup (to keep some of the backup numbers
that  depend on the full  backup,  you will  have to start  unselecting them in  the  order  they  were
created). 
Please note that when you delete a certain backup number using the Clean Backup tool,
all  the  files  in  the  destination  that  were  created  for  that  backup  number  will  be
removed.

There are several columns in the Clean Backup window that provide information for each backup
number:

· Delete  -  Shows  if  a  backup  number  is  selected  for  deletion.  You  can  manually  check/
uncheck  the  backup  numbers  you  want  deleted.  Once  selecting  a  backup  number  all  the
other backup numbers that depend on it will also be selected.

· Type - Type of the backup. Each of the backup types is represented by a descriptive icon

and text:  Full,   Incremental,  Differential,  Mirror. Additionally, full  backups are
marked with red.

· Backup No. - Number of the backup
· Backup date - Date and time when the backup was executed
· File No. - Number of files included in that backup
· Folder No. - Number of folders included in that backup
· Total size - Size of the backup
· Label - Label of the backup increment.

The backup numbers in the list can be sorted by clicking on the column headers. The right-click
menu on the column header provides a handy way to show/hide unnecessary columns. 

You can select a backup number by right-clicking it and choosing Check Selected (or uncheck it
using Uncheck Selected). The right-click menu also allows selecting all backup numbers (Check
all) or unselecting them (Uncheck all).

Using the Priority  slider  you can set  the execution speed compared to the  rest  of  the  running
processes on your computer.  Default  is  Normal  priority,  but  there  are  other  4  priority  levels:
Lowest priority,  Low priority,  High priority and Highest priority.  On Lowest  priority  the
process  will  consume  the  minimum  amount  of  computer  resources  but  will  take  the  longer  to
complete,  while  Highest  priority  will  consume  the  highest  amount  of  computer  resources  but
will take the least to complete.

Filter backups by date

Newer than
If  checked  backup  numbers  that  are  newer  than  the  selected  date  will  be  removed  when  the
Clean operation is executed.

Older than 
If checked backup numbers that are older than the selected date will be removed when the Clean
operation is executed.

Older than (fixed date)
The  backup  numbers  that  are  Older  than  a  certain  fixed  date  will  be  deleted  when  the  Clean
operation is executed.

Filter by backup type

Do not delete full backups 
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If this is checked, the full backups will be kept even if they fall into the range of files filtered for
deletion.

Do not delete differential backups
If  this  is  checked,  the  differential  backups  will  be  kept  even  if  they  fall  into  the  range  of  files
filtered for deletion. Note that this option is available only when Do not delete full backups  is
checked, because differential backups depend on full backups.

Reset to filters
Pressing this will ignore any manual selection done and restore the default selection based on the
filters applied.

Clean the destination folder
Deletes any files and folders inside the destination folder even if they are not related to the
backup job.
 

5.14 Erase CD/DVD/Blu-ray

The  Erase  CD/DVD/Blu-ray  window  can  be  opened  from  the  Tools->Erase  CD/DVD/Blu-
ray... menu item.

 

When the window is shown, devices capable of writing to CD, DVD or Blu-ray disc are listed in it.
The first device from the list is selected by default.
A summary of properties is shown for each device (calculated by Backup4all's internal burner):

· Maximum read speed of device - shows the maximum reading speed of the device (kb/
s)

· Maximum write speed of device - shows the maximum writing speed of the device (kb/
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s)
· Reading capabilities - displays a list of media the device can read from
· Writing capabilities - displays a list of media the device can write to
· Disk type - shows the type of media inserted
· Sessions on disk - number of sessions on the disk
· Disk free space - free space on disk
· Disk size - total size of disk
· Maximum read speed of media - maximum reading speed of media
· Maximum write speed of media - maximum writing speed of media

When an erase is performed, the progress bar shows the percentage of the operation completed.

Options

Erase
Erases the CD/DVD/Blu-ray based on the selection from the combo:

· Quick erase - disk appears to be empty, but the data is not physically erased (selected by
default)

· Full erase - will physically erase all data on disk. Takes longer to perform

Load
Closes the CD/DVD/Blu-ray tray. The button is enabled only when a device is selected.
 
Eject
Opens the CD/DVD/Blu-ray tray. The button is enabled only when a device is selected.
 
Refresh
Will reload all information about the CD/DVD/Blu-ray burners.

Close
Closes the Erase CD/DVD/Blu-ray window.
 

5.15 Plugins

The Manage Plugins window allows you to add, remove, enable or disable the Backup4ll plugins.
After  installing  a  plugin,  you  can  use  it  on  the  What  do  you  want  to  backup  page  when
creating  a  new  backup  job  using  the  New  Backup  Wizard  or  on  the  Sources  page  using
Advanced mode (Backup Properties).
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Add
Press this button to install a new backup plugin. 
You will be asked to select the plugin file location from your computer. Multiple plugin files can be
selected and open. 

Delete 
Use this button to remove one or more selected plugins from the list. This plugins will be removed
from the New Backup Wizard too.
Please note that if you delete a plugin from Backup4all, all  backup jobs using that plugin will  be
removed when you restart Backup4all.

Properties
Pressing this button will open a window with details about the selected plugin and its creator as:
Plugin Name, File Name, Plugin GUID, Company, Company Site and Company E-mail.

Get Plugins
Pressing this button will open our internet website on the Free Backup Plugins page.
Here you can download plugins to be used when creating backup jobs.

Close
Press this button to close the Manage Plugins window.
 

5.16 Logging

Backup4all provides a log engine that helps you track the backup, restore and test operations. It
is  composed  of  four  subsystems:  backup  logging,  restore  logging,  test  logging  and  cleanup
logging.  Log  files  are  accessible  from  the  View->Job  Logs  menu  item.  You  can  also  see  an
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"overview" of all three subsystems by selecting the View Application Log menu item.
 
For each operation the system logs:

· start time and date
· the operation
· errors or warnings
· end time and date

The Tools->Options->Logs and history configuration window provides additional options that
you can select to further customize the logging process.

Content

Log detailed information
If  this  option  is  enabled,  the  logs  will  contain  information  about  every  file  used  in  the  backup,
restore or test process.

Include summary in log
If this option is checked, the logs will include all the text available in the Summary view.

Log folder

After a long period the application will generate a large number of log files. Since all the log files
are stored in the same folder,  the system has an option  to limit  the size of  the log  folder.  Just
select Restricted to and choose a Size and Unit for the log folder (default  is 10MB). If  the log
file of the running backup job is larger than the limit, it will still be stored in the log folder. When
the same operation will run again, the previous log file will be deleted.
 

Backup Logging

 
· Checking sources/destination
· Creating file list
· Archiving files
· Merging files
· Burning CD, DVD or Blu-ray
· Saving catalog

Other information added to the logs: the total number of files added to backup, the total  size of
files added to backup and the number of files excluded.

Restore Logging
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Logged operations:
Logged operation (except mirror backup): Processing zip file. The total number of restore files
is logged and the start/end time of restoring.

Test Logging

Logged operations: Testing zip file or Testing files (for mirror backup without zip). The result
of the operation is also logged.

Cleanup Logging

Logged operations: Cleanup. Shows the backup numbers that are deleted and logs the result of
the operation.

5.17 System Tray

When is Backup4all shown in the system tray?

Backup4all  is  minimized to the system tray when the Minimize to tray option from the Tools-
>Options->Startup  window  is  checked  and  the  user  minimizes  the  main  window.  When  the
Close to tray option is  checked Backup4all  will  not exit  when you press the Close  button,  but
instead it will always be displayed in the system tray .



Backup4all 476

Backup4all 4 User Manual Copyright © 2010 Softland

The right-click menu of the tray icon allows to:
· Show/Hide - shows/hides Backup4all's main window
· Backup Group  -  lists  all  the existing groups,  to back them up without  opening the main

window
· Exit - closes Backup4all completely and removes it from the system tray.

Tray Icon Hints:
1) When backups are executed, restored or tested, the tray icon is animated and the name of
the backup jobs are shown in the hint along with the current operation.

2) If the application is idle the Backup4all 4 text is displayed in the hint.
3)  When  a  backup  is  finished  with  errors,  these  are  shown  in  the  tray  icon  too.  The
information will disappear when the main window of the application is opened. If  you do not
wish to see the information in case of errors, just uncheck Show errors in tray from the Tools-
>Options->Startup window.

 

5.18 Keyboard Shortcuts

Keyboard shortcuts configured in Backup4all:

 New backup wizard - CTRL + N

 Open backup - CTRL + O

 Backup job properties - CTRL + P

 Brief - F4
· Explore - F2
· Backup view - CTRL + F2
· Statistics - F3
· Summary - CTRL + F4

 Refresh - F5

 Execute backup - F6
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 Restore - F7

 Pause - CTRL + F8

 Stop - CTRL + S

 Cancel - F8

 Test - F9

 Show New Files - CTRL + 1

 Show Unchanged Files - CTRL + 2

 Show Modified Files - CTRL + 3

 Show Excluded Files - CTRL + 4

 Show Deleted Files - CTRL + 5

 Expand All - CTRL + 6

 Collapse All - CTRL + 7

 Focus menu - F10
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6 New Backup Wizard

6.1 Overview

Using  the  New Backup  Wizard  you  can  easily  create  a  new  backup  job.  The  steps  in  wizard
must be followed in the given order.

If you want to create a new backup job using advanced options, you can do that by pressing the
Advanced mode  button  that  will  open  the  Backup  Properties  window.  All  settings  from  the
New Backup Wizard are included in the Backup Properties.
 
The  New  Backup  Wizard  will  be  used  to  create  new  backup  jobs,  if  the  Use  New  Backup
Wizard  to  create  backup  jobs  option  (from  the  Other   section  in  Tools->Options-
>Preferences) is checked. If that option is not checked, the Backup Properties will be used to
create new backup jobs.
 

6.2 Name and destination

In the first step of the New Backup Wizard you can configure the backup name and the backup
destination.
 

 
Name your backup

Backup Name 
Enter  the  name  of  the  backup  job.  This  name  will  appear  in  the  backup  list,  right  under  the
chosen picture. This field is mandatory.
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The name of the backup job is closely related to the name of the subdirectory in destination that
contains zipped and mirrored files and to the name of the catalog. That is why when you rename
the backup job, the name of the catalog and the name of the subdirectory from destination are
also changed if possible.
If  the  destination  is  on  HDD  (local),  LAN  (network)  FTP  or  SFTP  (remote)  the  name  of  the
subdirectory and the name of the catalog can be changed, except for the case when you do not
have enough permission to rename or some files are locked.
If the destination is on a removable disk CD, DVD or Blu-ray disc, floppy disc and you have run
the backup job, the catalog and the subdirectory in destination are already created and they will
not be changed. If the backup job has not been run yet, then the catalog and the subdirectory will
be created with a name similar to the backup job at first backup run.

Where do you want to save your backup

User can select one of the available destinations:
· Local:  hard disk  drive,  floppy drive,  zip drive,  CD/DVD/Blu-ray  drive,  USB drive,  mapped

network drive
· Network: UNC network drive
· FTP: remote FTP locations
· SFTP: remote SFTP locations

 

6.2.1 Local

You can  use  a  valid  local  destination  for  your  backup:  hard  disk  drives,  floppy  disk  drives,  zip
drives, CD, DVD or Blu-ray drives, USB drives or other removable media.
The Local option is selected by default when you define a new backup. From the Drive list, you
can select  either one of  your hard disk  partitions,  mapped network drives, the floppy disk,  CD/
DVD/Blu-ray drive or other removable drive. By default, the first partition is selected (usually C:).
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In  the  Folder  where  to  perform  the  backup  field  by  default  it  is  the  path  to  the  My
Backup4all  4  folder  (\Users\<user  name>\Documents\MyBackup4all  4).  You  can  click  the
Browse button and select a destination folder of your choice where the backup will be stored.

If the destination drive is missing (when the network is disconnected for instance or floppy, CD,
DVD or Blu-ray is missing), an error message is shown containing the list of missing drives. The
user can choose Cancel to stop the backup process or Retry to check the drive again. 
 

6.2.2 Network

You  can  use  a  network  destination  for  your  backup  by  selecting  the  Network  option  in  the
Where do you want to save your backup? section.
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Click the Browse button and go through the My Network Places to select a destination where
the backup will be stored.

You can also enter  network paths  in  the Folder field.  Only a full  path is  allowed.  For  example,
suppose \\Backup_Server\PC1  is  mapped on your workstation as drive X,  then the following
paths  are  both  valid  and  indicate  the  same  folder:  \\Backup_Server\PC1\Backup  or  X:
\Backup.

Make sure you can write in the destination and in the selected folder (you have the proper rights
and the media is not write-protected) before finishing the backup configuration. You can enter an
User name and Password to access the network destination if it requires authentication. If you
are  logged  in  as  an  user  that  has  rights  to  write  to  the  specified  network  destination,  you  can
check  the  First  use  Windows  auth.  option.  What  this  option  does  is  that  it  checks  on  the
network destination if the logged in user has rights to access it.
After entering the path and eventually the username and password, use the Test button to see if
the  destination  is  reachable  and  that  you  have  sufficient  rights  to  access  it.  The  network
connection was tested successfully pop-up message means that the network destination was
accessible.  In  case  of  insufficient  rights  the  following  error  message  will  appear:  Network
connection error. Access is denied. In this case you have to either make sure that the entered
username and password  values  are correct,  or  contact  the  network  administrator  to  obtain  the
necessary rights.

If the destination is missing (when the network is disconnected), an error message is shown.
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The  user  can  choose  Cancel  to  stop  the  backup  process  or  Retry  to  check  the  network
connection again. 
 

6.2.3 FTP

Backup4all supports backing up to a remote computer or device using FTP (File Transfer Protocol)
connection.  This  is  a  practical  backup  destination  because  the  backed  up  data  can  be  easily
accessed from any other computer with an Internet connection. Select the FTP option  from the
Where do you want to save your backup? section to be able to configure the backup to FTP.

 

 
Use configuration
You  can  select  an  already  defined  FTP  configuration  given  that  you  added  one  in  the  Tools-
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>Options->FTP  window.  All  the fields  will  be  filled with  the information from the configuration
file. If no configuration was previously defined, you will have to enter the other details.

Host / Port
In this field you have to enter the name or IP address for the FTP server and a port if  different
than the default FTP port (21). The format is host:port; e.g. ftp.Backup4all.com:1002 will backup
to ftp.Backup4all.com connecting through port 1002.

Folder
Enter a folder name where the backup files will be stored on the remote computer via FTP. If the
folder does not exist, a new one is created with that name. If  that field is left blank, Backup4all
will automatically create a folder using the name of the backup job and place the backup files in
there.

User
In this field you can enter the user name for the FTP server.

Password
Type the password used for FTP server access.

There  are  FTP  servers  that  allow  anonymous  access  (public  FTP  servers).  You  can  connect  to
these types of FTP servers using as user name Anonymous and your email address as password.
It is not recommended to backup important files to public FTP servers.

By pressing the Test button you can check to see if the settings you have entered are correct. If
the test was successful, The ftp connection was tested successfully message will be displayed.
 

6.2.4 SFTP

Backup4all  supports  backing up to a remote  computer  or  device  using  SFTP  (SSH File  Transfer
Protocol)  connection.  This  is  a practical  backup destination because the backed up data  can  be
easily  accessed  from any  other  computer  with  an  Internet  connection.  Select  the  SFTP  option
from the Where do you want to save your backup? section to be able to configure the backup
to SFTP.
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Use configuration
You  can  select  an  already  defined  SFTP  configuration  given  that  you  added  one  in  the  Tools-
>Options->SFTP window. All the fields will be filled with the information from the configuration
file. If no configuration was previously defined, you will have to enter the other details.

Host / Port
In this field you have to enter the name or IP address for the SFTP server and a port if different
than  the  default  SFTP  port  (22).  The  format  is  host:port;  e.g.  ftp.Backup4all.com:1002  will
backup to ftp.Backup4all.com connecting through port 1002.

Folder
Enter a folder name where the backup files will be stored on the remote computer via SFTP. If the
folder does not exist, a new one is created with that name. If  that field is left blank, Backup4all
will automatically create a folder using the name of the backup job and place the backup files in
there.

User
In this field you can enter the user name for the SFTP server.

Password
Type the password used for SFTP server access.

There are SFTP servers that allow anonymous access (public SFTP servers).  You can connect  to
these types of SFTP servers using as user name Anonymous and your email address as password.
 It is not recommended to backup important files to public SFTP servers.
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By pressing the Test button you can check to see if the settings you have entered are correct. If
the test was successful, The sftp connection was tested successfully message will be displayed.

6.3 What do you want to backup?

In the second step of the New Backup Wizard, you must select the files and folders to be used
by Backup4all for the backup.
 

You can:
· add a whole folder by pressing the Add folder button
· add one or several files by pressing the Add files button
· remove any file or folder by selecting it and pressing the Remove button

· exclude subdirectories and files from backup by un-checking the thickbox 

You must add at least one file or directory in order to continue with the next step of the
wizard.

During backup, if the source drive is missing (when the network is  disconnected for  instance or
CD/DVD/Blu-ray is  missing),  a  warning  message  is  shown containing  the  list  of  missing  drives.
The user can choose Abort to stop the backup process, Retry to check the drive again, Ignore
to mark the source folder as deleted and continue with the next sources. 
If you have filters defined in Tools->Options->Filters, they will be listed in the Filters list. You can
use this filters to customize the backup sources selection. All filters  listed are include filters.  Do
not select any filter if you want to backup all files.
 
Filters list



New Backup Wizard 87

Backup4all 4 User Manual Copyright © 2010 Softland

In the right  side of  the  New  Backup  Wizard  window  there  is  the  Filters  list.  You  can  use  these
filters to customize the file selection. 
The filters  are defined in  Tools->Options->Filters.  Only the  filters  that  have  "Show filter  in
New  Backup  Wizard"  option  set  are  shown.  Filters  can  be  of  type  include  (backup  files  that
match the filter) or exclude (do not backup files that match the filter).
By  default,  the  list  contains  filters  to  exclude  temporary  and  system  files/folders  such  as:
hiberfil.sys, pagefile.sys, System Volume Information, Temp, etc. If you don't want to use a filter
from that list, simply clear (un-check) it. Clear all filters if you want to backup all files.

Tips:
· try to keep the number of checked files and folders greater than the number of unchecked

files and folders - backup process will run faster this way.
· you  can  add  files/folders  to  the  Sources  window  by  dragging  and  dropping  them  from

Windows Explorer.
 

6.4 How do you want to backup?

In the third step of the New Backup Wizard you can choose the backup type.
 

  

How do you want to backup?

From the drop-down list, you can choose one of the available options:
· Make full
· Make differential
· Make incremental



Backup4all 488

Backup4all 4 User Manual Copyright © 2010 Softland

· Make mirror

Make full
Full backup is the starting point for all other backups and contains all the data in the folders and
files that are selected to be backed up. Because full  backup stores all  files and folders, frequent
full  backups  result  in  faster  and  simpler  restore  operations.  Remember  that  when  you  choose
other backup types, restore jobs may take longer.
 
Make differential 
A differential backup contains all files that have changed since the last full backup. The advantage
of  a  differential  backup  is  that  it  shortens  restore  time  compared  to  an  incremental  backup.
However, if you perform the differential backup too many times, the size of the differential backup
might grow to be larger than the baseline full backup.
 
Make incremental
An  incremental  backup  stores  all  files  that  have  changed  since  the  last  full,  differential  or
incremental  backup.  The advantage  of  an  incremental  backup  is  that  it  takes  the  least  time  to
complete.  However,  during  a  restore  operation,  each  incremental  backup  must  be  processed,
which could result in a lengthy restore job.
   
Make mirror
A mirror backup is identical to a full backup, with the exception that the files are not compressed
in  zip  files  and  they  cannot  be  protected  with  a  password.  A  mirror  backup  is  most  frequently
used to create an exact copy of the backup data.  It has the benefit that the backup files can also
be readily accessed using tools like Windows Explorer.
If you choose the Make mirror option, you can also check the Compress option to zip each file
individually,  preserving  the  folder  structure.  This  allows  you  to  use  the  zip  compression  and
encryption features.

 
Encrypt?

Use this option if you want to add zip protection to your backups. Type the password you want to
use for this backup.
The  default  encryption  used  is  Advanced  Encryption  Standard  (AES),  the  best  choice  in  zip
protection,  but  recognized  only by  the latest  version of  third  party  zip  applications.  The  default
size of the encryption key is 128 bits. If you want to configure more encryption settings or choose
a stronger encryption key, press the Advanced mode button.
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7 Backup Properties

7.1 Overview

The Backup Properties window can be used to create new backup jobs in the advanced mode,
or to edit an existing backup job. 

By default, the New Backup Wizard will be used to create new backup jobs. To use the Backup
Properties when creating new jobs, uncheck the Use New Backup Wizard to create backup
jobs option from the Other section in Tools->Options->Preferences. 

 

7.2 General

The General page defines the appearance of the backup job in the backup list.

Name
Enter  the  name  of  the  backup  job.  This  name  will  appear  in  the  backup  list,  right  under  the
chosen picture. This field is mandatory.
The name of the backup job is closely related to the name of the subdirectory in destination that
contains zipped and mirrored files and to the name of the catalog. That is why when you rename
the backup job, the name of the catalog and the name of the subdirectory from destination are
also changed if possible.
If  the  destination  is  on  HDD  (local),  LAN  (network)  FTP  or  SFTP  (remote)  the  name  of  the
subdirectory and the name of the catalog can be always changed, except for the case when you
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do not have enough permission to rename or some files are locked.
If the destination is on a removable disk, CD, DVD or Blu-ray disc, floppy disc and you have run
the backup job, the catalog and the subdirectory in destination are already created and they will
not be changed. If the backup job has not been run yet, then the catalog and the subdirectory will
be created with a name similar to the backup job at first backup run.
 
Group
Select the group where you want the backup job to appear. If no group is available or you want to
define  a  new  group,  just  type  the  name  of  the  group  and  it  will  be  created.  This  field  is
mandatory.
 
Description
You can write in here a text describing the backup job defined 

Icon

Press the Change Icon button to manage the backup job icons.  This  icon  will  be  shown in  the
Backup List.  You can add a new icon by clicking on the Add  button. Only Windows icons (files
with ".ico" extension) or bitmaps (files with ".bmp" extension) can be added to the list. To remove
an icon from the list, you have to select it and then click on the Delete button. By default, each
new backup job icon will be the first icon from the Change Icon list. 
 

7.3 Destination

The Destination page defines where the backup archive will be stored.
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Destination

Valid destination types:
· Local hard drive
· External hard drive
· CD, DVD or Blu-ray
· Removable
· Network
· FTP server
· SFTP server

Selecting  a  backup  destination  type  on  the  Destination  page,  will  enable  the  options  on  the
corresponding type page.
You  can  also  change  the  backup  destination  from  any  destination  type  page  by  checking  the
Change destination to... option.
 
If you lost your backup job from the backup list  and you want to recreate it,  you can do so by
using  the  File->Open  backup  option  and  selecting  an  existing  ".bkc"  or  ".ini"  file.  The  same
action takes place  if  you double  click on the ".bkc"  file.  A  new backup  job  configuration  will  be
added to the backup list and the configuration of  the new backup job is  copied  from the ".bkc"
file.
 

7.3.1 Local hard drive

You can use a valid local hard disk destination for your backup. The Local hard drive option is
selected  by  default  when  you  define  a  new  backup.
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Destination

If  the  current  backup  destination  is  not  a  local  hard  drive,  you  can  change  it  by  checking  the
Change destination to local hard drive option. 
In  the  Folder  where  to  perform  the  backup  field  by  default  it  is  the  path  to  the  My
Backup4all  4  folder  (\Documents  and  Settings\<user  name>\My  Documents\MyBackup4all  4).
You can click on the Browse... button and select a location of your choice where the backup will
be stored.
In  destination  folder  field,  you  can  use  Environment  Variables  as  %Computername%,  %
SystemDrive%, %UserName% etc.
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7.3.2 External hard drive

You  can  select  an  external  hard  drive  as  destination  for  backup.

 

Destination

If the current backup destination is not an external hard drive, you can change it by checking the
Change destination to local hard drive option. 

From the External hard drive list, you can select either an USB or a Firewire external hard drive.
You can type  a  folder  name  in  the  Folder  field  or  you  can  click  the  Browse  button  to  choose
another folder where the backup will be stored.
In  destination  folder  field,  you  can  use  Environment  Variables  as  %Computername%,  %
SystemDrive%, %UserName% etc.

Lock the destination to this external hard drive
When  disconnecting  and  reconnecting  an  external  drive,  your  computer  may  not  assign  it  the
same drive  letter.  If  the drive  letter  was changed,  the backup  might  fail  because  Backup4all  is
trying to backup to the same old drive letter which probably does not exist.
Use this option if you want Backup4all to detect the external drive after its own serial number and
automatically change the backup destination according with the new drive letter.
You should not check this option if you use a rotation backup scheme with two or more external
hard drives.
By default, this option is not checked.
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Enable disk spanning
The  option  is  effective  when  there  is  not  enough  space  to  copy  all  files  in  the  external  drive
destination. If checked, the application will copy files to the destination until a file will not fit. Then
it  will  ask  you  for  another  drive  to  continue  with  the  rest  of  the  files.  If  the  option  is  not  set,
Backup4all will stop when the destination drive is full. 
By default, this option is not checked.
 

7.3.3 CD, DVD or Blu-ray

You can select a CD, DVD or Blu-ray drive as destination for backup.
 

 

Destination

If the current backup destination is not a CD, DVD or Blu-ray drive, you can change it by checking
the Change destination to CD, DVD or Blu-ray option.
You can type  a  folder  name  in  the  Folder  field  or  you  can  click  the  Browse  button  to  choose
another folder where the backup will be stored.
In  destination  folder  field,  you  can  use  Environment  Variables  as  %Computername%,  %
SystemDrive%, %UserName% etc.

Erase disk before writing
When this option is checked, the rewritable CD, DVD or Blu-ray disc is erased before burning the
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backup files. By default this option is not marked.

Write method

Burn using built-in driver
Backup4all has built-in burning capabilities. Depending on the option selected in CD, DVD or Blu-
ray  (from Tools->Options->Backup),  one  of  the  internal  burners   will  be  used  to  write  the  CD,
DVD or Blu-ray disc. This option is checked by default.
 
Speed
Use this option to specify a different speed for  burning the CD,  DVD or  Blu-ray  disc.  By default
this option is set to Maximum speed.
 
Use third-party packet writing software
UDF  is  a  platform-independent  file  system;  the  same  media  can  be  written  and  read  by  any
operating system or vendor. Each CD, DVD or Blu-ray disc must be UDF formatted before burning
otherwise the backup will  fail.  The  limitation  of  this  type  is  that  you  must  have  an  UDF  reader
installed on each computer you wish to use the CD, DVD or Blu-ray disc.

Volume label

Use custom prefix
You can type your own volume label prefix to customize the backups.

 

7.3.4 Removable

You can save your backup to a removable drive  (USB flash drive,  floppy etc)  as  destination for
backup.
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Destination

If  the  current  backup  destination  is  not  a  removable  drive,  you  can  change  it  by  checking  the
Change destination to removable disk option. 
You can type  a  folder  name  in  the  Folder  field  or  you  can  click  the  Browse  button  to  choose
another folder where the backup will be stored.
In  destination  folder  field,  you  can  use  Environment  Variables  as  %Computername%,  %
SystemDrive%, %UserName% etc.

Lock the destination to this external hard drive
When  disconnecting  and  reconnecting  an  external  drive,  your  computer  may  not  assign  it  the
same drive  letter.  If  the drive  letter  was changed,  the backup  might  fail  because  Backup4all  is
trying to backup to the same old drive letter which probably does not exist.
Use this option if you want Backup4all to detect the external drive after its own serial number and
automatically change the backup destination according with the new drive letter.
You should not check this option if you use a rotation backup scheme with two or more external
hard drives.
By default, this option is not checked.

Erase disk before writing
When this  option  is  checked,  the  removable  disk  is  erased  before  burning  the  backup  files.  By
default this option is not marked.
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Volume label

Use custom prefix
You can type your own volume label prefix to customize the backups.
 

7.3.5 Network

You  can  choose  to  save  your  backup  to  a  shared  network  drive  (another  computer  or  NAS).

 

Destination
You can  use  a  network  destination  for  your  backup  by  selecting  the  Network  option  from  the
Destination  window  or  by  checking  the  Change  destination  to  network  option  from  the
network page.
 
Click the Browse button to open My Network Places and select a destination where the backup
will be stored.
You can also enter network paths in the Network path (UNC) field. Only a full path is allowed.
For example, suppose \\Backup_Server\PC1 is  mapped on your workstation as drive X,  then
the  following  paths  are  both  valid  and  indicate  the  same  folder:  \\Backup_Server\PC1
\Backup or X:\Backup.
In  destination  folder  field,  you  can  use  Environment  Variables  as  %Computername%,  %
SystemDrive%, %UserName% etc.

Authentication
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Make sure you can write in the destination and in the selected folder (you have the proper rights
and the media is not write-protected) before finishing the backup configuration. You can enter an
User name and Password to access the network destination if it requires authentication. If you
are  logged  in  as  an  user  that  has  rights  to  write  to  the  specified  network  destination,  you  can
check the Try Windows user and password first option. What this option does is that it checks
on the network destination if the logged in user has rights to access it.

You  can  set  Backup4all  to  disconnect  and  reconnect  the  network  drive  if  already  connected  by
checking the Reconnect if already connected option. By default, this option is not checked.
After  entering  the  path  and  eventually  the  username/password,  use  the  Test  network
connection  button  to  see  if  the  destination  is  reachable  and  that  you  have  sufficient  rights  to
access it. The network connection was tested successfully pop-up message means that the
network destination was accessible. In case of insufficient rights the following error message will
appear: Network connection error.  Access  is  denied.  In this  case you have to either make
sure  that  the  entered  username/password  values  are  correct,  or  contact  the  network
administrator to obtain the necessary rights.
 
If the destination is missing (when the network is disconnected), an error message is shown. 

The  user  can  choose  Cancel  to  stop  the  backup  process  or  Retry  to  check  the  network
connection again. 
 

7.3.6 FTP server

Backup4all supports backing up to a remote computer or device using FTP (File Transfer Protocol)
connection.  This  is  a  practical  backup  destination  because  the  backed  up  data  can  be  easily
accessed from any other computer with an Internet connection. 
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Destination
 
Select the FTP server option from the Destination window to be able to configure the backup to
FTP.  If  the current backup destination is  not an FTP  server,  you can  change  it  by  checking  the
Change destination to FTP option.
 
Use existing configuration
Use  this  option  if  you  want  to  use  an  already  defined  FTP  location  in  Tools->Options->FTP.
From the drop-down list, select the FTP location you want to use.
The  advantage  is  that  if  you  use  the  same  FTP  destination  for  multiple  backup  jobs  and  a
modification  is  needed  for  destination,  you  can  change  only  the  FTP  configuration  from  Tools-
>Options->FTP and all backup jobs destinations will be updated.

Custom configuration
Use  this  option  to  add  a  new  FTP  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description

Here you can see a listing of the FTP settings.
If you configured a new FTP location or  you edit  an existing one,  you should use the Test FTP
connection  button  to  see  if  the  FTP  settings  are  correct.  If  the  test  was  successful,  The  ftp
connection was tested successfully message will be displayed.
Once you press the OK button, Backup4all will try to connect to the FTP server to see if a backup
catalog  already  exists  on  the  destination.  If  the  FTP  destination  is  not  available,  a  Cannot
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connect to the FTP server message is displayed in the status bar (bottom of the main window).
 

7.3.6.1 Edit configuration

This  window  is  shown when  selecting  Edit  configuration  from  the  Destination->FTP  server
window.

General

Reset to configuration
If you want to add a new FTP location, the <New> option should be selected. To edit an existing
FTP  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the  values  of  the
selected FTP.  

FTP server

· Server name or IP  -  In this field you have to enter  the name or  IP address for  the FTP
server

· Port - In this field you have to enter the port number if different than the default FTP ports
(21).

· Destination - Here you can enter the destination path if different than root.
· User name - If this is a private FTP server (no anonymous access allowed) enter the user

name for your account.
· Password - In this field enter the password for the FTP server.

Bandwidth limitation

Bandwidth limitation - allows setting different limitations for upload/download speeds:
· Limit upload speed - if checked you can set a maximum upload speed for the FTP transfer
· Limit  download  speed  -  if  checked  you  can  set  a  maximum  upload  speed  for  the  FTP
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transfer

Advanced

SSL encryption level - indicates the level of Transport Layer Security (TLS) required for control
channel and data channel connections to the FTP server:

· No SSL - the server does not require Secure Socket Layer transport
· Implicit SSL - implies that Secure Socket Layer is in use
· Only explicit SSL - allows the connection to the FTP server only if TLS is available.
· Explicit  SSL,  if  available  -  when  SSL  is  available,  uses  explicit  security  by  default.  The

server  allows  regular  FTP  sessions  without  encryption  as  well  as  encrypted  FTP  sessions
using SSL.

Use  passive  mode  for  transfers  (like  WWW  browsers)  -  each  file  transfer  (upload  or
download)  needs  an  additional  connection  for  the  data  stream.  Normally  (in  active  mode),  the
server  establishes  this  connection.  In  passive  mode,  however,  the  client  establishes  the
connection. This may be necessary through some firewalls, which do not allow connections from
outside.

Use  extended  passive  mode  -  the  FTP  Server  operates  exactly  the  same  as  passive  mode,
however it only transmits the port number (not broken into high and low bytes) and Backup4all is
to  assume  that  it  connects  to  the  same  IP  address  that  was  originally  connected  to.  Use  this
option if the normal passive mode connection failed.

Use XCRC when testing (if available) - if the server supports the XCRC extension Backup4all
can  verify  that  files  transferred  to  the  server  have  been  transmitted  correctly  using  the  CRC
information  received  from the  FTP  server.  This  results  in  faster  testing,  as  the  files  will  not  be
downloaded to perform the CRC testing.

Resume  upload/downloads  (if  available)  -  it  resume  the  backup  upload  if  the  server
supports resume command. 

Maximum file size - specify the maximum file size you want to have. Please note that many FTP
servers does not allow you to upload files larger than 2 GB.

Timeout - you can set the time interval (in seconds) that is allowed for no data transfer before
the transfer operation is interrupted and must be resumed. Default is 15 seconds.

Firewall

Proxy type - select one of the options below (supported by your firewall) if you use a proxy to
connect to the FTP:

· None  -  Sends the User name and optional Password for the FTP  server as  entered in  the
FTP window

· Send command USER - Sends the User name and optional Password defined in the proxy
settings, followed immediately by the User name and optional Password for the FTP server.

· Send command SITE - Sends the User name and optional Password defined in the proxy
settings, the SITE command with the Host value, and the User name and optional Password
for the FTP site.

· Send command OPEN -  Sends the User name and optional Password defined in the proxy
settings, sends the OPEN command with the Host value, and the User  name and optional
Password for the FTP site.

· USER user@firewalluser@hostname / PASS pass@firewallpass - Sends the command
USER user@proxyuser@host, then the command PASS pwd@proxypwd, or optionally PASS
pwd.

· Transparent -  Sends the User name and optional Password defined in the  proxy settings,
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followed immediately by the FTP server User name and optional Password.
Host name or IP - In this field you have to enter the name or IP address for the proxy server
(firewall).
Host port - Type the port number if different than the default port (80).
User name - This field is used to enter the proxy user name.
Password - In this field you can enter the password for the specified user name.
 

7.3.7 SFTP server

Backup4all  supports  backing up to a remote  computer  or  device  using  SFTP  (SSH File  Transfer
Protocol)  connection.  This  is  a practical  backup destination because the backed up data  can  be
easily accessed from any other computer with an Internet connection. 
 

Destination

Select the SFTP server option from the Destination window to be able to configure the backup
to SFTP. If the current backup destination is not an SFTP server, you can change it  by checking
the Change destination to SFTP option.
 
Use existing configuration
Use this option if you want to use an already defined SFTP location in Tools->Options->SFTP.
From the drop-down list, select the SFTP location you want to use.
The  advantage  is  that  if  you  use  the  same  SFTP  destination  for  multiple  backup  jobs  and  a
modification is  needed for  destination,  you  can  change  only  the  SFTP  configuration  from Tools-
>Options->SFTP and all backup jobs destinations will be updated.
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Custom configuration
Use  this  option  to  add  a  new  SFTP  location  or  to  edit  an  existing  one  by  pressing  the  Edit
configuration button. 

Description 

Here you can see a listing of the SFTP settings.
If you configured a new SFTP location or you edit an existing one, you should use the Test SFTP
connection  button  to  see  if  the  SFTP  settings  are  correct.  If  the  test  was  successful,  The  ftp
connection was tested successfully message will be displayed.
Once  you  press  the  OK  button,  Backup4all  will  try  to  connect  to  the  SFTP  server  to  see  if  a
backup  catalog  already  exists  on  the  destination.  If  the  SFTP  destination  is  not  available,  a
Cannot connect to the SFTP server message is displayed in the status bar (bottom of the main
window).

7.3.7.1 Edit configuration

This window is shown when selecting Edit configuration  from the Destination->SFTP server
window.

General
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Reset to configuration
If you want to add a new SFTP location, the <New> option should be selected. To edit an existing
SFTP  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the  values  of  the
selected SFTP.  

SFTP server

· Server name or IP - In this field you have to enter the name or IP address for the SFTP
server

· Port  -  In  this  field  you  have  to  enter  the  port  number  if  different  than  the  default  SFTP
ports (22).

· Destination - Here you can enter the destination path if different than root.
· User name - If this is a private SFTP server (no anonymous access allowed) enter the user

name for your account.
· Password - In this field enter the password for the SFTP server.

Private key

· None - no private key is used
· Key file - allows user to specify a key file that will be used
· Personal certificate store - allows user to import and use different certificate formats 

Bandwidth limitation

Bandwidth limitation - allows setting different limitations for upload/download speeds:
· Limit  upload  speed  -  if  checked  you  can  set  a  maximum  upload  speed  for  the  SFTP

transfer
· Limit  download speed  -  if  checked you can set  a maximum upload  speed  for  the  SFTP

transfer

Advanced

· Verify host key: If checked, the host key will be verified each time
· Maximum file  size  -  specify  the  maximum file  size  you  want  to  have.  Please  note  that

many SFTP servers does not allow you to upload files larger than 2 GB.
· Timeout  -  you can set  the time interval  (in  seconds) that  is  allowed for  no data  transfer

before the transfer operation is interrupted and must be resumed. Default is 15 seconds.

Authentication

You can  select  which  authentication  methods  will  be  used  when  backing  up.  Available  options:
publickey and password.
The priority of these options can also be changed.

Encryption

· Ciphers:  clear  or  select  the  check  boxes  to  specify  which  ciphers  you  want  to  allow  for
encrypting  SFTP  sessions.  A  Cipher  is  the  algorithm(s)  used  for  symmetric  session
encryption. To give a cipher a lower priority rating, select it with the mouse and then click
the Down button.

· MACs:  clear  or  select  the  check  boxes  to  specify  which  MACs  you  want  to  allow  for
encrypting SFTP  sessions.  A MAC (Message Authentication  Code)  is  the algorithm(s) used



Backup4all 4106

Backup4all 4 User Manual Copyright © 2010 Softland

for data integrity verification. To give a MAC a lower priority rating, select it with the mouse,
and then click the Down button.

Compression

SFTP  supports  the  use  of  data  compression  to  reduce  the  amount  of  data  that  is  transmitted.
Both the client  and server agree on a  compression  algorithm.  They  then  compress  data  before
sending and decompress data when it is received.
Typically,  zlib  compression  is  the  compression  algorithm  most  commonly  supported  in  SFTP
servers.  No  compression  is  set  as  the  default,  and  zlib  is  specified  as  an  option.  If  the  server
forces use of zlib compression it will happen automatically

7.4 Sources

The  Sources  page  defines  what  files  and  folders  will  be  used  by  Backup4all  for  the  backup.

You can:
· add a whole folder by pressing the Add folder button
· add one or several files by pressing the Add files button
· remove any file or folder by selecting it and pressing the Remove button

· exclude subdirectories and files from backup by un-checking the thickbox 
· select all files and folders by pressing the Check all button
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· unselect all files and folders by pressing the Uncheck all button

At least one source must be added to the backup job.
If the source drive is missing (when the network is disconnected for instance or CD/DVD/Blu-ray
is  missing),  a  warning  message  is  shown  containing  the  list  of  missing  drives.  The  user  can
choose Abort to stop the backup process, Retry  to check the drive again, Ignore  to mark the
source folder as deleted and continue with the next sources. 

Tips:
· try to keep the number of checked files and folders greater than the number of unchecked

files and folders - backup process will run faster this way.
· you  can  add  files/foders  to  the  Sources  window  by  dragging  and  dropping  them  from

Windows Explorer

 

7.5 Filters

The Filters  page defines files and folders filters to be applied to backup sources.  Only files  and
folders that match the filters will be added to backup.
You can use the Add include and Add exclude buttons to add filter rules for the current backup
job.

The system selects only files that match the include filter and do not match the exclude filter. This
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means the exclude filter is more powerful: if a file satisfies both include and exclude filters, it will
be excluded.

Include and exclude filters are composed from filter restrictions. Two or more filter restrictions in
the  include  filter  means  that  a  file  must  satisfy  at  least  one  restriction  to  be  included  in  the
backup.  Two  or  more  filter  restrictions  in  the  exclude  filter  means  that  a  file  must  satisfy  any
restriction to be excluded.

All filters with the Active box checked will be used by the current backup job. To disable a filter,
just uncheck the Active box.

Note:
Filters on files  and filters  on folders  must  be  created individually.  If  you  use  a  file  and  a  folder
filter condition in the same filter, files will be filtered only if both filter conditions were met. 

Example:
If you use a single filter for .jpg files and Temp folder, only the .jpg files from Temp folder will be
filtered. If you use separate filters for files and folders, all .jpg files and whole Temp folder will be
filtered.

You can manage filter restrictions using the buttons:
· Add include - this will open a new Filter Properties window from where you can add a new

include restriction to the filters list.
· Add exclude - this will open a new Filter Properties window from where you can add a new

exclude restriction to the filters list.
· Edit  -  will  open  the  selected  filter's  properties  window.  You  will  be  able  to  modify  the

selected restriction.
· Copy - this will create a copy of the selected filter.
· Delete - will remove the selected filter from the list of include or exclude filters.

 

7.5.1 Customize

On  the  Customize  page  you  can  override  the  main  backup  filter.  It  will  show  a  tree  with  all
selected sources for the backup job.
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The customized filter can be defined only for  folders.  That  is  why add button is  not enabled for
files. 

Any  customized  filter  completely  replaces  the  main  filter.  Once  defined,  the  customized  filter
applies on the current folder and recursively on all its subfolders until another customized filter is
met. The behavior is the same for include and exclude filters.

Suppose we have the folder structure in the picture above. Backup source is "D:\Backup sources".
A main filter is defined to include all  .txt and .doc files. Suppose we do not want to backup .txt
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files from "ccc" folder. For this we define a customized filter on "ccc" that includes only .doc files.

The result is that all .txt and .doc files will be included except the .txt files inside "ccc" folder as in
the picture bellow:

When  a  folder  is  selected,  the  Add  include  and  Add  exclude  buttons  from  the  bottom  are
activated  (these  are  activated  only  for  folders,  not  for  individual  files).  That  means  you  can
replace  the  main  filter  with  a  different  one.  The  customized  filter  is  valid  only  for  the  selected
folder  and  its  descendants.  Click  the  Add  include  or  Add  exclude  button  to  define  the
customized  filter.  This  will  open  a  Filter  Properties  window.  You  can  define  include  or  exclude
filters in this window just as you do in the Filter page.

All files and folders for which a customized filter is applied are shown in red color. You can Edit,
Copy or Delete a customized filter by selecting the folder and clicking one of the buttons bellow.
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7.6 Type

Backup  type

User can select one of these backup types:
· Full
· Differential
· Incremental
· Mirror

The backup type can be changed from the Type page in Backup Properties, or from a specific
type page, by checking the box to select that type as default backup type.
Full,  differential  and  incremental  backup  types  use  zip  compression  to  reduce  the  size  of  the
stored backup versions.
The  mirror  backup  type  creates  in  destination  an  exact  copy  of  the  source  file  without  zipping
them.

 
Save storage space?

To  keep  the  number  of  stored  zip  files  at  a  reasonable  number,  the  application  provides  three
options:  Limit  number  of  file  versions,  Limit  number  of  backups  and  Merge  backups.
These  options  either  delete  older  stored  backups  or  perform  an  internal  merge  to  keep  the
number of stored backups or file versions under the selected limit.
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The  Limit number of file versions, Limit number of backups and Merge backups options
cannot be used when the backup destination is on a removable media, CD, DVD or Blu-ray disc
etc.

By default the Limit number of file versions and  the  Limit number of backups options are
not enabled. This means that the system will keep all the stored backup versions. If you choose to
enable the Merge backups option, when the limit is reached the system will perform an internal
merge between the older versions keeping the number of stored backups equal to the specified
limit (the merge between zip files is necessary to keep at the latest file version from each zip file
to be merged).
However when changing between Mirror and Full,  Incremental or Differential,  the older versions
are deleted.

The Limit number of file versions option will delete from the backups only the files that have
more  versions  than  the  maximum  allowed  limit,  to  keep  the  number  of  versions  under  the
specified limit. 
The Limit number of backups option will delete the backups to maintain the maximum limit.
 

Other

If the Clear archive bit option is checked, the application will remove the Archive flag of the files
that were added to the backup.  By default  Backup4all  uses  the current comparison criteria  and
the information from catalog file to detect if a file was modified or not since the last backup, which
is more accurate than using only the Archive bit (as other backup programs do). However, if you
want  to  backup  files  based  only  on  the  Archive  bit  attribute,  you  can  change  the  comparison
criteria from the Properties->Type window.
 

7.6.1 Full

Full backup is the starting point for all other backups, and contains all the data in the folders and
files  that  are  selected  to  be  backed  up.  Because  the  full  backup  stores  all  files  and  folders,
frequent full backups result in faster and simpler restore operations. This backup type is slow on
large volumes of data, so it  is  recommended to be done periodically (each Week/Month) and in
between to use other backup types like Incremental or Differential. The advantage is that you
only need the result of one backup execution to make a full restore.
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If the Full type is not your default backup type, you can check the Select Full as the default
backup type option.

Customize prefix of backup files

Typically  the  name  of  the  zip  file  is  something  like:  "1_C.zip",  "1_D.zip"  etc.  (one  zip  for  each
drive).  The  names  of  these  zip  files  do  not  make  much  sense  for  the  user  but  they  can  be
customized by pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)
· Backup Number (<BACKUP NUMBER>)
· Backup Type (<BACKUP TYPE>)
· Backup Date (<DATE>)
· Backup Time (<TIME>)
· Backup Year (<YEAR>)
· Backup Month (<MONTH_MMM>)
· Backup Month - numeric (<MONTH_MM>)
· Backup Week (<WEEK>)
· Backup Day of Week (<DAY OF WEEK>)
· Backup Day (<DAY>)

You can also add your text in the edit tag field. Use the Preview button to see how the names of
the zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |
Therefore Backup4all will prompt you to change these characters if present in the Customize zip
name prefix field.
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7.6.2 Differential

A  differential  backup  contains  all  files  that  have  changed  since  the  last  full  backup.  The
advantage of a differential backup is that it shortens restore time compared to a full backup or an
incremental backup. However, if you perform the differential backup too many times, the size of
the differential backup might grow to be larger than the baseline full backup. At the first backup
execution the catalog was not created yet, so the application will perform a full backup. The rest
of  the  backups  contain  only  the  files  that  differ  from  the  latest  full  backup.

 
If the Differential type is not your default backup type, you can check the Select Differential
as the default backup type option.

Customize prefix of backup files
Typically  the  name  of  the  zip  file  is  something  like:  "1_C.zip",  "1_D.zip"  etc.  (one  zip  for  each
drive).  The  names  of  these  zip  files  do  not  make  much  sense  for  the  user  but  they  can  be
customized by pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)
· Backup Number (<BACKUP NUMBER>)
· Backup Type (<BACKUP TYPE>)
· Backup Date (<DATE>)
· Backup Time (<TIME>)
· Backup Year (<YEAR>)
· Backup Month (<MONTH_MMM>)
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· Backup Month - numeric (<MONTH_MM>)
· Backup Week (<WEEK>)
· Backup Day of Week (<DAY OF WEEK>)
· Backup Day (<DAY>)

You can also add your text in the edit tag field. Use the Preview button to see how the names of
the zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |
Therefore Backup4all will prompt you to change these characters if present in the Customize zip
name prefix field.

Automatically make full backup

If the differential exceeds % of full backup size
In time, the size of the differential can outgrow the full version. For maximum efficiency, the size
of the differential should be kept as small as possible. This option will trigger the creation of a full
backup when a certain percentage of the full backup will be exceeded (default is 50%).

Make full backup when the differential exceeds
If this is checked, Backup4all  will  trigger the creation of  a full  backup when that  custom size is
reached  (default is 1 MBytes).
 

7.6.3 Incremental

An  incremental  backup  stores  all  files  that  have  changed  since  the  last  full,  differential  or
incremental  backup.  The advantage  of  an  incremental  backup  is  that  it  takes  the  least  time  to
complete.  However,  during  a  restore  operation,  each  incremental  backup  is  processed,  which
could result in a lengthy restore job.
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If the Incremental type is not your default backup type, you can check the Select Incremental
as the default backup type option.

Customize prefix of backup files

Typically  the  name  of  the  zip  file  is  something  like:  "1_C.zip",  "1_D.zip"  etc.  (one  zip  for  each
drive).  The  names  of  these  zip  files  do  not  make  much  sense  for  the  user  but  they  can  be
customized by pressing the Insert tag button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)
· Backup Number (<BACKUP NUMBER>)
· Backup Type (<BACKUP TYPE>)
· Backup Date (<DATE>)
· Backup Time (<TIME>)
· Backup Year (<YEAR>)
· Backup Month (<MONTH_MMM>)
· Backup Month - numeric (<MONTH_MM>)
· Backup Week (<WEEK>)
· Backup Day of Week (<DAY OF WEEK>)
· Backup Day (<DAY>)

You can also add your text in the edit tag field. Use the Preview button to see how the names of
the zip files will look like.
Windows does not allow the following characters in the file name: / \ * ? : " < > |
Therefore Backup4all will prompt you to change these characters if present in the Customize zip
name prefix field.
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Automatically make full backup

Make full backup when all increments exceed % of full backup size
In time, the size of the incremental can outgrow the full version. For maximum efficiency, the size
of the incremental should be kept as small as possible. This option will trigger the creation of a full
backup when a certain percentage of the full backup will be exceeded (default is 50%).

Make full backup when all increments exceed
If this is checked, Backup4all  will  trigger the creation of  a full  backup when that  custom size is
reached  (default is 1 MBytes).
 

7.6.4 Mirror

A mirror backup is identical to a full backup, with the exception that the files and folders are not
compressed in zip files and they cannot be protected with a password. A mirror backup is  most
frequently used to create an exact copy of the backup source data. The sources folder tree will be
recreated in the destination.
This backup type is the fastest, provided that Fast mirror option is checked.

If  the  Mirror  type  is  not  your  default  backup  type,  you  can  check  the  Select  Mirror  as  the
default backup type option.

Create subfolder(s) in destination
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Use this option to create a subfolder in the destination. The name of the folder can be customized
by pressing the Insert tags button. Following tags are predefined:

· Backup Name (<BACKUP NAME>)
· Backup Number (<BACKUP NUMBER>)
· Backup Type (<BACKUP TYPE>)
· Backup Date (<DATE>)
· Backup Time (<TIME>)
· Backup Year (<YEAR>)
· Backup Month (<MONTH_MMM>)
· Backup Month - numerical (<MONTH_MM>)
· Backup Week (<WEEK>)
· Backup Day (<DAY>)

You can  also  add  your  text  in  tag  field.  Use  the  Preview  button  to  see  how  the  name  of  the
subfolder will look like.

Note  that  the  Fast  mirror  option  will  be  ignored  if  you  choose  to  create  subfolders  in  the
destination with a different name each time.

Options
 
Fast mirror (copy only new or modified files)
Use this option to make mirror backups even faster. When this option is set, Backup4all uses the
information  stored  in  ".bkc"  files  to  copy  only  new  or  modified  files  to  the  destination.  If  this
option is not set, the system will copy all files each time the backup is executed. By default this
option is checked.

Create full paths (including drive letter)
Sometimes  there  can  be  sources  with  the  same  names.  The  system  will  detect  this  conflict
situation and will show a warning message.
To avoid files to be overwritten check the Save full  folder  info  option. This  will  create the full
path of the source in the destination.
For example, suppose we have the backup source "C:\My Documents\My Pictures". Without this
option, only the My Pictures folder will  be created and its  subfolders.  With this  option  set,  the
destination  will  contain  the  C  folder,  My  Documents  inside  C  folder,  My  Pictures  inside  My
Documents folder and so on. By default this option is unchecked.
 
Copy files in a subfolder
If checked, the files will be copied in a subfolder of the destination folder (typically you will see a
".bkc"  file  and  a  folder  with  the  same  name).  If  the  option  is  not  set,  the  files  (and  folder
structure) will be copied directly into the destination folder. By default this option is checked.

Remove excluded or deleted files from backup
Use  this  option  to  remove  from the  backup  the  files  that  were  deleted  (or  excluded)  from  the
backup  sources.  When  you  select  this  option  (unchecked  by  default),  you'll  get  a  warning
message that the deleted files will  be removed from the backup too -  press Yes  if  you want to
continue.
 
Only if the source drive is available
Use this option to avoid removing your files from backup if the sources are not available  all  the
time.
If  you  don't  use  this  option,  when  the  source  files  are  not  reachable,  Backup4all  will  consider
them as being deleted or excluded.
The deleted or excluded files will be removed from the backup.
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Others

Zip the files
Use this option to zip each file individually.  The folder  structure will  be  preserved,  only the files
will be zipped. 
 
Copy NTFS security permissions
Use this option to copy the files NTFS security permissions

Copy NTFS alternate file streams
Use this option to copy the NTFS alternate file streams
 
Allow file splitting when spanning
The  option  is  effective  only  when  there  is  not  enough  space  in  the  destination  to  copy  all  files
(removable media is full, USB drive is full, etc.). If checked, the application will  copy files to the
destination until a file will not fit. Then it will split that file and continue with the rest of it on the
next  disk.  If  the option  is  not set,  files  are  not  split.  If  you  are  backing  up  media  files  (music,
videos)  you  should  uncheck  this  option  so  that  you  will  not  have  any  melody/movie  split.  By
default this option is checked.
 
Sort mirror files for optimized spanning
This option is useful when spanning the backup over multiple removable drives. If this is checked,
Backup4all  will  sort  the files  by  size (descending) before copying  them on the removable drive.
This way it will start with the larger files and put the smaller ones towards the end of the backup
(optimizing the space used on the removable drive). By default this option is not checked.
 
Be aware that you can restore only from the latest version of a mirror backup from the Backup4all
interface.  You can restore however  manually previous  versions  as  they  are accessible  from any
file manager, like Windows Explorer.
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7.7 Compression

On the Compression page, you can configure the compression and encryption settings.

Compression

Level
You can set different compression levels for the backup:

· Zip without compression (Fastest) - files are just copied inside the zip archive, without
any compression

· Low compression (Fast) - select this option if the size of the zip archive is not important,
but the speed of the backup is

· Normal compression (Medium) - this is usually the best choice because it  provides the
optimum rate between zip archive size and the backup speed

· Best compression (Slow)  -  use this compression level to reduce the zip archive  size as
much as possible (the backup speed is reduced)

Use  No compression  or  Low compression  if  you  backup  large  files  to  speed  up  the  backup
process.  Use  High  compression  when  you  want  to  create  the  smallest  archive  possible.  This
option takes more time if the files included in archive are large.

Do not compress files of type
The filter can be applied to increase the compression performance. It defines what types of files
to be stored uncompressed in the zip file. These are files that are already compressed (e.g. zip,
rar, mp3 or avi) and using the zip compression on them wouldn't result in a smaller sized backup.
You can use the already defined file types or you can add others using the Default compression
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filter  list  in  Tools->Options->Backup.  The  result  will  be  that  the  backup  will  take  less  time
when using compression.

Always use temporary folder to create zip files
If checked, the zip files  are created in  the temporary folder  and then moved to the destination
folder. This means that there should be enough free disk space on the drive where the temporary
folder is located.

When backing up to removable media (CD, DVD or Blu-ray disc, floppy, zip disk, etc.) this option
is  ignored,  the  zip  files  are  always  created  in  the  temporary  folder  and  then  copied  to  the
destination. When backing up to internal  hard drives  or  LAN,  you should uncheck this  option  to
speed up the backup execution. By default this option is not checked.
 
Use alternate zipping mode
If  not  checked  (default  zipping  mode),  each  file  is  compressed  in  blocks  that  are  immediately
added to the final zip file. If checked (alternate zipping mode), each file is compressed in blocks in
a temporary file. When the whole file is compressed in the temporary file, it is added to the final
zip file.
This option has effect only when backing up to internal hard drives and LAN. In all other cases this
option is  ignored.  When backing up to LAN  drives,  it  is  recommended  to  check  this  option  and
uncheck Always use temporary folder to create zip files option. When backing up to internal
hard drives, it is recommended to uncheck both options. By default this option is not checked.

Encrypt the zip files

No encryption
The zip files created are not protected by password for unauthorized access.
 
Strong encryption (AES)
This is the Advanced Encryption Standard, the best choice in zip protection, but recognized only
by the latest version of third party zip applications.
Backup4all supports AES encryption in three different strengths:

· 128 bit (strong) - size of the encryption key is 128 bits. This provides significantly better
security than standard zip 2.0 encryption.

· 192 bit (stronger) - size of the encryption key is 192 bits
· 256  bit  (strongest)  -  size  of  the  encryption  key  is  256  bits.  This  is  the  strongest

encryption method for zip files and it provides the best security.
 
Standard encryption (Zip2 compatible)
This  is  the  standard  Zip  2.0  encryption:  an  older  encryption  technique  that  provides  relatively
weak security compared to AES encryption. Zip 2.0 encryption format cannot provide protection
from  individuals  with  access  to  specialized  password  recovery  tools.  Its  advantage  over  AES
encryption is the compatibility with all third party zip applications.

Set password
After you press this button, a windows with the following fields will appear:

· New password
Manually enter the password you want to use for your zip files in this field
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· Confirm new password
Re-enter the password in this field to avoid typing errors.
· Old password

This  field  is  enabled  only  when  the  backup  job  already  has  a  password.  You  can  change  the
password only if you enter the old one in this field. This way only the owner of the backup will be
allowed to change the password.

The system makes it possible to set different passwords for the same backup job, so the backup
may contain zip files with different passwords.

Tips:
· when choosing a password, it  is  recommended that  you use a combination of  letters  and

numbers and at least 8 characters.
· Backup4all  does  not  store  passwords.  Make  sure  that  you  remember  all  passwords  that

have been used for a backup job, or you will not be able to restore your files.

 
Split (does not apply to Mirror backup type)

Split by size type
· Automatic
This is the default split option, meaning that the size of the zip is limited to the maximum file
size allowed by the file system.

· Predefined
The predefined values are provided for floppy disks, zip disks and different CD media types.

 

 
· Custom size
Sometimes these predefined values are not enough. Therefore you can select Custom size in
the combo and specify the maximum archive size you want.  The minimum span size is  512
kilobytes.  The  value  in  the  Size  field  means  that  each  span  should  not  exceed  this  value.
However, because of the zip algorithm limitation, the system might create spans with size up
to 32-64 kilobytes smaller than this value.

Split by file number type
· None



Backup Properties 123

Backup4all 4 User Manual Copyright © 2010 Softland

The split by file number option is disabled

· Custom files and folders number
Specify the maximum number of  files  and folders  to be  included in  a zip file.  This  option  is
useful if the application is using a lot of computer memory

Create independent splits
Using this option, each backup split can be independently restored. 
If  you have a large backup that  spans  over  several  removable media  (CD/DVD/Blu-ray,  floppy)
each spanned backup can be independently restored. Thus, if one of the spanned backup disks is
corrupted you can still restore the other files.
Example: you have a backup  that  was  spanned  over  20  CDs,  and  you  didn't  leave  the  Create
independent  splits  option  checked.  If  you  need  to  do  a  restore  and  one  of  the  zip  files  is
damaged, you lose all the data from the 20 CDs. Now, if the Create independent splits would
have been checked, even if one zip file would have been damaged, the data  from the other 19
could have been recovered.

Each zip file created with Backup4all can be extracted with standard zip utilities. However, when
using the Create  Independent  Splits  option  and backing up a file  big enough to be  split  into
more than one zip file, you will need to perform an additional operation if you want to restore that
file manually (without using Backup4all). 

  

7.8 Advanced

Options on this page affect the way a particular backup job is executed. Options that are marked
with (*) might not be available in your edition - check Feature Matrix for detailed information on
differences between editions. 
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Backup options

Use local catalogs (.bkc)
If this option is checked, Backup4all will  keep a local copy of the backup catalog for the current
backup  job.  Keeping  a  local  copy  of  the  catalog  is  recommended  in  most  cases,  except  when
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using a backup rotation scheme to back up to CD, DVD or Blu-ray disc, USB or external drives.
 
Example: the option Use locals catalogs  is  unchecked and you are performing an incremental
backup to DVD, but on each working day you're changing the DVD so that if one DVD fails you'll
still be able to recover most of your files. So on Monday you insert DVD 1, Backup4all runs and
performs a full backup. On Tuesday you insert DVD 2 (which is empty) and Backup4all performs a
full backup that includes all the data that's on DVD 1 plus the data that was added in between.
Now, if the Use local catalogs option would have been checked, Backup4all would have executed
on DVD 2 an incremental backup because of the full backup already executed on DVD 1.
 
Test after backup
If this option is set Backup4all will test the resulting backup for data integrity after every backup
process. Only the latest backup number will be tested after the backup execution. If you wish to
test other backup numbers you can do so from the Test Backup window.
 
Delete sources after successful backup
If this option is checked the backup sources will be deleted after performing the backup. 
This option is disabled if the Test after backup option is not enabled.

Ask for backup label before execution
If this option is set a window will be shown and will prompt the user to enter the label description
of the backup increment.
If you do not want to give a label to the current backup, leave the edit control empty. Check the
Don't label next backups if you do not want to see this window when the current backup job is
executed in the future. This feature is particularly useful for incremental backup types, when the
label can be seen as a milestone for all files backed up. These labels are visible on the Versions
page of the Restore Wizard and in the list of file versions in the Explore view.

Backup open files
If checked, the application will  back up open files.  Please  note backing up open files  is  possible
only on Windows XP or higher, if the file is stored on a local NTFS hard drive and the VSS service
is running and properly configured.

Store temporary catalog data in memory
If  checked,  the  catalog  file  will  be  stored  in  RAM  memory.  If  you  receive  an  "Out  of  memory"
warnings  or  you  have  a  large  catalog  file,  we  recommend  you  to  uncheck  that  option.  If
unchecked, the catalog file will be stored in a temporary file on your hard drive.

Backup priority
Using the slider  you can set  the backup execution priority  compared to  the  rest  of  the  running
processes on your system. Setting it to Highest priority, for instance, will determine the system
to allocate most of its resources for this backup execution.

Run action before backup

Run program/action
Check this option and select one of the predefined actions or choose a different  executable  file.

You can either enter directly the path to the program (has to be between quotes) or click the 
button to browse for the file. Backup4all waits until the action is finished before proceeding with
the actual backup process.

The <Clear backup> predefined action deletes the ".bkc" file and all zip files associated with the
current backup job. If this action is set,  then the backup performed is a full  backup, even if the
backup  type  is  set  to  incremental  or  differential  .  You  can  customize  it  with  the  following
parameters (numbers can be changed as necessary):

· <Clear backup d=7> - Clear backup is executed only if 7 days have passed since the first
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backup increment (the full backup).
· <Clear backup n=10> - Clear backup is executed only if the number of file versions is 10.
· <Clear backup d=7 n=10>  -  Clear backup is executed if 7  days have passed since the

first backup increment (the full backup) or if the number of file versions is 10.
· <Clear  backup  dw=1,2,7>  -  Clear  backup  is  executed  only  in  the  first,  second  and

seventh  day  of  the  week  (Monday,  Tuesday  and  Sunday  in  the  given  example).  Valid
values: 1-7 (if a parameter outside of these values is set, it will be ignored).

· <Clear backup dm=23, 30> - Clear backup is executed only in the 23rd and 30th day of
the  month.  Valid  values:  1-31  (if  a  parameter  outside  of  these  values  is  set,  it  will  be
ignored, same as using the value 31 for a month having only 30 days).

 
Run only once
If  this  option  is  set,  the  action  will  run  only  once  at  the  next  backup  execution  and  the  Run
program/action option will be reset and disabled afterwards.

Abort backup when action fails
User can check this option to abort the backup if the action ran before the backup failed.
Backup4all uses the exit codes returned by the applications.
If the exit code is 0 (zero), it means the action was successful.
If the exit code is different than 0  (zero),  the action was not successful  and the backup will  be
aborted.

Backup4all returns exit codes after each task execution (backup, independent test or cleanup).
As a general case, if the backup was successful, the exit code is 0, otherwise is different. 
Here are the possible exit codes:
- if  backup was successful, the exit code is 0
- if there are parameter errors or syntax errors, the exit code is 1
- if  backup was aborted, the exit code is 2
- if  backup was finished with warnings, the exit code is 3
- if the independent test was finished with errors, the exit code is 4
- if cleanup was finished with errors, the exit code is 5
- if B4aCmd was not correctly installed, the exit code is 6

Run action after backup

Run program/action
Check this option and select one of the predefined actions or choose a different  executable  file.

You can either enter directly the path to the program (has to be between quotes) or click the 
button  to  browse  for  the  file.  Backup4all  does  not  wait  for  the  action  to  be  finished  before
proceeding.

Available predefined actions:
· <Stand by> - The computer will enter in the Stand by state after the backup is executed.
· <Hibernate> - Computer enters in Hibernate (if available) after the backup execution.
· <Log off> - Logs off current user.
· <Shut down> - Shuts down the computer after the backup was executed.

 
Run only once
If  this  option  is  set,  the  action  will  run  only  once  at  the  next  backup  execution  and  the  Run
program/action option will be reset and disabled.

Run program or action on
You  can  set  conditions  to  run  the  action  after  the  backup:  on  Success,  on  Warnings  or  on
Errors. You can check multiple options or a single one, but at least one option must be checked.

Comparison



Backup Properties 127

Backup4all 4 User Manual Copyright © 2010 Softland

 
Criteria
This section contains special settings for advanced file comparison. You can set what properties of
a file will be used when deciding if a file was modified or not.
 
There is a list of quick sets to choose for predefined comparison criteria:

· None - if this is selected, a warning window is shown asking you to confirm if you want the
Date  modified  criteria  disabled  or  not.  If  this  criterion  is  disabled,  Backup4all  will  only
backup files that have the size changed.

· Custom - this is the default option and has several important file properties and attributes
selected  as  comparison  criteria  (Size,  Date  modified,  Date  created,  Archived,  Hidden,
System, Read-Only).

· Archive  attribute  only  -  if  this  is  selected,  a  warning  window  is  shown  asking  you  to
confirm if you want the Date modified  criteria disabled or not. If  this criteria is disabled,
Backup4all will only backup files that have the archive attribute changed.

· FAT attributes - if this is selected, a set of File Allocation Table attributes will be used for
comparison

· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes
will be used for comparison. Note that these attributes are available only on Windows 2000,
Windows XP, Windows Server 2003, Windows Vista and Windows 7.

Available file properties are:
· Size - file size (it is mandatory)
· Date modified - the latest date and time when the file was modified (a warning message

is displayed if you uncheck it)
· Date created - the date and time when the file was created
· CRC32  -  the most  comprehensive criteria  because it  calculates  a checksum based on file

contents and compares it with the checksum from the backup (this slows the process)

Available file attributes are:
· Read-Only - file can be read, but not modified or deleted
· Archived  (unavailable  when  the  Clear  archive  bit  option  is  checked  from  the  Backup

Properties->Type  window)  -  file  attribute  used  for  backup.  When  a  file  is  created,  the
archive  bit  is  turned  on.  When  a  backup  program copies  the  file,  it  turns  off  the  archive
attribute.

· Hidden  -  files  marked  Hidden  do  not  normally  display  unless  the  file  manager  option  to
display them is selected

· System  -  files  marked System do not normally  display  unless  the  file  manager  option  to
display them is selected

· Compressed (only NTFS) - file that is made generally much smaller than the original size
of  file.  Decompression  occurs  automatically  when  the  file  is  read.  The  file  is  compressed
again when it is closed or saved.

· Temporary (only NTFS) - the file is being used for temporary storage.
· Encrypted  (only  NTFS)  -  file  is  encrypted  on  a  NTFS  volume  to  protect  it  from

unauthorized access
· Not indexed (only NTFS) - file not indexed by the content indexing service
· Offline  (only  NTFS)  -  content  of  the  file  is  not  immediately  available.  This  attribute

indicates that the file data has been physically moved to an offline storage.
· Reparse point (only NTFS) - reparse points are used as building blocks by Microsoft and

third-parties to enhance NTFS file system behavior.
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· Sparse file (only  NTFS)  -  in  a  sparse  file,  large  ranges  of  zeroes  may  not  require  disk
allocation. Space for nonzero data will be allocated as needed as the file is written.

If  you select  more than one  attribute,  Backup4all  will  consider  the  file  for  backup  if  any  of  the
attributes selected is changed.
Legacy (use archive bit)
If  this  is  selected,  Backup4all  will  determine  which  files  will  be  backed  up  by  verifying  if  the
archive bit attribute is set. If the archive bit attribute for a file is not set, that file will be ignored
(even  if  its  size  was  modified  for  instance).  Our  recommendation  is  to  use  the  Criteria  option
since it's more accurate than using the archive bit alone.
 
 
Play sounds after backup

Use this  section to set  sound notifications  to be  played when  the  backup  is  finished.  There  are
three types of sound notifications depending on the backup status: success, warning and error.

Play sounds
If checked then success, warning and error sounds will  be  played at  the end of  the backup.  By
default this option is not checked.

On success
It indicates the sound that will  be played when the backup is finished with  success.  The default

sound  is  <Default  beep  sound>,  but  you  can  change  it  using  the  Open  button  .  If  you

press the Play  button  you can hear the selected sound file.  To disable  this  sound you can
select from the drop-down box <No success sound>.

On warning
It indicates the sound that will be played when the backup is finished with warnings. The default

sound is  <Exclamation sound>,  but  you can change  this  using  the  Open  button  .  If  you

press the Play button   you can hear the selected sound file. To disable this sound you can
select from the drop-down box <No warning sound>.

On error
It  indicates  the sound that  will  be  played when the backup has failed  because of  an  error.  The

default sound is <Asterisk sound>, but you can change this using the Open button . If you

press the Play  button  you can hear the selected sound file.  To disable  this  sound you can
select from the drop-down box <No error sound>.

Open sounds
This  button  will  open  the  standard  Sounds  and  Multimedia  Properties->Sounds  window  of
the  operating  system  (that  can  also  be  opened  from  the  Control  Panel).  You  can  use  this  to
configure or troubleshoot your sounds settings.

7.9 Email

Use this section to set email notifications to be sent when the backup is finished. There are three
types  of  email  notifications  depending  on  the  backup  status:  success,  warning  and  error  email
notifications.
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Emails

Send emails to:
If checked then notification emails will be sent at the end of the backup, test or cleanup operation
to  the  specified  email  addresses  (email  addresses  must  be  separated  by  comma  to  be
recognized). This option can be checked/unchecked only if the Tools->Options->Email window
has the Enable email notification option checked.

Send emails to:
Specify the email address where the notification emails will be sent. You can enter multiple email
addresses separated by comma.

Log

Attach log file to email
If this option is checked, the backup log file will be attached to the email.

Compress the log file
Option  is  active  only  if  Attach  log  file  to  email  option  is  checked.  If  this  option  is  enabled,
Backup4all will zip the log file before sending it. Additionally you can encrypt the log file.
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No encryption
The zipped log file created is not protected by password for unauthorized access.

Zip(2) compatible encryption
This  is  the  standard  Zip  2.0  encryption:  an  older  encryption  technique  that  provides  relatively
weak security compared to AES encryption. Zip 2.0 encryption format cannot provide protection
from  individuals  with  access  to  specialized  password  recovery  tools.  Its  advantage  over  AES
encryption is the compatibility with all third party zip applications.

AES encryption(*)
This is the Advanced Encryption Standard, the best choice in zip protection, but recognized only
by the latest version of third party zip applications. Backup4all supports AES encryption in three
different strengths:

· 128 bit (strong) - size of the encryption key is 128 bits. This provides significantly better
security than standard zip 2.0 encryption.

· 192 bit (stronger) - size of the encryption key is 192 bits
· 256  bit  (strongest)  -  size  of  the  encryption  key  is  256  bits.  This  is  the  strongest

encryption method for zipped log file and it provides the best security.

Set password
After you press this button, a windows with the following fields will appear:

· New password
Manually enter the password you want to use for your zipped log file in this field. If  you
enter a password with less than 8 characters,  a warning window will  be  displayed when
you click OK notifying that the password is not secure enough.

 
· Confirm new password

Re-enter the password in this field to avoid typing errors.

· Old password
This  field  is  enabled only when the log  file  encryption  already  has  a  password.  You  can
change the password only if you enter the old one in this field. This way only the owner
will be allowed to change the password.
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Tips:
· when choosing a password, it  is  recommended that  you use a combination of  letters  and

numbers and at least 8 characters.
· Backup4all does not store passwords. Make sure that you remember the password used, or

you will not be able to extract the log file.

Email Messages

On successful backup send
It indicates the email that will be sent when the backup is finished with success. The default email

is  <Default  email>,  but  you can change it  using the Open  button .  If  you press the  Edit

button  you can modify the selected email  file  (except  the  default  email).  Also  there  is  the
option  to  choose  <No email>  if  you  don't  want  Backup4all  to  send  an  email  if  a  backup  was
successful.

On backup with warnings send
It  indicates  the  email  that  will  be  sent  when  the  backup  is  finished  with  warnings.  The  default

email is <Default email>, but you can change this using the Open button . If you press the

Edit  button  you can modify the selected email  file (except the default email).  Also there is
the option to choose <No email> if you don't want Backup4all to send an email if a backup was
completed and there were warnings during execution.

On backup with errors send 
It  indicates  the  email  that  will  be  sent  when  the  backup  has  failed  because  of  an  error.  The

default email  is  <Default email>,  but you can change this using the Open  button .  If  you

press the Edit  button  you can edit  the  selected  email  file  (except  the  default  email).  Also
there is the option to choose <No email> if you don't want Backup4all to send an email if there
were errors during the execution of the backup.

On successful test send 
It  indicates  the  email  that  will  be  sent  when  the  test  operation  is  finished  with  success.  The

default  email  is  <Default  email>,  but  you  can  change  it  using  the  Open  button  .  If  you

press the Edit button  you can modify the selected email file (except the default email). Also
there is the option to select <No email> if you don't want Backup4all to send an email if a test
operation was successful.

On test with errors send
It  indicates  the email  that  will  be  sent  when the  test  operation  failed  because  of  an  error.  The

default email  is  <Default email>,  but you can change this using the Open  button .  If  you

press the Edit button  you can modify the selected email file (except the default email). Also
there is the option to select <No email> if you don't want Backup4all to send an email  if there
were errors during the test operation.
 
On successful cleanup send
It indicates the email  that will  be sent when the cleanup operation is finished with success. The

default  email  is  <Default  email>,  but  you  can  change  it  using  the  Open  button  .  If  you
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press the Edit button  you can modify the selected email file (except the default email). Also
there  is  the option  to select  <No email>  if  you  don't  want  Backup4all  to  send  an  email  if  the
cleanup operation was successful.

On cleanup with error send
It indicates the email that will be sent when the cleanup operation failed because of an error. The

default email  is  <Default email>,  but you can change this using the Open  button .  If  you

press the Edit button  you can modify the selected email file (except the default email). Also
there is the option to select <No email> if you don't want Backup4all to send an email  if there
were errors during the cleanup operation.
  

Customizing emails

If  you  want  to  create  a  customized  email  to  be  sent  (on  success/warning/error),  the  email
template will have to include special tags that Backup4all will recognize and replace according to
the description (note that the format of the tag must be <#tag_name>):

· <#BACKUP_NAME> - will insert the name of the executed backup job
· <#GROUP_NAME> -  will insert the name of the backup group
· <#SOURCES> -  will insert the sources of the executed backup
· <#DEST_DRIVE> - will insert the destination drive letter
· <#DEST_DRIVE_TYPE> - will insert the destination drive type
· <#DEST_FOLDER> - will insert the name of the destination folder
· <#DEST_CATALOG_FILE> - will insert the name of the catalog file created
· <#BACKUP_TYPE> - will insert the backup type that was performed
· <#BACKUP_START_TIME> - will insert the start time of the backup executed
· <#BACKUP_END_TIME> - will insert the end time of the backup executed
· <#TEST_START_TIME> - will insert the start time of test
· <#TEST_END_TIME> - will insert end time of test
· <#LAST_BACKUP_SIZE_COMPR> - will insert the resulted size of the last backup
· <#TOTAL_BACKUP_SIZE> - will insert the total backup size
· <#REMAINING_DISC_SPACE> - will insert the remaining space on the destination drive
· <#NBR_FILES_ADDED> - will insert the number of files added to the backup
· <#SIZE_FILE_ADDED> - will insert the size of the added files
· <#NBR_FILE_WARNINGS> - will insert the number of warnings
· <#NBR_ERRORS> - will insert the number of errors
· <#LAST_LOG_NAME> - will insert the name of the last log file
· <#EXCLUDED_SOURCES> - will insert the list of sources excluded
· <#TESTED_VERSIONS> - will insert the list of tested backup numbers
· <#TEST_SUMMARY> - will insert the detailed list of test backup numbers
· <#REMOVED_VERSIONS> - will insert the list of backups removed after cleanup
· <#CLEANUP_SUMMARY> - will insert the detailed list of backup numbers removed
· <#CLEANUP_START_TIME> - will insert the start time of cleanup
· <#CLEANUP_END_TIME> - will insert the end time of cleanup
· <#PROCESSED_SIZE> - will insert the total size of the files removed

For  an  example  of  tag  usage,  open  one  of  the  5  default  emails.  The  emails  are  stored  in  text
format in application's directory (i.e. "C:\Program Files\Softland\Backup4all 4\") with the following
filenames:  SuccessFullEmail.txt,  WarningFullEmail.txt,  ErrorFullEmail.txt  for  backup
emails, TestSuccessFullEmail.txt and TestErrorFullEmail.txt for test emails.

The  subject  line  of  the  email  sent  can  be  customized  too  by  adding  the  following  line  at  the
beginning of the customized file that will be used by Backup4all as an email: <! Subject of the
email !>
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Here is an example of a customized email that can be sent when a cleanup operation is successful
(note that the first line of this will be used as the subject line of the email):

<!Cleanup for <#BACKUP_NAME> finished successfully at <#CLEANUP_END_TIME>!>
Cleanup for backup job <#BACKUP_NAME> at <#CLEANUP_START_TIME> finished successfully.
See log file <#LAST_LOG_NAME> for more information.
Removed backups : <#REMOVED_VERSIONS>
Removed version details:
<#CLEANUP_SUMMARY>
----- 
Total removed file size : <#PROCESSED_SIZE>
Free space on destination: <#REMAINING_DISC_SPACE>
Cleanup started at:  <#CLEANUP_START_TIME>
Cleanup finished at:  <#CLEANUP_END_TIME>
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8 Restore Wizard

8.1 Where and how to restore

Using the Restore Wizard you can restore from a backup job. In the first step you can choose
the destination, the priority of the execution and customize the restore operation if you wish.
 

Where do you want to restore?

Use original location
Copies the files from the zip backup into the original location. If a file with the same name already
exists, a dialog will be shown prompting for an action before the restore can continue.

Choose another location
Copies files from the zip backup to a different folder. If selected, you can choose a different folder
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to restore files from the backup.

Do not create drive letter folder
If checked, Backup4all will restore the files in the designated location using the original directory
structure. If  you select this option and you have files from multiple drives, some files might get
overwritten. For example,  if  you backed up your Documents and Settings  folder  from your C
drive, when you restore it  to a different location having the Do not create drive letter  folder
unchecked,  Backup4all  will  first  create  a  folder  named  C  and  in  it  place  the  Documents  and
Settings folder. If  you would have checked the Do not create drive letter  folder  option, the
folder named C wouldn't have been created.

How do you want to restore?

Restore the latest version of all files
Backup4all will restore the latest version for all the files in the backup.

Restore all files as of
Choose the date to which you want to restore the files. The restored files will be exactly as they
were on the selected date.

Note: If you used the Limit number of file versions option, restoring the files as of a specified
date could not restore all your files if some of them were deleted by the file version limitation.

Choose files and restore the latest version
Backup4all will restore the latest version for all the files in the backup. You will be able to filter the
files using the Preview page.

Choose/filter files and restore the latest version
Backup4all will restore the latest version of the files. Files that are excluded from backup are not
restored. Check the status of the files in the Explore view of the main screen.
 
Choose/filter files and restore any version
Lets you specify which version of the files will be restored. For example, you might restore all files
in their original state from the first backup number.
 
Restore excluded and deleted files
If  this  option  is  checked, the latest  version  of  all  files  will  be  restored,  even  if  these  files  were
excluded from the backup.

 
Preview files at the end of wizard
If checked, a preview page with the files to be restored will be shown at the end of wizard.

Using the slider from the bottom of the Restore Wizard window, you can set the restore execution
priority compared to the rest of the running processes on your system. For example, setting the
priority to Highest  priority,  will  determine the system to allocate most of  its  resources  for  the
restore execution.
 

8.2 What do you want to restore

This is the second step of the Restore Wizard.  It  appears only for  Choose files  and restore
from the latest  version,  Choose/filter files  and restore the latest  version and  Choose/
filter files and restore from any version options.
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You can uncheck the files you don't want to restore. By default, all files are checked.

Information provided for each file:
· File/Folder - Name of the file/folder
· Size - Size of the the file
· Modified - Date and time when the file version was last modified (at backup execution)
· Backup no. - The last backup number containing the file 

The file versions in the list can be sorted by clicking on the column headers. The right-click menu
on the column header provides a handy way to show/hide unnecessary columns (except the File/
Folder column which is grayed out).

 

8.3 To what date do you want to restore

This  is  the  third  step  of  the  Restore  Wizard  if  the  Choose/filter  files  and  restore  any
version option was chosen.
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Restore as of
This option allows you to restore your files and folders to a specified date.  Just select  the data,
press Apply and then press Finish.

The purpose of  this  step is  to let  you select  versions  to restore.  Use  left  mouse  clicks  together
with  SHIFT  and/or  CTRL  keys  to  select  several  backup  numbers  to  restore.  The  most  recent
version of a file in the selected backup number will be restored. If you select all backup numbers,
then a full restore is performed just as the Choose/filter files and restore the latest version
restore option.

Note: If you used the Limit number of file versions option, restoring the files as of a specified
date could not restore all your files if some of them were deleted by the file version limitation.

If you use the Mirror backup type, the Restore as of feature is not available. The Mirror backup
type does not keep track of file versions. Only the last version is available for restore.
 
Information provided for each version:

· Type - Type of the Backup. Each of the backup types is represented by a descriptive icon:

 Full,  Incremental,  Differential,  Mirror
· Backup Date - Date and time when the version was added to the backup
· Backup No. - Number of the backup increment
· File No. - Number of files in the backup
· Folder No. - Number of folders in the backup
· Comp. Size - Size of the file version (compressed)
· Uncomp. Size - Size of the file version (uncompressed)
· Label - Label of the backup number. This column is hidden by default
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8.4 Do you want to filter the files

This  is  the  third  step  of  the  Restore  Wizard  for  Choose/filter  files  and  restore  the  latest
version restore type. For Choose/filter files and restore any version restore type, this is the
fourth step. You can filter the files to be restored.
Its  behavior  is  the  same  as  the  Filters  page  of  the  New  Backup  Wizard  or  the  Backup
Properties window, except that the process is restore and not backup.

The Filters page defines files filters to be applied to files that are going to be restored. Only files
and folders that match the filters will be restored.

You can add include or exclude filters. By default all files are included in the list to be restored.

 

The system selects only files that match the include filter and do not match the exclude filter. This
means the exclude filter is more powerful: if a file satisfies both include and exclude filters, it will
not be processed by the system.
Include and exclude filters are composed from filter restrictions:

· two or more filter restrictions in the include filter means that a file must satisfy at least one
restriction to be restored.

· two  or  more  filter  restrictions  in  the  exclude  filter  means  that  a  file  must  satisfy  any
restriction to be excluded.

In the Type column you can see if the filter is for include or exclude. To change the filter type,
press the "Change to Include" or "Change to Exclude" button.

You can manage filter restrictions using the buttons:
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· Add include - this will open a new window from where you can add a new restriction to the
list of include filters.

· Add exclude  -  this will  open a new window from where you can add a new restriction to
the list of exclude filters.

· Edit - will open the same window as Add, with the selected filter's properties. You will  be
able to modify the selected restriction.

· Copy - will create a copy of the selected filter.
· Delete - will delete the selected filter from the list.

8.5 Preview the files to be restored

This page is the final step of the Restore Wizard. It appears only if the Preview files at the
end of wizard option is checked. The purpose of this step is to show a preview of the files that
will be restored. If any other customization is required, user must go back and reselect the files to
be restored.

 

For the Choose/filter files  and restore any version  restore type,  files  and folders  shown in
the tree are calculated based on selected backup versions. Files that have not been backed up in
the selected backup versions or were filtered will  not be shown in the tree. Selecting all  backup
versions in the Choose/filter files and restore any version restore type is the same as using
the Choose/filter files and restore the latest version type.
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9 File Filtering

9.1 Overview

File filtering in Backup4all provides an intuitive way to define what files and folders to back up or
restore.

Select Folders and Files for filtering
 
The files can be filtered when added to backup. On the "What do you want to backup" page, from
the Backup Wizard or Backup Properties->Sources page each file and folder is shown in the tree
with a checkbox in front of it. If you uncheck it, the file or folder will be excluded from the backup
or restore process. 

After applying filters, each file and folder is shown in the tree with a checkbox in front of it. If you
uncheck it, the file or folder will be excluded from the backup or restore process.

Filter
 
The role of the filter is to restrict the files from the sources or destination that will  participate in
the backup or restore process. The filter actually consists of two filters: the include filter and the
exclude filter.

Include filter shows which files will be included in the backup or restore process. If the filter type
is "Include", it means the files which match the filter will be included in backup.
Exclude filter shows the files that will be excluded from the backup or restore. If the filter type is
"Exclude", it means the files which match the filter will be excluded from backup.
You can change the filter type from Include to Exclude or from Exclude to Include if you press the
"Change to Include"/"Change to Exclude"  button.  If  no filters  are defined,  then all  the files  and
folders from sources will be backed up or restored.

Users can define their  own filters  in  Tools->Options->Filters  to be  used  any time they  need.
The defined filters can also be used in the New Backup Wizard. 
 
 
Customize
 
There are special situations when the main filter is not enough to define the files to be backed up
or restored. In this case, you can refine the filters adding individual filters for folders. The refined
filter applies to all the files and subfolders of that folder. All files and folders for which a refined
filter is applied are marked with red.
To remove a refined filter, select the folder, select the filter and press the Delete button.

 

9.2 File Filter

The Edit file filter item window is shown every time a file filter restriction is added or modified.
It can be opened by pressing the Add button from the Filters page (New Backup Wizard, Backup
Properties, Restore Wizard window or Tools->Options) or the Edit button (if filters are already
defined).
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What do you want to do?

User can Create  new  filter,  Create  new starting  from existing  filter  or  Use  existing  filter.
The existing filters are listed in the drop down list and they  can be  added,  edit  or  deleted from
Tools->Options->Filters
 

General 

In the Filter name field you can type the name of the created filter. By default, the "New filter
configuration" name is assigned. If you use an existing filter, the name of that filter is used.
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File name

Enabling this will allow defining filters based on file name pattern. 
Press Add and select an existing file extension from the Filter combo (*.doc, *.pdf, *.zip etc.). If
the extension does not exist in the combo, just type it in and press OK. You can use the Edit or
Delete buttons to modify/remove the file name filters defined.
  
File name patterns can include:

· * - it matches one or more letters. For example a*.doc matches all  files that start with a
and have .doc extension

· ? -  it  matches only one letter. For example a*.do? matches all  files that start with a and
have any extension composed of three letters, the first two being do

 
Folder name

Enabling this will allow defining filters based on folder name pattern. 
Enter  the  directory  name  that  you  want  to  filter  in  the  following  format:  *\directory_name\*
(leading *\ and ending \* are required). Backup4all will apply the filter to all the directories that
are called directory_name. If you want to apply the filter to directories containing a specific word,
you must enter it in the following format *\*keyword*\*. Now Backup4all will apply the filter to all
the directories that have the word keyword in their names. You can use the Edit or Delete buttons
to modify/remove the folder name filters defined.
You can also use environment variables when creating filters: %temp%, %SystemRoot% etc.

File attributes

Enabling this section allows the user to specify file filters depending on the file attributes.
There is a list of quick sets to choose for predefined filter criteria:

· Custom - this is the default option and allows you to check whatever attributes you want
· None - if this is selected all the file attributes check boxes are unchecked
· FAT attributes - if this is selected, a set of File Allocation Table attributes will be used

for file filtering.
· NTFS attributes - if this is selected, a set of NTFS (New Technology File System) attributes

will  be  used  for  filtering.  Note  that  these  attributes  are  available  only  on  Windows  2000,
Windows XP, Windows Server 2003, Windows Vista and Windows 7.

 
File attributes available for file filters:

· Read-Only - if checked files with read-only attribute will be selected
· Archived - if checked files with archived attribute will be selected
· Hidden - if checked files with hidden attribute will be selected
· System - if checked files with system attribute will be selected
· Compressed (only NTFS) - if checked files with compressed attribute will be selected
· Temporary (only NTFS) - if checked files with temporary attribute will be selected
· Encrypted (only NTFS) - if checked files with encrypted attribute will be selected
· Not indexed (only NTFS) - if checked files with "not indexed" attribute will be selected
· Offline (only NTFS) - if checked files with offline attribute will be selected
· Reparse point (only NTFS) - if checked files with reparse point attribute will be selected
· Sparse file (only NTFS) - if checked files with sparse file attribute will be selected

For example, if you want to include files with read-only and archived attributes set, you have to
check both attributes  checkboxes in  a single restriction.  If  you  want  to  include  files  with  read-
only or archived attributes set, you have to make two separate restrictions: one for read-only
and another for archived.
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File dates

This section allows the user to build restrictions based on file dates and times. To enable options
in this section, check the Filter by date option.
Filters in this section can be applied by selecting one of the available date filters:

· date accessed
· date and time accessed
· date modified
· date and time modified
· date created
· date and time created

You can compare these dates and times with a fixed date or a relative date: today, yesterday,
one week ago or one month ago.
Comparison operators available:

· < >  date (and time) not equal to fixed or relative date
· < =  date (and time) less than or equal to fixed or relative date
· > =  date (and time) greater than or equal to fixed or relative date
· <  date (and time) less than fixed or relative date
· >  date (and time) greater than fixed or relative date
· in interval - date (and time) in a particular time interval between the Start date and End

date

File size

This  section  provides  the  possibility  to  build  restrictions  based  on  the  file  size.  To  enable  the
options in this section, check the Filter by size option. You can enter a file size in the Size field
and  select  a  measurement  Unit.  The  filter  will  compare  the  file  size  on  disk  with  the  size  you
enter using the comparison filters you selected:

· < >  file size on disk not equal to the value in the Size field
· < =  file size on disk less than or equal to the value in the Size field
· > =  file size on disk greater than or equal to the value in the Size field
· <  file size on disk less than the value in the Size field
· >  file size on disk greater than the value in the Size field

 
Note:
Filters on files  and filters  on folders  must  be  created individually.  If  you  use  a  file  and  a  folder
filter condition in the same filter, files will be filtered only if both filter conditions were met. 

Examples
· If you use a single filter for .jpg files and Temp folder, only the .jpg files from Temp folder will

be filtered. If you use separate filters for files and folders, all .jpg files and whole Temp folder
will be filtered.

· Suppose you want to backup (or restore) all .pdf files accessed in the last month and all .doc
files modified in the last week, but you don't want to backup (or restore) system or hidden files.

Here are the steps to define this filter starting from the default filter:
1) Add a new restriction in the include filter: enable File name, add *.pdf file pattern and set
date accessed to be greater than or equal to fixed date one month ago; click OK
2) Add a new restriction: add *.doc file pattern and set date and time modified to be greater
than or equal to fixed date one week ago; click OK
3) Add a new restriction: enable File attributes and the System checkbox, then click OK
4) Add a new restriction: enable File attributes and the Hidden checkbox, then click OK
5) For the last two restrictions, check the Use as exclude filter boxes.
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10 Options

10.1 General

The  General  page  of  the  Options  window  (accessible  from  the  Tools,  Options  menu  item)
contains  general  settings  of  the  program.

 

 
Security
 Backup4all allows you to lock the program interface, using a password.
Press the Set password  button to add  or  change the password. Near this  button,  the security
status is displayed: "No password" or "Password protected".
When  opening  the  program's  interface,  if  the  interface  is  locked,  you  will  be  asked  for  the
password.
To remove the password, press the Set password button, type the old password and press OK. 
 

Language

In  the  Language  section  you  can  select  the  language  of  the  program  interface  by  choosing
another one from the drop down list. Only the languages that were installed with the program are
displayed.  The  language  of  the  interface  changes  only  after  the  Options  window  is  closed  by
pressing  the  OK  button.  The  selected  language  is  kept  as  long  as  you  don't  change  it  or  it
becomes invalid due to software updates.
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The text box below the Language field shows details about the selected language (like translator
name and contact information).
 

10.2 Preferences

The Preferences  page of  the Options  window (accessible from the Tools,  Options menu item)
contains  settings  related  to  the  display  of  the  Toolbar  menu.

Toolbar

Show Toolbar 
User can choose if the toolbar will be displayed or not. By default, this option is checked.

Show toolbar button hint
If  checked  a  hint  will  be  displayed  when  hovering  over  a  toolbar  button  with  the  mouse.  By
default this option is checked.

Show toolbar button captions
If checked the toolbar buttons will  display their caption. Uncheck if you need more space in the
main window. You can use the button hints in this case.  By default this option is checked.

Align caption to the right
If  checked the toolbar  buttons will  have their  caption displayed on the right  of  the icons,  if  not
they  will  be  shown  below  the  icons.  This  option  is  only  valid  if  the  Show  toolbar  button
captions option is checked. By default this option is not checked.
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Toolbar icon size
You may use this  drop down list  to select  the size of  the toolbar  buttons.  Possible  choices  are:
Small, Medium and Large. By default this option is set to Small.

Views

Default view
The selected view will be assigned as default to the Views button from the application toolbar. 
The possible views are: Brief, Explore, Backup, Statistics and Summary.

Show explorer icons
If checked a small  icon is shown for each file in the Explore view. The icon is  the standard icon
associated with the type of the file. You will see the same icons as in Windows Explorer. If the
Explore view contains a large number of files, you can uncheck this option to show files faster. By
default this option is checked.

Hide empty folders on expand all
If checked the folders that do not show any file in the Explore view will be automatically hidden
when pressing the Expand All button. By default this option is not checked.

Show context menu
If  checked  it  will  display  the  context  menu  when  right  clicking  on  a  file  or  folder  in  the  main
window's  Explore  view  or  the  Sources  page  of  the  Backup  Properties  and  New  Backup
Wizard windows. By default this option is checked.

Job list

Background color
Press the (...) button if you want change the background color of the main window's Backup List
and the button list of the Backup Properties window.
View list as 
Choose the listing mode for the backup jobs and groups in the Backup List. The possible choices
are: Tree, Icons and List. 
 
Sort backup jobs alphabetically in a group
If checked the backup jobs are sorted alphabetically in each backup group. By default this option
is not checked.

Measurement unit

Auto
If checked the file sizes are shown like in Windows Explorer. By default this option is checked.

Custom
If checked you can see all file sizes in the same unit. You can set the desired unit from the drop
down  list.  Possible  choices  are:  Bytes,  KB  (kilobytes),  MB  (megabytes)  or  GB  (gigabytes).  Be
advised that if you select  GB as a unit,  for  files  under  10MB the size will  be  shown as 0GB.  By
default this option is not checked.

Application priority

Users can move the application priority cursor to a higher or a lower value.
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External program  
Difference viewer: Choose an application to compare the selected file  version with  the source
file in Explore View. You can also use parameters for difference viewer application.

Other
 

NTFS daylight saving correction
The Windows NT File System (NTFS) reports wrong file times after the clock changes according to
daylight saving time rules. As a consequence, the program sees these files as changed and backs
them up. When you check this option these files will not be reported as modified. By default this
option is checked.

10.3 Startup

The  Startup  page  of  the  Options  window  (accessible  from  the  Tools,  Options  menu  item)
contains  startup  related  settings  of  the  program.
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Startup and tray
 
Show "Getting Started"
If checked, the "Getting Started" window is displayed when you start Backup4all.
 
Show tray icon
If checked the program icon is displayed in the Taskbar Notification Area.
 
Minimize to tray - Check this option if you want to show  Backup4all in the taskbar tray when
the application is minimized. If unchecked, the application is minimized normally to the Windows
taskbar. By default this option is not checked
 
Close to tray - Check this option if you want to show  Backup4all in the taskbar tray even when
you close it from the File->Exit menu or the title bar close button. If unchecked,  Backup4all will
terminate when you exit the application. By default this option is not checked
 
Show errors in tray -  The error icon appears when the application  is  minimized to tray and a
backup had errors. The error icon will  blink over the default  Backup4all  tray icon.  Uncheck this
option if you do not want to see the error icon in the tray. By default this option is checked.

Visualization mode

Manual Run - You can select the way  Backup4all's main window will be displayed after a normal
startup. The options are: Last window state, Normal and Maximized.
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10.4 Application folders

The Application folders page of the Options window (accessible from the Tools, Options menu
item) contains general settings of the program.

 
Override default destination folder
This is the folder used as destination for the newly created backup jobs. The existing backup job
destinations  will  not  be  affected  if  you  change  this  option  (you  have  to  manually  change  the

destination for them). You can use the Browse button  to select an existing folder. By default
this  option  is  set  to  the  "My  Documents\MyBackup4all  4\"  folder  of  your  Window  login  account
profile.

Override temporary folder
This folder is used by the compression engine to handle compressed files (.zip). Only a full path is
allowed. The recommendation is to set the temporary directory on the hard disk partition with the

most free space available. You can use the Browse  button  to select  an existing folder.  By
default the option is set to the operating system's temporary folder.
  

10.5 Backup

The  Backup  page  of  the  Options  window  (accessible  from  the  Tools,  Options  menu  item)
contains settings related to the backup operations.
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Confirmations
 
Warn before  completely  erasing  a  disk  -  Check  this  option  if  you  want  to  be  warned  each
time  Backup4all wants to completely erase a disk. By default this option is checked.

Show warnings dialog at the end of the backup - Check this option if you want to be notified
if  any  warnings  or  errors  appeared  while  performing  the  backup.  You  can  always  check  for
warnings and errors  in  the log  file.  The warning or  error  icon  is  shown over  the  backup  job  no
matter if this option is checked or not. By default this option is checked.

Show  success  messages  -  Check  this  option  if  you  want   Backup4all  to  pop-up  a  success
message  when  the  backup  or  restore  operation  was  executed  with  no  errors  or  warnings.  By
default this option is not checked.

Ask for a new disk before backup - Check this option if you want to be asked to enter a new
disk  before  backup  execution  starts.  This  way  you  can  have  different  backup  executions  on
different disks. By default this option is not checked.

Show disk label message after writing a disk - This option applies only when you back up to
removable media and the backups are spanned to multiple disks. If this option is set, you will be
asked to mark the disk  with  a label  after each disk  is  completely written.  The system suggests
you  the  disk  labels  and  will  refer  to  each  disk  using  its  label  (while  restoring).  By  default  this
option is checked.

Show file warnings - If checked file warnings like access denied, locked files etc. are displayed
to the user during backup execution. These warnings are also written  to the log  file.  By default
this option is checked.

Warn before canceling the backup - If checked a confirmation message will be displayed when
a backup is canceled before being completely executed.  By default this option is checked.
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Default compression filter

This  default  filter  is  applied  to  new  backup  jobs  by  default,  to  increase  the  compression
performance. It defines what types of files to be stored uncompressed in the zip file. These are
files  that  are already compressed (e.g.  zip,  rar,  mp3  or  avi)  and  using  the  zip  compression  on
them wouldn't result in a smaller sized backup. This can also be modified individually from each
backup job's Properties->Types->Advanced window in the Filters box.

 
When destination not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination location if it  is  not available. By default this option  is  set  to 3  attempts.  The second
number (Wait option) indicates how many seconds to wait between two consecutive attempts to
access the destination location. By default this option is set to 5 seconds.
 

Memory usage

This option allows you to change the memory usage level. You can move the memory indicator to
a lower or a higher level.
 

10.6 Logs and history

On the Logs and history page of the Options window (accessible from the Tools, Options menu
item) you can change log and history options.

Content



Options 155

Backup4all 4 User Manual Copyright © 2010 Softland

Log detailed information
If checked the program will log detailed information about all files handled by the backup, restore
or test process. By default this option is not checked.

Include summary in log
If  checked the logs will  contain  all  the  text  available  in  the  main  window's  Summary  view.  By
default this option is not checked.

Log folder

In this group you can set the size limits for the folder where the logs are stored. The path to the
logs is set on the File Locations page of the Options window.

Unlimited size
If  checked  the  log  folder  size  is  not  limited,  and  its  size  will  increase  as  needed.  After  a  long
period the program will generate a large number of log files, so you might want to clean up the
log folder manually. By default this option is not checked.

Restricted to
If checked the log folder size is limited to the value set in the Size field below. If the log file of the
running backup job is larger than the limit, it will still be stored in the log folder. When the same
operation will run again, the previous log file will be deleted. By default this option is checked.

The log folder size will be less or equal then the selected value. By default this option is set to 20
MB.
You can set the desired unit from the drop down list. Possible choices are: Bytes, KB (kilobytes),
MB (megabytes) or GB (gigabytes). By default this option is set to MB.

Log Viewer

Program
User  can  choose  which  program  to  be  used  when  opening  the  log  files  with  Backup4all.  The
available  options are: <Default  text  editor>,  <Notepad>  or  <Wordpad>.  User  can  also  browse
the computer to choose another program.

Log file extension
User can change the extension of log files. The available options are: log and txt.

10.7 Backup on demand

The Backup on demand page of the Options window (accessible from the Tools, Options menu
item) contains settings for the one touch button of some USB/FireWire devices.
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Some USB enclosures have a button to start the execution of an associated program. If you have
such a device, you can configure  Backup4all  to execute  a backup job or  a backup group when
this  button  is  pressed.  If  your  One  Touch  button  device  is  not  detected  by   Backup4all  (
Backup4all  is  not  natively  compatible  with  the  device),  you  could  use  the  command  line
parameters to create a command that can be associated to the One Touch button of your device.
 
  
Backup on demand 
Enable  Plug-and-Backup support
Use this option to enable the Plug-and-Backup functionality. If the option is set, you can choose
which  Backup  job  or  Backup  group  will  be  executed  when  the  portable  drive  is  plugged  in.
Sometimes (when the backup job or the backup group is deleted or renamed) the target backup
cannot be executed. In this case a dialog will be shown asking you to either create a new backup,
select another backup or disable the Plug-and-Backup functionality.
 

What to execute

Backup job
Use this option to select a backup job.

Backup group
Use this option to select a backup group.

What to display

On Backup
The  application  can:  show  nothing,  show  a  tray  popup  or  show  the  main  window.  By
default  this  option  is  set  to show nothing. If  the show the  main  window  option  is  selected,  the
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Hide when finished option becomes available too (checked by default).
 
Minimize to tray when finished option will  minimize the application  to  tray  after  the  backup
finishes.  This  option  works  only  if  the  application  was  started  by  Plug  and  backup.  If  the
application was already open, the option does not work.

10.8 CD, DVD or Blu-ray

The CD, DVD or Blu-ray page of the Options window (accessible from the Tools, Options menu
item) contains the settings of the CD, DVD or Blu-ray burners.

Engine

Use SCSI Pass Through Direct Layer (SPTD)
Selected by default. Backup4all  uses  this  internal  burning engine to write  CD,  DVD,  HD-DVD or
Blu-ray discs. SPTD is a new method of access to storage devices and has the ability to provide
direct control of devices without risk of compromising it by some malicious 3rd party filter drivers
or other "rootkit" applications. 
SPTD  is  currently  supported  only  on  Microsoft  OS  Windows  2000  and  above.  SPTD  (similar  to
other access layers) is not removed from your system after Backup4all uninstall, in order not to
disrupt other applications that may use it. 

Use native Win32 Interface (SPTI)
If you have problems backing up using the SPTD method, we recommend you to use this option.
  

Other
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Load CD, DVD or Blu-ray before backup
If checked, the CD, DVD or Blu-ray media is loaded before the execution of a backup. This option
is useful when the CD, DVD or Blu-ray disc was previously ejected by another process.

Eject CD, DVD or Blu-ray after backup
If  checked, the CD,  DVD or  Blu-ray  media  is  ejected,  but  not reloaded after burning process is
finished. By default this option is not checked.
 

10.9 FTP

The FTP page of the Options  window (accessible from the Tools,  Options menu item) contains
FTP settings.
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When FTP server not ready

The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination  server  if  it  is  not  available.  By  default  this  option  is  set  to  3  attempts.  The  second
number (wait option) indicates how many seconds to wait between two consecutive attempts to
access  the destination location.  By default  this  option  is  set  to  5  seconds.  This  option  is  useful
when the destination FTP server has restrictions (i.e. only 2 users logged in the same time, no. of
accesses  etc.)  and  insures  that  if  the  FTP  server  cannot  accept  your  connection,  it  will  not  be
"hammered" by sending log-in requests frequently.

Configurations

The Tools->Options->FTP window allows you to define FTP configurations that can be used on
the  Destination  page  in  the  New  Backup  Wizard  or  Backup  Properties  windows.  You  can
add, edit, copy or delete an FTP connection using this window.
In  order  to  add  a  new  FTP  connection  press  the  Add  button.  The  Define  FTP  configuration
window will appear in the list and you can enter the other settings for this connection.
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General

Configuration name
Enter here an arbitrary name for the connection. By default the New FTP configuration name is
assigned.

FTP Server

Server name or IP
In this field you have to enter the name or IP address for the FTP server

Port 
In this field you have to enter the port number if different than the default FTP ports (21).

Destination folder
Here  you  can  specify  a  destination  folder  on  the  remote  FTP  server  where  the  backup  will  be
stored.  If  the  entered  folder  does  not  exist,  it  will  be  created  on  the  server.  If  no  destination
folder is set, Backup4all will automatically create a folder using the name of the backup job.

User name
If this is a private FTP server (no anonymous access allowed) you have to enter the user name for
your account.

Password
In  this  field  you  can  enter  the  password  for  the  FTP  server.  There  are  FTP  servers  that  allow
anonymous access (public FTP servers). You can connect to these types of FTP servers using as
user  name Anonymous and your email  address as  password. It  is  not recommended to  backup
important files to public FTP servers. 

Bandwidth limitation

This section allows setting different limitations for upload/download speeds:
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· Limit upload speed - if checked you can set a maximum upload speed for the FTP transfer
· Limit  download  speed  -  if  checked  you  can  set  a  maximum  upload  speed  for  the  FTP

transfer

Advanced

SSL encryption level 
Indicates  the  level  of  Transport  Layer  Security  (TLS)  required  for  control  channel  and  data
channel connections to the FTP server:

· No SSL - the server does not require Secure Socket Layer transport
· Implicit SSL - implies that Secure Socket Layer is in use
· Only explicit SSL - allows the connection to the FTP server only if TLS is available.
· Explicit  SSL,  if  available  -  when  SSL  is  available,  uses  explicit  security  by  default.  The

server allows regular FTP sessions without encryption as well as encrypted FTP sessions using
SSL.

Use passive mode for transfers (like WWW browsers)
Each  file  transfer  (upload  or  download)  needs  an  additional  connection  for  the  data  stream.
Normally (in active mode), the server establishes this connection. In passive mode, however, the
client  establishes  the  connection.  This  may  be  necessary  through some  firewalls,  which  do  not
allow connections from outside.

Use extended passive mode
The FTP Server operates exactly the same as passive mode,  however  it  only transmits the port
number (not broken into high and low bytes) and Backup4all is to assume that it connects to the
same IP  address  that  was  originally  connected  to.  Use  this  option  if  the  normal  passive  mode
connection failed.

Use XCRC when testing (if available)
If  the  server  supports  the  XCRC  extension  Backup4all  can  verify  that  files  transferred  to  the
server have been transmitted correctly using the CRC information received from the FTP server.
This results in faster testing, as the files will not be downloaded to perform the CRC testing.

Timeout (seconds)
You can set the time interval (in seconds) that is allowed for no data transfer before the transfer
operation is interrupted and must be resumed. Default is 15 seconds.
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Firewall

Proxy type 
Select one of the options below (supported by your firewall) if you use a proxy to connect to the
FTP:

· None  -  Sends the User name and optional Password for the FTP  server as  entered in  the
FTP window

· Send command USER - Sends the User name and optional Password defined in the proxy
settings, followed immediately by the User name and optional Password for the FTP server.

· Send command SITE - Sends the User name and optional Password defined in the proxy
settings, the SITE command with the Host value, and the User name and optional Password
for the FTP site.

· Send command OPEN -  Sends the User name and optional Password defined in the proxy
settings, sends the OPEN command with the Host value, and the User  name and optional
Password for the FTP site.

· USER user@firewalluser@hostname / PASS pass@firewallpass - Sends the command
USER user@proxyuser@host, then the command PASS pwd@proxypwd, or optionally PASS
pwd.

· Transparent -  Sends the User name and optional Password defined in the  proxy settings,
followed immediately by the FTP server User name and optional Password.

Host name or IP 
In this field you have to enter the host name or IP address for the proxy server (firewall).

Host port
Enter the host port number in this field. By default, the port number is set to 80.

User name
This field is used to enter the proxy user name.

Password
In this field you can enter the password for the specified user name.
 

10.10 SFTP

The SFTP page of the Options window (accessible from the Tools, Options menu item) contains
SFTP settings.
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When SFTP server not ready
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The  first  number  (Retry  option)  indicates  how  many  times  the  application  tries  to  access  the
destination  server  if  it  is  not  available.  By  default  this  option  is  set  to  3  attempts.  The  second
number (wait option) indicates how many seconds to wait between two consecutive attempts to
access  the destination location.  By default  this  option  is  set  to  5  seconds.  This  option  is  useful
when the destination FTP server has restrictions (i.e. only 2 users logged in the same time, no. of
accesses  etc.)  and  insures  that  if  the  FTP  server  cannot  accept  your  connection,  it  will  not  be
"hammered" by sending log-in requests frequently.

Configurations

The Tools->Options->SFTP window allows you to define SFTP configurations that can be used
on the Destination page in the New Backup Wizard or Backup Properties windows. You can
add, edit, copy or delete an SFTP connection using this window.

In order to add a new SFTP connection press the Add  button. The Define SFTP configuration
window will appear in the list and you can enter the other settings for this connection.

General

Reset to configuration
If you want to add a new SFTP location, the <New> option should be selected. To edit an existing



Options 165

Backup4all 4 User Manual Copyright © 2010 Softland

SFTP  location,  select  it  from  the  drop-down  list.  All  fields  will  be  filled  with  the  values  of  the
selected SFTP.  

SFTP server

· Server name or IP - In this field you have to enter the name or IP address for the SFTP
server

· Port  -  In  this  field  you  have  to  enter  the  port  number  if  different  than  the  default  SFTP
ports (22).

· Destination - Here you can enter the destination path if different than root.
· User name - If this is a private SFTP server (no anonymous access allowed) enter the user

name for your account.
· Password - In this field enter the password for the SFTP server.

Private key

· None - no private key is used
· Key file - allows user to specify a key file that will be used
· Personal certificate store - allows user to import and use different certificate formats 

Bandwidth limitation

Bandwidth limitation - allows setting different limitations for upload/download speeds:
· Limit  upload  speed  -  if  checked  you  can  set  a  maximum  upload  speed  for  the  SFTP

transfer
· Limit  download speed  -  if  checked you can set  a maximum upload  speed  for  the  SFTP

transfer



Backup4all 4166

Backup4all 4 User Manual Copyright © 2010 Softland

Advanced

· Verify host key: If checked, the host key will be verified each time
· Maximum file  size  -  specify  the  maximum file  size  you  want  to  have.  Please  note  that

many SFTP servers does not allow you to upload files larger than 2 GB.
· Timeout  -  you can set  the time interval  (in  seconds) that  is  allowed for  no data  transfer

before the transfer operation is interrupted and must be resumed. Default is 15 seconds.

Authentication

You can  select  which  authentication  methods  will  be  used  when  backing  up.  Available  options:
publickey and password.
The priority of these options can also be changed.

Encryption

· Ciphers:  clear  or  select  the  check  boxes  to  specify  which  ciphers  you  want  to  allow  for
encrypting  SFTP  sessions.  A  Cipher  is  the  algorithm(s)  used  for  symmetric  session
encryption. To give a cipher a lower priority rating, select it with the mouse and then click
the Down button.
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· MACs:  clear  or  select  the  check  boxes  to  specify  which  MACs  you  want  to  allow  for
encrypting SFTP  sessions.  A MAC (Message Authentication  Code)  is  the algorithm(s) used
for data integrity verification. To give a MAC a lower priority rating, select it with the mouse,
and then click the Down button.

Compression

SFTP  supports  the  use  of  data  compression  to  reduce  the  amount  of  data  that  is  transmitted.
Both the client  and server agree on a  compression  algorithm.  They  then  compress  data  before
sending and decompress data when it is received.
Typically,  zlib  compression  is  the  compression  algorithm  most  commonly  supported  in  SFTP
servers.  No  compression  is  set  as  the  default,  and  zlib  is  specified  as  an  option.  If  the  server
forces use of zlib compression it will happen automatically 

10.11 Email

On the Email  page of the Options  window (accessible from the Tools, Options menu item) you
can set configurations necessary to send emails.
 

 

Email notifications 

Enable email notifications
If checked the email notifications are available in the backup jobs on the Advanced\Emails page
in  the  backup  job  Properties  or  New  Backup  Wizard  (accessible  from  the  File  menu).  By
default this option is not checked.
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SMTP server

Server Name or IP
Enter the DNS name or IP address of the SMTP server to be used to send emails (example: mail.
yourdomain.com) This field is mandatory.

Port
Enter the port number to be used by the SMTP server to send the emails. The default value is 25.

Use SSL
If checked the Transport Layer Security (TLS) will  be used for control channel and data channel
connections to the SMTP server. By default this option is not checked.

Send Test Email
Press Send Test Email  if  you want to test  the configuration you just  entered.  In  the  box  that
pops-up, enter the email address where you want to receive notifications and press OK. If all the
settings are correct, a test email should arrive in your specified email account.

Email addresses
 
From
Enter the sender's email address. If  you enter a wrong email  address, the email  notification will
not be sent. This field is mandatory.

Reply To
Optionally you can specify a different reply email address. If no value is entered the From email
will be used.

Authentication

Server requires authentication
If checked the SMTP server uses authentication and you will  need to supply a user name and a
password. By default this option is not checked.

User name
Enter the user name to be used when authenticating on the SMTP server.

Password
Enter the password to be used when authenticating on the SMTP server.

Dial-up connection

In  this  group  you  can  set  how  the  program  should  handle  dial-up  connections.  The  available
options are: Do not start, Automatically start-up, Manually start-up.

Do not start
If selected email notifications are sent only if your computer is already connected to the Internet.
If you have a connection but you are not connected the program will not dial for you.

Automatically start-up
If  selected  and  you  are  not  connected  to  the  Internet,  the  program  attempts  to  make  the
connection for you automatically.

Manually start-up
If selected and you are not connected to the Internet, the program asks you if it should connect.
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You can approve or deny the request.

Hang up when finished
If checked the dial-up connection will be closed after the notification email is sent.
 

10.12 Updates

On the Updates page of the Options window (accessible from the Tools, Options menu item) you
can configure Backup4all when to check for updates.

Check for updates

Check mode
User can choose one of these modes: 

· Manual - user will manually check for new updates. This option is selected by default.
· Reminder  -  the  program  will  remind  you  with  the  selected  frequency  to  check  for  new

updates 
· Automatically  -  the  program will  automatically  check  for  new updates  with  the  selected

frequency.

Frequency 
User can set the frequency for Backup4all to remind or to automatically check for new updates.

Check at application startup
If checked, the program will check for new updates at application startup.
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11 Help

11.1 Support Request

Before asking for support, please make sure you have installed the latest version of Backup4all.
Also  visit  our  online  Knowledgebase,  as  it  contains  valuable  information  and  your  questions
might already be answered there. 

If  you can’t  find an  answer  to  your  questions  in  our  Knowledgebase,  please  go  to  Backup4all’s
Help tab and click on Support Request. This will  open an email  and it  will  include at the bottom
some  basic  information  we  would  need  (application  build  number,  operating  system  and
registration details).

Please include in your support request the following details:
· Exactly what did you do?
· Can you reproduce the problem again?
· If possible send us a screenshot of the error message.

We might ask you for additional information, if we cannot reproduce the problem.

11.2 Purchasing and Registration

How to Know What Edition to Buy?
 
Backup4all has a trial period of 30 days. During these 30 days you have access to all application
features. After this period, you have to decide which edition you want to use: Professional edition
(fully featured application), Standard or Lite edition (not all features are available).
 
Please  read  the  What  edition  to  choose?  section  for  a  summary  of  differences  between  Lite,
Standard and Professional  edition. The  Feature  Matrix  section  presents  in  detail  the  differences
between Lite, Standard and Professional edition.

 

http://www.backup4all.com/kb/
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Register

The  Register  Backup4all  window  appears  when  clicking  on  Register  menu  item from the  Help
menu of Backup4all. This window also appears when the application starts if the trial period has
expired (the registration window might be different in the OEM editions).

On the Register Backup4all window (Help->Register), please copy and paste the exact values
as you received them by email in the Registration name and Registration key fields. Press the
 Register button bellow when you are ready.

If the registration information is valid, you will get a confirmation message saying Backup4all has
been successfully registered. After the confirmation message, you can see the registration details
at the bottom of the about box of Backup4all (Help->About Backup4all).
 
If you lost your registration key, please send us an email  to Sales Support. You should specify
your  purchase  information  (purchase  number  and  approximate  date),  the  name  (or  company
name)  and  email  address  you  used  to  buy  your  copy  of  Backup4all.  We  will  send  to  you  the
registration key again.
 
If you have questions or you experience problems related to the registration process, you can use
the General Support button (from Help->Register) under Support section to contact us. We
will be happy to assist you with the registration.

Buy now

In the Buy Now! section you'll see information on how to order Backup4all and pressing the Buy
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now! button opens the online web-page where you can purchase Backup4all.

After  completing the purchase,  a registration  key will  be  delivered  to  you  by  email.  This  key  is
required to register the program. It is recommended that you make a backup copy of this email
(e.g. print out a hard copy).
 
Backup4all  is  available  as  Shareware -  another way of  saying  Try  before  you  buy.   It  is  fully
functional for a period of 30 days. After 30 days, the program will  start only if you enter a valid
registration key (OEM version users might be asked to enter their registration keys sooner). You
can buy Backup4all online if you fill out the online purchase form.
 
There are two ways to start the order process:

· go to the Help menu of Backup4all and click on How to Order
· go to the Help menu, click Register and press the Buy now!  button from the Buy Now

section 
An online Buy Now  page will  be  opened  in  your  browser.  After  you  select  the  desired  edition,
press the Buy Now buttons (from the online ordering page) and the online ordering form will be
displayed.

Support

If you want to report bugs, feature requests or want to ask general software usage questions, you
can contact our support department.
Pressing  the  General  Support  button,  starts  a  new  email  message  that  will  be  sent  to  the
support team.

If  you  experience  any  problems  during  the  registration  process,  you  can  contact  our  sales
department.
Pressing  the Sales Support button,  starts  a new email  message  that  will  be  sent  to  the  sales
team.
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11.3 Check for Updates

 

You can manually check for updates from Help -> Check for Updates. 
In the Upgrade window, you can see if there are any updates available and what is new in the
update.

11.4 About

The  About  page  of  Backup4all  contains  information  about  the  version  and  edition  you  have
installed, as well as the information about the registration status. If Backup4all is registered, you
can  see  the  Registration  Name and  Registration  Key,  otherwise  it  will  show  as  UNREGISTERED
and mention the number of days left until the trial version expires.
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